aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/erlang/Makefile9
-rw-r--r--lang/erlang14/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 58e085c867f0..91879ac6ba8b 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -50,6 +50,10 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
+.if defined(WITH_ERLANG_THREADS)
+CONFIGURE_ARGS+= --enable-threads
+.endif
+
.if !defined(WITHOUT_JAVA)
# The Java applications that are part of the Erlang distribution are
# not strictly necessary - it is included for completeness sake. A
@@ -72,6 +76,11 @@ SCRIPT_ENV+= PATH=${PATH}:${JAVABINDIR}
post-patch:
@cd ${WRKSRC} && ${CAT} ${FILESDIR}/post-patch-configure | ${PATCH}
+pre-extract:
+.if !defined(WITH_ERLANG_THREADS)
+ @${ECHO_MSG} "You can enable support for threaded I/O by defining WITH_ERLANG_THREADS."
+.endif
+
pre-configure:
# Regenerate erts configuration script
cd ${WRKSRC}/erts && ${AUTOCONF}
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 58e085c867f0..91879ac6ba8b 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -50,6 +50,10 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
+.if defined(WITH_ERLANG_THREADS)
+CONFIGURE_ARGS+= --enable-threads
+.endif
+
.if !defined(WITHOUT_JAVA)
# The Java applications that are part of the Erlang distribution are
# not strictly necessary - it is included for completeness sake. A
@@ -72,6 +76,11 @@ SCRIPT_ENV+= PATH=${PATH}:${JAVABINDIR}
post-patch:
@cd ${WRKSRC} && ${CAT} ${FILESDIR}/post-patch-configure | ${PATCH}
+pre-extract:
+.if !defined(WITH_ERLANG_THREADS)
+ @${ECHO_MSG} "You can enable support for threaded I/O by defining WITH_ERLANG_THREADS."
+.endif
+
pre-configure:
# Regenerate erts configuration script
cd ${WRKSRC}/erts && ${AUTOCONF}