aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--math/Makefile2
-rw-r--r--math/elementary-calculator/Makefile (renamed from math/pantheon-calculator/Makefile)10
-rw-r--r--math/elementary-calculator/distinfo3
-rw-r--r--math/elementary-calculator/files/patch-src_MainWindow.vala28
-rw-r--r--math/elementary-calculator/pkg-descr (renamed from math/pantheon-calculator/pkg-descr)0
-rw-r--r--math/elementary-calculator/pkg-plist (renamed from math/pantheon-calculator/pkg-plist)0
-rw-r--r--math/pantheon-calculator/distinfo3
-rw-r--r--math/pantheon-calculator/files/patch-src_MainWindow.vala15
9 files changed, 38 insertions, 24 deletions
diff --git a/MOVED b/MOVED
index 3c279ca9b5b8..acd38dd2853a 100644
--- a/MOVED
+++ b/MOVED
@@ -17153,3 +17153,4 @@ graphics/magnum-examples||2022-05-17|Has expired: Depends on broken graphics/mag
graphics/magnum||2022-05-17|Has expired: Broken for more than a year
graphics/magnum-plugins||2022-05-17|Has expired: Depends on broken graphics/magnum
graphics/magnum-extras||2022-05-17|Has expired: Depends on broken graphics/magnum
+math/pantheon-calculator|math/elementary-calculator|2022-05-18|Switch to reverse domain name notation
diff --git a/math/Makefile b/math/Makefile
index b39bdf6119c2..1e497804a1b7 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -289,6 +289,7 @@
SUBDIR += eigen3
SUBDIR += eispack
SUBDIR += elemental
+ SUBDIR += elementary-calculator
SUBDIR += elpa
SUBDIR += emc2
SUBDIR += ensmallen
@@ -764,7 +765,6 @@
SUBDIR += p5-Text-AsciiTeX
SUBDIR += p5-bignum
SUBDIR += palp
- SUBDIR += pantheon-calculator
SUBDIR += pari
SUBDIR += pari_elldata
SUBDIR += pari_galdata
diff --git a/math/pantheon-calculator/Makefile b/math/elementary-calculator/Makefile
index 3eb461ef488b..51a01fd03077 100644
--- a/math/pantheon-calculator/Makefile
+++ b/math/elementary-calculator/Makefile
@@ -1,8 +1,7 @@
PORTNAME= calculator
-PORTVERSION= 1.7.2
+DISTVERSION= 2.0.0
CATEGORIES= math
-PKGNAMEPREFIX= pantheon-
-DIST_SUBDIR= pantheon
+PKGNAMEPREFIX= elementary-
MAINTAINER= duchateau.olivier@gmail.com
COMMENT= Simple calculator written in Vala
@@ -12,15 +11,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:lang/vala
LIB_DEPENDS= libgee-0.8.so:devel/libgee \
- libgranite.so:x11-toolkits/granite \
+ libgranite-7.so:x11-toolkits/granite7 \
libhandy-1.so:x11-toolkits/libhandy
USES= gettext gnome meson pkgconfig python:3.6+,build
-USE_GNOME= cairo gdkpixbuf2 glib20 gtk30
USE_GITHUB= yes
GH_ACCOUNT= elementary
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk40
+
GLIB_SCHEMAS= io.elementary.calculator.gschema.xml
.include <bsd.port.mk>
diff --git a/math/elementary-calculator/distinfo b/math/elementary-calculator/distinfo
new file mode 100644
index 000000000000..43d0053d9e47
--- /dev/null
+++ b/math/elementary-calculator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1652373931
+SHA256 (elementary-calculator-2.0.0_GH0.tar.gz) = bf4fefc9a526ad9e7c546374e764473e75aed77822bd0d3f7b706017181a4f1d
+SIZE (elementary-calculator-2.0.0_GH0.tar.gz) = 232133
diff --git a/math/elementary-calculator/files/patch-src_MainWindow.vala b/math/elementary-calculator/files/patch-src_MainWindow.vala
new file mode 100644
index 000000000000..09c28ab502d2
--- /dev/null
+++ b/math/elementary-calculator/files/patch-src_MainWindow.vala
@@ -0,0 +1,28 @@
+Replace missing icons (Adwaita)
+
+--- src/MainWindow.vala.orig 2022-05-10 20:12:35 UTC
++++ src/MainWindow.vala
+@@ -78,7 +78,7 @@ public class PantheonCalculator.MainWindow : Gtk.Appli
+ history = new List<History?> ();
+ position = 0;
+ button_extended = new Gtk.ToggleButton () {
+- icon_name = "pane-hide-symbolic",
++ icon_name = "pan-end-symbolic",
+ tooltip_text = _("Show extended functionality")
+ };
+ button_extended.toggled.connect (toggle_grid);
+@@ -731,12 +731,12 @@ public class PantheonCalculator.MainWindow : Gtk.Appli
+ position = entry.get_position ();
+ if (button.get_active ()) {
+ /* Show extended functionality */
+- button.icon_name = "pane-show-symbolic";
++ button.icon_name = "pan-start-symbolic";
+ button.tooltip_text = _("Hide extended functionality");
+ extended_revealer.reveal_child = true;
+ } else {
+ /* Hide extended functionality */
+- button.icon_name = "pane-hide-symbolic";
++ button.icon_name = "pan-end-symbolic";
+ button.tooltip_text = _("Show extended functionality");
+ extended_revealer.reveal_child = false;
+ }
diff --git a/math/pantheon-calculator/pkg-descr b/math/elementary-calculator/pkg-descr
index a0836d1e901d..a0836d1e901d 100644
--- a/math/pantheon-calculator/pkg-descr
+++ b/math/elementary-calculator/pkg-descr
diff --git a/math/pantheon-calculator/pkg-plist b/math/elementary-calculator/pkg-plist
index dc5345d20c8b..dc5345d20c8b 100644
--- a/math/pantheon-calculator/pkg-plist
+++ b/math/elementary-calculator/pkg-plist
diff --git a/math/pantheon-calculator/distinfo b/math/pantheon-calculator/distinfo
deleted file mode 100644
index 36f5305b4b59..000000000000
--- a/math/pantheon-calculator/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1639672237
-SHA256 (pantheon/elementary-calculator-1.7.2_GH0.tar.gz) = d296d06b36a0c7dd84e7e91e9801989e83312612d6ee6f0479030c1b340d397b
-SIZE (pantheon/elementary-calculator-1.7.2_GH0.tar.gz) = 229144
diff --git a/math/pantheon-calculator/files/patch-src_MainWindow.vala b/math/pantheon-calculator/files/patch-src_MainWindow.vala
deleted file mode 100644
index ee7a9ad7db1d..000000000000
--- a/math/pantheon-calculator/files/patch-src_MainWindow.vala
+++ /dev/null
@@ -1,15 +0,0 @@
-Replace missing icons (Adwaita)
-
---- src/MainWindow.vala.orig 2016-08-10 05:29:30 UTC
-+++ src/MainWindow.vala
-@@ -73,8 +73,8 @@ namespace PantheonCalculator {
- headerbar.set_title (_("Calculator"));
- set_titlebar (headerbar);
-
-- extended_img_1 = new Gtk.Image.from_icon_name ("pane-hide-symbolic", Gtk.IconSize.MENU);
-- extended_img_2 = new Gtk.Image.from_icon_name ("pane-show-symbolic", Gtk.IconSize.MENU);
-+ extended_img_1 = new Gtk.Image.from_icon_name ("pan-end-symbolic", Gtk.IconSize.MENU);
-+ extended_img_2 = new Gtk.Image.from_icon_name ("pan-start-symbolic", Gtk.IconSize.MENU);
-
- button_extended = new Gtk.ToggleButton ();
- button_extended.image = extended_img_1;