aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/py-s2/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/graphics/py-s2/Makefile b/graphics/py-s2/Makefile
index d6e12988ce20..2904aca8d112 100644
--- a/graphics/py-s2/Makefile
+++ b/graphics/py-s2/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= s2>=${PORTVERSION}:graphics/s2 \
swig:devel/swig
LIB_DEPENDS= libs2.so:graphics/s2
-USES= cmake compiler:c++11-lang localbase:ldflags python
+USES= cmake localbase:ldflags python
WRKSRC_SUBDIR= src/python
@@ -25,4 +25,12 @@ GH_ACCOUNT= google
GH_PROJECT= s2geometry
USE_GITHUB= yes
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
+
.include <bsd.port.mk>