aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/clanlib1/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/devel/clanlib1/Makefile b/devel/clanlib1/Makefile
index e984e612ff59..7b5d94daaa7d 100644
--- a/devel/clanlib1/Makefile
+++ b/devel/clanlib1/Makefile
@@ -20,15 +20,14 @@ LIB_DEPENDS= libpng.so:graphics/png \
libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg
-USES= alias gmake jpeg libtool localbase:ldflags pathfix \
+USES= alias gmake gl jpeg libtool localbase:ldflags pathfix \
pkgconfig tar:tgz
+USE_CXXSTD= c++98
USE_XORG= x11 xi xxf86vm
USE_LDCONFIG= yes
USE_SDL= gfx
USE_GL= gl glu
-CXXFLAGS+= -Wno-c++11-narrowing
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docs \
--enable-clanDisplay \