aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/libxine/Makefile5
-rw-r--r--graphics/libxine/distinfo2
-rw-r--r--graphics/libxine/files/patch-src:audio_out:audio_oss_out.c23
-rw-r--r--graphics/libxine/files/patch-src:video_out:video_out_sdl.c11
-rw-r--r--graphics/libxine/files/patch-src:xine-engine:Makefile.am12
-rw-r--r--graphics/libxine/files/patch-src:xine-utils:Makefile.am12
-rw-r--r--graphics/libxine/pkg-plist12
-rw-r--r--multimedia/libxine/Makefile5
-rw-r--r--multimedia/libxine/distinfo2
-rw-r--r--multimedia/libxine/files/patch-src:audio_out:audio_oss_out.c23
-rw-r--r--multimedia/libxine/files/patch-src:video_out:video_out_sdl.c11
-rw-r--r--multimedia/libxine/files/patch-src:xine-engine:Makefile.am12
-rw-r--r--multimedia/libxine/files/patch-src:xine-utils:Makefile.am12
-rw-r--r--multimedia/libxine/pkg-plist12
14 files changed, 72 insertions, 82 deletions
diff --git a/graphics/libxine/Makefile b/graphics/libxine/Makefile
index aae01bffb4e9..a3c625dbe784 100644
--- a/graphics/libxine/Makefile
+++ b/graphics/libxine/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xine
-PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTVERSION= 0.9.10
CATEGORIES= graphics
MASTER_SITES= http://xine.sourceforge.net/files/ \
${MASTER_SITE_SOURCEFORGE}
@@ -21,6 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libavcodec.a:${PORTSDIR}/graphics/ffmpeg \
${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
aa.1:${PORTSDIR}/graphics/aalib \
+ SDL-1.1:${PORTSDIR}/devel/sdl12 \
intl.2:${PORTSDIR}/devel/gettext \
iconv.3:${PORTSDIR}/converters/libiconv
@@ -34,6 +34,7 @@ USE_AUTOMAKE= yes
USE_MESA= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ SDL_CONFIG="${LOCALBASE}/bin/sdl11-config" \
THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
THREAD_LIBS="${PTHREAD_LIBS}" \
X_EXTRA_LIBS="-lGL -lGLU -lXext -lX11 -lm"
diff --git a/graphics/libxine/distinfo b/graphics/libxine/distinfo
index a9226d757fa7..6e360cf0a3aa 100644
--- a/graphics/libxine/distinfo
+++ b/graphics/libxine/distinfo
@@ -1 +1 @@
-MD5 (xine-lib-0.9.9.tar.gz) = fd628882e9140311868f28da929fbd75
+MD5 (xine-lib-0.9.10.tar.gz) = 2f17619b58b2e6c84c1421ed36045983
diff --git a/graphics/libxine/files/patch-src:audio_out:audio_oss_out.c b/graphics/libxine/files/patch-src:audio_out:audio_oss_out.c
index 3f72f84ce062..dcfab11ae62b 100644
--- a/graphics/libxine/files/patch-src:audio_out:audio_oss_out.c
+++ b/graphics/libxine/files/patch-src:audio_out:audio_oss_out.c
@@ -1,14 +1,11 @@
---- src/audio_out/audio_oss_out.c.old Tue Jan 15 21:55:15 2002
-+++ src/audio_out/audio_oss_out.c Thu Apr 11 13:27:47 2002
-@@ -49,7 +49,11 @@
- #if defined(__OpenBSD__)
- #include <soundcard.h>
- #elif defined(__FreeBSD__)
-+#if __FreeBSD__ > 3
-+#include <sys/soundcard.h>
-+#else
- #include <machine/soundcard.h>
-+#endif
+--- src/audio_out/audio_oss_out.c.orig Sun Jun 2 01:54:46 2002
++++ src/audio_out/audio_oss_out.c Sun Jun 2 01:55:37 2002
+@@ -51,6 +51,8 @@
+ #elif defined (__FreeBSD__)
+ # if __FreeBSD__ < 4
+ # include <machine/soundcard.h>
++# else
++# include <sys/soundcard.h>
+ # endif
#else
- #if defined(__linux__)
- #include <linux/config.h> /* Check for DEVFS */
+ # if defined(__linux__)
diff --git a/graphics/libxine/files/patch-src:video_out:video_out_sdl.c b/graphics/libxine/files/patch-src:video_out:video_out_sdl.c
new file mode 100644
index 000000000000..ae6f697f1859
--- /dev/null
+++ b/graphics/libxine/files/patch-src:video_out:video_out_sdl.c
@@ -0,0 +1,11 @@
+--- src/video_out/video_out_sdl.c.orig Sun Jun 2 02:04:24 2002
++++ src/video_out/video_out_sdl.c Sun Jun 2 02:04:30 2002
+@@ -47,7 +47,7 @@
+ #include <string.h>
+ #include <inttypes.h>
+ #include <math.h>
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+
+ #include "video_out.h"
+ #include "xine_internal.h"
diff --git a/graphics/libxine/files/patch-src:xine-engine:Makefile.am b/graphics/libxine/files/patch-src:xine-engine:Makefile.am
deleted file mode 100644
index 6eac654e2594..000000000000
--- a/graphics/libxine/files/patch-src:xine-engine:Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/xine-engine/Makefile.am.orig Sat Dec 29 02:31:25 2001
-+++ src/xine-engine/Makefile.am Thu Jan 24 13:42:50 2002
-@@ -15,8 +15,7 @@
- libxine_la_LIBADD = $(THREAD_LIBS) $(DYNAMIC_LD_LIBS) @INTLLIBS@ -lm -lz
-
- libxine_la_LDFLAGS = \
-- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-- -release $(LT_RELEASE)
-+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
- include_HEADERS = buffer.h metronom.h configfile.h \
- audio_out.h resample.h video_out.h xine_internal.h spu_decoder.h \
diff --git a/graphics/libxine/files/patch-src:xine-utils:Makefile.am b/graphics/libxine/files/patch-src:xine-utils:Makefile.am
deleted file mode 100644
index b32ff6a3f970..000000000000
--- a/graphics/libxine/files/patch-src:xine-utils:Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/xine-utils/Makefile.am.orig Thu Nov 8 02:41:14 2001
-+++ src/xine-utils/Makefile.am Thu Nov 8 02:41:46 2001
-@@ -16,8 +16,7 @@
- -lm
-
- libxineutils_la_LDFLAGS = \
-- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-- -release $(LT_RELEASE)
-+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
- include_HEADERS = attributes.h cpu_accel.h memcpy.h utils.h monitor.h
-
diff --git a/graphics/libxine/pkg-plist b/graphics/libxine/pkg-plist
index eb72b91af124..57d5df51a92d 100644
--- a/graphics/libxine/pkg-plist
+++ b/graphics/libxine/pkg-plist
@@ -20,6 +20,8 @@ include/xine/video_overlay.h
include/xine/xine_internal.h
include/xine/xineintl.h
include/xine/xineutils.h
+include/xine/xmllexer.h
+include/xine/xmlparser.h
include/xine.h
lib/libxine.so
lib/libxine.so.0
@@ -29,12 +31,15 @@ lib/libxineutils.so.0
lib/xine/plugins/xineplug_ao_out_esd.so
lib/xine/plugins/xineplug_ao_out_oss.so
lib/xine/plugins/xineplug_decode_a52.so
+lib/xine/plugins/xineplug_decode_cinepak.so
+lib/xine/plugins/xineplug_decode_cyuv.so
lib/xine/plugins/xineplug_decode_divx4.so
lib/xine/plugins/xineplug_decode_dts.so
lib/xine/plugins/xineplug_decode_ff.so
lib/xine/plugins/xineplug_decode_lpcm.so
lib/xine/plugins/xineplug_decode_mad.so
lib/xine/plugins/xineplug_decode_mpeg2.so
+lib/xine/plugins/xineplug_decode_msvc.so
lib/xine/plugins/xineplug_decode_spu.so
lib/xine/plugins/xineplug_decode_spucc.so
lib/xine/plugins/xineplug_decode_sputext.so
@@ -61,6 +66,7 @@ lib/xine/plugins/xineplug_inp_stdin_fifo.so
lib/xine/plugins/xineplug_inp_vcd.so
lib/xine/plugins/xineplug_vo_out_aa.so
lib/xine/plugins/xineplug_vo_out_opengl.so
+lib/xine/plugins/xineplug_vo_out_sdl.so
lib/xine/plugins/xineplug_vo_out_syncfb.so
lib/xine/plugins/xineplug_vo_out_xshm.so
%%HAVE_LIBXV%%lib/xine/plugins/xineplug_vo_out_xv.so
@@ -136,12 +142,16 @@ share/xine/fonts/sans-16.xinefont.gz
share/xine/fonts/sans-20.xinefont.gz
share/xine/fonts/sans-24.xinefont.gz
share/xine/fonts/sans-32.xinefont.gz
+share/xine/fonts/sanshu-16.xinefont.gz
+share/xine/fonts/sanshu-20.xinefont.gz
+share/xine/fonts/sanshu-24.xinefont.gz
+share/xine/fonts/sanshu-32.xinefont.gz
share/xine/fonts/serif-16.xinefont.gz
share/xine/fonts/serif-20.xinefont.gz
share/xine/fonts/serif-24.xinefont.gz
share/xine/fonts/serif-32.xinefont.gz
+share/xine/skins/xine_logo.mpg
share/xine/skins/xine_logo.png
-share/xine/skins/xine_logo.zyuy2
@dirrm include/xine
@dirrm lib/xine/plugins
@dirrm lib/xine
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index aae01bffb4e9..a3c625dbe784 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xine
-PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTVERSION= 0.9.10
CATEGORIES= graphics
MASTER_SITES= http://xine.sourceforge.net/files/ \
${MASTER_SITE_SOURCEFORGE}
@@ -21,6 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libavcodec.a:${PORTSDIR}/graphics/ffmpeg \
${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
aa.1:${PORTSDIR}/graphics/aalib \
+ SDL-1.1:${PORTSDIR}/devel/sdl12 \
intl.2:${PORTSDIR}/devel/gettext \
iconv.3:${PORTSDIR}/converters/libiconv
@@ -34,6 +34,7 @@ USE_AUTOMAKE= yes
USE_MESA= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ SDL_CONFIG="${LOCALBASE}/bin/sdl11-config" \
THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
THREAD_LIBS="${PTHREAD_LIBS}" \
X_EXTRA_LIBS="-lGL -lGLU -lXext -lX11 -lm"
diff --git a/multimedia/libxine/distinfo b/multimedia/libxine/distinfo
index a9226d757fa7..6e360cf0a3aa 100644
--- a/multimedia/libxine/distinfo
+++ b/multimedia/libxine/distinfo
@@ -1 +1 @@
-MD5 (xine-lib-0.9.9.tar.gz) = fd628882e9140311868f28da929fbd75
+MD5 (xine-lib-0.9.10.tar.gz) = 2f17619b58b2e6c84c1421ed36045983
diff --git a/multimedia/libxine/files/patch-src:audio_out:audio_oss_out.c b/multimedia/libxine/files/patch-src:audio_out:audio_oss_out.c
index 3f72f84ce062..dcfab11ae62b 100644
--- a/multimedia/libxine/files/patch-src:audio_out:audio_oss_out.c
+++ b/multimedia/libxine/files/patch-src:audio_out:audio_oss_out.c
@@ -1,14 +1,11 @@
---- src/audio_out/audio_oss_out.c.old Tue Jan 15 21:55:15 2002
-+++ src/audio_out/audio_oss_out.c Thu Apr 11 13:27:47 2002
-@@ -49,7 +49,11 @@
- #if defined(__OpenBSD__)
- #include <soundcard.h>
- #elif defined(__FreeBSD__)
-+#if __FreeBSD__ > 3
-+#include <sys/soundcard.h>
-+#else
- #include <machine/soundcard.h>
-+#endif
+--- src/audio_out/audio_oss_out.c.orig Sun Jun 2 01:54:46 2002
++++ src/audio_out/audio_oss_out.c Sun Jun 2 01:55:37 2002
+@@ -51,6 +51,8 @@
+ #elif defined (__FreeBSD__)
+ # if __FreeBSD__ < 4
+ # include <machine/soundcard.h>
++# else
++# include <sys/soundcard.h>
+ # endif
#else
- #if defined(__linux__)
- #include <linux/config.h> /* Check for DEVFS */
+ # if defined(__linux__)
diff --git a/multimedia/libxine/files/patch-src:video_out:video_out_sdl.c b/multimedia/libxine/files/patch-src:video_out:video_out_sdl.c
new file mode 100644
index 000000000000..ae6f697f1859
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:video_out:video_out_sdl.c
@@ -0,0 +1,11 @@
+--- src/video_out/video_out_sdl.c.orig Sun Jun 2 02:04:24 2002
++++ src/video_out/video_out_sdl.c Sun Jun 2 02:04:30 2002
+@@ -47,7 +47,7 @@
+ #include <string.h>
+ #include <inttypes.h>
+ #include <math.h>
+-#include <SDL/SDL.h>
++#include <SDL11/SDL.h>
+
+ #include "video_out.h"
+ #include "xine_internal.h"
diff --git a/multimedia/libxine/files/patch-src:xine-engine:Makefile.am b/multimedia/libxine/files/patch-src:xine-engine:Makefile.am
deleted file mode 100644
index 6eac654e2594..000000000000
--- a/multimedia/libxine/files/patch-src:xine-engine:Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/xine-engine/Makefile.am.orig Sat Dec 29 02:31:25 2001
-+++ src/xine-engine/Makefile.am Thu Jan 24 13:42:50 2002
-@@ -15,8 +15,7 @@
- libxine_la_LIBADD = $(THREAD_LIBS) $(DYNAMIC_LD_LIBS) @INTLLIBS@ -lm -lz
-
- libxine_la_LDFLAGS = \
-- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-- -release $(LT_RELEASE)
-+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
- include_HEADERS = buffer.h metronom.h configfile.h \
- audio_out.h resample.h video_out.h xine_internal.h spu_decoder.h \
diff --git a/multimedia/libxine/files/patch-src:xine-utils:Makefile.am b/multimedia/libxine/files/patch-src:xine-utils:Makefile.am
deleted file mode 100644
index b32ff6a3f970..000000000000
--- a/multimedia/libxine/files/patch-src:xine-utils:Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/xine-utils/Makefile.am.orig Thu Nov 8 02:41:14 2001
-+++ src/xine-utils/Makefile.am Thu Nov 8 02:41:46 2001
-@@ -16,8 +16,7 @@
- -lm
-
- libxineutils_la_LDFLAGS = \
-- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-- -release $(LT_RELEASE)
-+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
- include_HEADERS = attributes.h cpu_accel.h memcpy.h utils.h monitor.h
-
diff --git a/multimedia/libxine/pkg-plist b/multimedia/libxine/pkg-plist
index eb72b91af124..57d5df51a92d 100644
--- a/multimedia/libxine/pkg-plist
+++ b/multimedia/libxine/pkg-plist
@@ -20,6 +20,8 @@ include/xine/video_overlay.h
include/xine/xine_internal.h
include/xine/xineintl.h
include/xine/xineutils.h
+include/xine/xmllexer.h
+include/xine/xmlparser.h
include/xine.h
lib/libxine.so
lib/libxine.so.0
@@ -29,12 +31,15 @@ lib/libxineutils.so.0
lib/xine/plugins/xineplug_ao_out_esd.so
lib/xine/plugins/xineplug_ao_out_oss.so
lib/xine/plugins/xineplug_decode_a52.so
+lib/xine/plugins/xineplug_decode_cinepak.so
+lib/xine/plugins/xineplug_decode_cyuv.so
lib/xine/plugins/xineplug_decode_divx4.so
lib/xine/plugins/xineplug_decode_dts.so
lib/xine/plugins/xineplug_decode_ff.so
lib/xine/plugins/xineplug_decode_lpcm.so
lib/xine/plugins/xineplug_decode_mad.so
lib/xine/plugins/xineplug_decode_mpeg2.so
+lib/xine/plugins/xineplug_decode_msvc.so
lib/xine/plugins/xineplug_decode_spu.so
lib/xine/plugins/xineplug_decode_spucc.so
lib/xine/plugins/xineplug_decode_sputext.so
@@ -61,6 +66,7 @@ lib/xine/plugins/xineplug_inp_stdin_fifo.so
lib/xine/plugins/xineplug_inp_vcd.so
lib/xine/plugins/xineplug_vo_out_aa.so
lib/xine/plugins/xineplug_vo_out_opengl.so
+lib/xine/plugins/xineplug_vo_out_sdl.so
lib/xine/plugins/xineplug_vo_out_syncfb.so
lib/xine/plugins/xineplug_vo_out_xshm.so
%%HAVE_LIBXV%%lib/xine/plugins/xineplug_vo_out_xv.so
@@ -136,12 +142,16 @@ share/xine/fonts/sans-16.xinefont.gz
share/xine/fonts/sans-20.xinefont.gz
share/xine/fonts/sans-24.xinefont.gz
share/xine/fonts/sans-32.xinefont.gz
+share/xine/fonts/sanshu-16.xinefont.gz
+share/xine/fonts/sanshu-20.xinefont.gz
+share/xine/fonts/sanshu-24.xinefont.gz
+share/xine/fonts/sanshu-32.xinefont.gz
share/xine/fonts/serif-16.xinefont.gz
share/xine/fonts/serif-20.xinefont.gz
share/xine/fonts/serif-24.xinefont.gz
share/xine/fonts/serif-32.xinefont.gz
+share/xine/skins/xine_logo.mpg
share/xine/skins/xine_logo.png
-share/xine/skins/xine_logo.zyuy2
@dirrm include/xine
@dirrm lib/xine/plugins
@dirrm lib/xine