aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-cogdumper/Makefile24
-rw-r--r--graphics/py-cogdumper/distinfo3
-rw-r--r--graphics/py-cogdumper/pkg-descr9
4 files changed, 37 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 983c1c51c20d..b515a21d08cd 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -790,6 +790,7 @@
SUBDIR += py-cairocffi
SUBDIR += py-cairosvg
SUBDIR += py-cartopy
+ SUBDIR += py-cogdumper
SUBDIR += py-colour
SUBDIR += py-descartes
SUBDIR += py-django-easy-thumbnails
diff --git a/graphics/py-cogdumper/Makefile b/graphics/py-cogdumper/Makefile
new file mode 100644
index 000000000000..22e60af3fabf
--- /dev/null
+++ b/graphics/py-cogdumper/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cogdumper
+PORTVERSION= 1.1.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Cloud Optimized GeoTIFF (COG) dumper
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>=1.6.2:www/py-boto3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=6.7:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.18.4:www/py-requests@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-cogdumper/distinfo b/graphics/py-cogdumper/distinfo
new file mode 100644
index 000000000000..ffc5e8402d6e
--- /dev/null
+++ b/graphics/py-cogdumper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588930301
+SHA256 (cogdumper-1.1.0.tar.gz) = 75afe1ed636f4b5b8b540832f464dcc4d5fa3e8594d58bf8f27aa4d12e3ba164
+SIZE (cogdumper-1.1.0.tar.gz) = 9340
diff --git a/graphics/py-cogdumper/pkg-descr b/graphics/py-cogdumper/pkg-descr
new file mode 100644
index 000000000000..e3c9958ef90e
--- /dev/null
+++ b/graphics/py-cogdumper/pkg-descr
@@ -0,0 +1,9 @@
+COG Dumper is a python utility to extract a tile from a Cloud Optimized GeoTIFF
+(COG) without decompressing the contained data. Tiff data can be hosted locally,
+on a web server or S3.
+
+This can be useful for serving compressed tiles from a TIFF without invoking
+Rasterio and GDAL. This utility has been tested with Tiff that have JPEG
+compression.
+
+WWW: https://github.com/mapbox/COGDumper