aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/linux-opera-devel/Makefile9
-rw-r--r--www/linux-opera-devel/distinfo6
-rw-r--r--www/linux-opera-devel/files/patch-ini::pluginpath.ini14
-rw-r--r--www/linux-opera-devel/files/patch-install.sh29
-rw-r--r--www/linux-opera-devel/pkg-message2
-rw-r--r--www/linux-opera/Makefile9
-rw-r--r--www/linux-opera/distinfo6
-rw-r--r--www/linux-opera/files/patch-ini::pluginpath.ini14
-rw-r--r--www/linux-opera/files/patch-install.sh29
-rw-r--r--www/linux-opera/pkg-message2
10 files changed, 50 insertions, 70 deletions
diff --git a/www/linux-opera-devel/Makefile b/www/linux-opera-devel/Makefile
index 910071f0e5de..e2a9d5584bd8 100644
--- a/www/linux-opera-devel/Makefile
+++ b/www/linux-opera-devel/Makefile
@@ -7,7 +7,6 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
-PORTREVISION= 2
CATEGORIES= www linux
MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
ftp://ftp.sunet.se/pub/www/clients/Opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
@@ -35,9 +34,9 @@ ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
-OPERA_VER= 9.20
-OPERA_DATE= 20070409
-OPERA_BUILD= 638
+OPERA_VER= 9.21
+OPERA_DATE= 20070510
+OPERA_BUILD= 641
DATADIR= ${PREFIX}/share/${UNIQUENAME}
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
@@ -45,7 +44,7 @@ MAN1= linux-opera.1
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/install.sh ${WRKSRC}/ini/pluginpath.ini
@${FIND} ${WRKSRC} -name '*.orig' -delete
@${FIND} ${WRKSRC} -name '*.bak' -delete
diff --git a/www/linux-opera-devel/distinfo b/www/linux-opera-devel/distinfo
index da121e2c8718..5b4cffaac443 100644
--- a/www/linux-opera-devel/distinfo
+++ b/www/linux-opera-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (opera-9.20-20070409.1-static-qt.i386-en.tar.bz2) = dd5365a5ca0f31b373deafdb80a17ac7
-SHA256 (opera-9.20-20070409.1-static-qt.i386-en.tar.bz2) = 4ea0e5d407e11e3df247a643412eac19962c923177f2f22c23566a776dc8945f
-SIZE (opera-9.20-20070409.1-static-qt.i386-en.tar.bz2) = 6790435
+MD5 (opera-9.21-20070510.1-static-qt.i386-en.tar.bz2) = 42e3039163f7bbfd49119860cfac60d0
+SHA256 (opera-9.21-20070510.1-static-qt.i386-en.tar.bz2) = fdf6766a0408d7030f7a930576fd70aff78e2b66fe2bbe8ca1af8da4bace95cd
+SIZE (opera-9.21-20070510.1-static-qt.i386-en.tar.bz2) = 6785626
diff --git a/www/linux-opera-devel/files/patch-ini::pluginpath.ini b/www/linux-opera-devel/files/patch-ini::pluginpath.ini
index 99b2d56ba319..dfe5782ead26 100644
--- a/www/linux-opera-devel/files/patch-ini::pluginpath.ini
+++ b/www/linux-opera-devel/files/patch-ini::pluginpath.ini
@@ -1,6 +1,6 @@
---- ini/pluginpath.ini.orig Wed Apr 11 12:37:42 2007
-+++ ini/pluginpath.ini Wed Apr 11 12:40:18 2007
-@@ -2,62 +2,34 @@
+--- ini/pluginpath.ini.orig Thu May 10 12:01:53 2007
++++ ini/pluginpath.ini Fri May 25 12:46:15 2007
+@@ -2,62 +2,26 @@
; Do not edit this file while Opera is running
; This file is stored in UTF-8 encoding
@@ -46,15 +46,12 @@
-/usr/lib/RealPlayer8=1
-/usr/lib/realplay=1
+%%LOCALBASE%%/Acrobat5/Browsers/intellinux=1
-+%%X11BASE%%/Acrobat5/Browsers/intellinux=1
; Flash
-/usr/lib/flash-plugin=1
-/usr/lib/flashplugin-nonfree=1
+%%LOCALBASE%%/lib/linux-flashplugin6=1
+%%LOCALBASE%%/lib/linux-flashplugin7=1
-+%%X11BASE%%/lib/linux-flashplugin6=1
-+%%X11BASE%%/lib/linux-flashplugin7=1
-; Netscape Plug-in Paths
-$HOME/.netscape6/plugins=1
@@ -67,8 +64,6 @@
+; Realplayer
+%%LOCALBASE%%/lib/RealPlayer=1
+%%LOCALBASE%%/lib/RealPlayer/plugins=1
-+%%X11BASE%%/lib/RealPlayer=1
-+%%X11BASE%%/lib/RealPlayer/plugins=1
; Since Mozilla supports NS plugins, there might
; be some in the Mozilla plugin directory.
@@ -77,11 +72,8 @@
-/usr/lib64/browser-plugins=1
-/usr/lib/browser-plugins=1
+%%LOCALBASE%%/lib/linux-mozilla/plugins=1
-+%%X11BASE%%/lib/linux-mozilla/plugins=1
+
+; Global plugins path in FreeBSD. Need this for
+; the Adobe Acrobat7 and other plugins too.
+%%LOCALBASE%%/lib/browser_linux_plugins=1
-+%%X11BASE%%/lib/browser_linux_plugins=1
+%%LOCALBASE%%/lib/npapi/symlinks/linux-opera=1
-+%%X11BASE%%/lib/npapi/symlinks/linux-opera=1
diff --git a/www/linux-opera-devel/files/patch-install.sh b/www/linux-opera-devel/files/patch-install.sh
index 3be9cd36aa4c..cbdf7d7e25e7 100644
--- a/www/linux-opera-devel/files/patch-install.sh
+++ b/www/linux-opera-devel/files/patch-install.sh
@@ -1,5 +1,5 @@
---- install.sh.orig Mon Apr 9 10:57:12 2007
-+++ install.sh Fri Apr 13 20:17:57 2007
+--- install.sh.orig Thu May 10 12:01:53 2007
++++ install.sh Fri May 25 12:47:45 2007
@@ -805,10 +805,9 @@
case "${machine}:${os}" in
x86:Linux|x86_64:Linux|x86:AnyBSD|x86_64:AnyBSD|x86:OpenBSD)
@@ -135,7 +135,7 @@
; do
for PREFIX in \${PREFIXES}; do
if test -f \"\${PREFIX}/\${SUNJAVA}/lib/${wrapper_sunjava_machine}/libjava.so\"; then OPERA_JAVA_DIR=\"\${PREFIX}/\${SUNJAVA}/lib/${wrapper_sunjava_machine}\" && break; fi
-@@ -1037,11 +996,8 @@
+@@ -1037,11 +996,7 @@
# Acrobat Reader
for BINDIR in \\
@@ -145,11 +145,10 @@
- /opt/Acrobat[45]/bin \\
- /usr/Acrobat[45]/bin \\
+ %%LOCALBASE%%/Acrobat5/bin \\
-+ %%X11BASE%%/Acrobat5/bin \\
; do
if test -d \${BINDIR} ; then PATH=\${PATH}:\${BINDIR}; fi
done
-@@ -1063,13 +1019,6 @@
+@@ -1063,13 +1018,6 @@
done"
case "${os}" in
@@ -163,7 +162,7 @@
SunOS)
wrapper_contain="${wrapper_contain}
-@@ -1098,7 +1047,7 @@
+@@ -1098,7 +1046,7 @@
};
// Opera package classes get all permissions
@@ -172,7 +171,7 @@
permission java.security.AllPermission;
};
-@@ -1167,7 +1116,7 @@
+@@ -1167,7 +1115,7 @@
chop "${OPERADESTDIR}" "str_localdirshare"
chop "${OPERADESTDIR}" "str_localdirplugin"
@@ -181,7 +180,7 @@
# Executable
debug_msg 1 "Executable"
-@@ -1201,7 +1150,7 @@
+@@ -1201,7 +1149,7 @@
#cp $cpv $cpf wrapper.sh $wrapper_dir/opera
generate_wrapper
@@ -190,7 +189,7 @@
# Manual page
debug_msg 1 "Manual page"
-@@ -1210,7 +1159,7 @@
+@@ -1210,7 +1158,7 @@
chmod $chmodv 755 ${man_dir}
mkdir $mkdirv $mkdirp ${man_dir}/man1
chmod $chmodv 755 ${man_dir}/man1
@@ -199,7 +198,7 @@
# Documentation
debug_msg 1 "Documentation"
-@@ -1242,13 +1191,6 @@
+@@ -1242,13 +1190,6 @@
mkdir $mkdirv $mkdirp $share_dir/ini/
chmod $chmodv 755 $share_dir/ini
cp $cpv $cpf $cpR ini/* $share_dir/ini/
@@ -213,7 +212,7 @@
fi
mkdir $mkdirv $mkdirp $share_dir/locale/
-@@ -1340,43 +1282,11 @@
+@@ -1340,43 +1281,11 @@
if test -z "${OPERADESTDIR}"
then
@@ -258,7 +257,7 @@
fi
fi # OPERADESTDIR
-@@ -1428,19 +1338,19 @@
+@@ -1428,19 +1337,19 @@
# arg1 = location
# arg2 = type
@@ -281,7 +280,7 @@
Name[af]=opera
Name[eo]=Opero
Name[zu]=I Opera
-@@ -1464,7 +1374,7 @@
+@@ -1464,7 +1373,7 @@
GenericName[ven]=Buronza ya Webu
GenericName[xh]=Umkhangeli Zincwadi Zokubhaliweyo
GenericName[zu]=Umkhangeli zincwadi we Web
@@ -290,7 +289,7 @@
Terminal=false"
# Application is not a category, according to
-@@ -1479,25 +1389,26 @@
+@@ -1479,25 +1388,26 @@
if test "${2}" = "xdg"; then
desktop_contain="${desktop_contain}
Categories=Application;Qt;Network;WebBrowser;X-Ximian-Main;X-Ximian-Toplevel
@@ -323,7 +322,7 @@
echo "${desktop_contain}" > ${desktop_file}
chmod $chmodv 644 ${desktop_file}
-@@ -1528,55 +1439,28 @@
+@@ -1528,55 +1438,28 @@
debug_msg 0 "in icons()"
diff --git a/www/linux-opera-devel/pkg-message b/www/linux-opera-devel/pkg-message
index f55552e917ce..a8a402ef412f 100644
--- a/www/linux-opera-devel/pkg-message
+++ b/www/linux-opera-devel/pkg-message
@@ -1,5 +1,5 @@
##
-Changelog for 9.20 Final: http://www.opera.com/docs/changelogs/linux/920/
+Changelog for 9.21 Final: http://www.opera.com/docs/changelogs/linux/921/
If you are upgrade from version 7.x or below, it is recommend for you to
backup your personal "~/.linux-opera" directory and remove it. As for the
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index 910071f0e5de..e2a9d5584bd8 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -7,7 +7,6 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
-PORTREVISION= 2
CATEGORIES= www linux
MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
ftp://ftp.sunet.se/pub/www/clients/Opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
@@ -35,9 +34,9 @@ ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
-OPERA_VER= 9.20
-OPERA_DATE= 20070409
-OPERA_BUILD= 638
+OPERA_VER= 9.21
+OPERA_DATE= 20070510
+OPERA_BUILD= 641
DATADIR= ${PREFIX}/share/${UNIQUENAME}
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
@@ -45,7 +44,7 @@ MAN1= linux-opera.1
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/install.sh ${WRKSRC}/ini/pluginpath.ini
@${FIND} ${WRKSRC} -name '*.orig' -delete
@${FIND} ${WRKSRC} -name '*.bak' -delete
diff --git a/www/linux-opera/distinfo b/www/linux-opera/distinfo
index da121e2c8718..5b4cffaac443 100644
--- a/www/linux-opera/distinfo
+++ b/www/linux-opera/distinfo
@@ -1,3 +1,3 @@
-MD5 (opera-9.20-20070409.1-static-qt.i386-en.tar.bz2) = dd5365a5ca0f31b373deafdb80a17ac7
-SHA256 (opera-9.20-20070409.1-static-qt.i386-en.tar.bz2) = 4ea0e5d407e11e3df247a643412eac19962c923177f2f22c23566a776dc8945f
-SIZE (opera-9.20-20070409.1-static-qt.i386-en.tar.bz2) = 6790435
+MD5 (opera-9.21-20070510.1-static-qt.i386-en.tar.bz2) = 42e3039163f7bbfd49119860cfac60d0
+SHA256 (opera-9.21-20070510.1-static-qt.i386-en.tar.bz2) = fdf6766a0408d7030f7a930576fd70aff78e2b66fe2bbe8ca1af8da4bace95cd
+SIZE (opera-9.21-20070510.1-static-qt.i386-en.tar.bz2) = 6785626
diff --git a/www/linux-opera/files/patch-ini::pluginpath.ini b/www/linux-opera/files/patch-ini::pluginpath.ini
index 99b2d56ba319..dfe5782ead26 100644
--- a/www/linux-opera/files/patch-ini::pluginpath.ini
+++ b/www/linux-opera/files/patch-ini::pluginpath.ini
@@ -1,6 +1,6 @@
---- ini/pluginpath.ini.orig Wed Apr 11 12:37:42 2007
-+++ ini/pluginpath.ini Wed Apr 11 12:40:18 2007
-@@ -2,62 +2,34 @@
+--- ini/pluginpath.ini.orig Thu May 10 12:01:53 2007
++++ ini/pluginpath.ini Fri May 25 12:46:15 2007
+@@ -2,62 +2,26 @@
; Do not edit this file while Opera is running
; This file is stored in UTF-8 encoding
@@ -46,15 +46,12 @@
-/usr/lib/RealPlayer8=1
-/usr/lib/realplay=1
+%%LOCALBASE%%/Acrobat5/Browsers/intellinux=1
-+%%X11BASE%%/Acrobat5/Browsers/intellinux=1
; Flash
-/usr/lib/flash-plugin=1
-/usr/lib/flashplugin-nonfree=1
+%%LOCALBASE%%/lib/linux-flashplugin6=1
+%%LOCALBASE%%/lib/linux-flashplugin7=1
-+%%X11BASE%%/lib/linux-flashplugin6=1
-+%%X11BASE%%/lib/linux-flashplugin7=1
-; Netscape Plug-in Paths
-$HOME/.netscape6/plugins=1
@@ -67,8 +64,6 @@
+; Realplayer
+%%LOCALBASE%%/lib/RealPlayer=1
+%%LOCALBASE%%/lib/RealPlayer/plugins=1
-+%%X11BASE%%/lib/RealPlayer=1
-+%%X11BASE%%/lib/RealPlayer/plugins=1
; Since Mozilla supports NS plugins, there might
; be some in the Mozilla plugin directory.
@@ -77,11 +72,8 @@
-/usr/lib64/browser-plugins=1
-/usr/lib/browser-plugins=1
+%%LOCALBASE%%/lib/linux-mozilla/plugins=1
-+%%X11BASE%%/lib/linux-mozilla/plugins=1
+
+; Global plugins path in FreeBSD. Need this for
+; the Adobe Acrobat7 and other plugins too.
+%%LOCALBASE%%/lib/browser_linux_plugins=1
-+%%X11BASE%%/lib/browser_linux_plugins=1
+%%LOCALBASE%%/lib/npapi/symlinks/linux-opera=1
-+%%X11BASE%%/lib/npapi/symlinks/linux-opera=1
diff --git a/www/linux-opera/files/patch-install.sh b/www/linux-opera/files/patch-install.sh
index 3be9cd36aa4c..cbdf7d7e25e7 100644
--- a/www/linux-opera/files/patch-install.sh
+++ b/www/linux-opera/files/patch-install.sh
@@ -1,5 +1,5 @@
---- install.sh.orig Mon Apr 9 10:57:12 2007
-+++ install.sh Fri Apr 13 20:17:57 2007
+--- install.sh.orig Thu May 10 12:01:53 2007
++++ install.sh Fri May 25 12:47:45 2007
@@ -805,10 +805,9 @@
case "${machine}:${os}" in
x86:Linux|x86_64:Linux|x86:AnyBSD|x86_64:AnyBSD|x86:OpenBSD)
@@ -135,7 +135,7 @@
; do
for PREFIX in \${PREFIXES}; do
if test -f \"\${PREFIX}/\${SUNJAVA}/lib/${wrapper_sunjava_machine}/libjava.so\"; then OPERA_JAVA_DIR=\"\${PREFIX}/\${SUNJAVA}/lib/${wrapper_sunjava_machine}\" && break; fi
-@@ -1037,11 +996,8 @@
+@@ -1037,11 +996,7 @@
# Acrobat Reader
for BINDIR in \\
@@ -145,11 +145,10 @@
- /opt/Acrobat[45]/bin \\
- /usr/Acrobat[45]/bin \\
+ %%LOCALBASE%%/Acrobat5/bin \\
-+ %%X11BASE%%/Acrobat5/bin \\
; do
if test -d \${BINDIR} ; then PATH=\${PATH}:\${BINDIR}; fi
done
-@@ -1063,13 +1019,6 @@
+@@ -1063,13 +1018,6 @@
done"
case "${os}" in
@@ -163,7 +162,7 @@
SunOS)
wrapper_contain="${wrapper_contain}
-@@ -1098,7 +1047,7 @@
+@@ -1098,7 +1046,7 @@
};
// Opera package classes get all permissions
@@ -172,7 +171,7 @@
permission java.security.AllPermission;
};
-@@ -1167,7 +1116,7 @@
+@@ -1167,7 +1115,7 @@
chop "${OPERADESTDIR}" "str_localdirshare"
chop "${OPERADESTDIR}" "str_localdirplugin"
@@ -181,7 +180,7 @@
# Executable
debug_msg 1 "Executable"
-@@ -1201,7 +1150,7 @@
+@@ -1201,7 +1149,7 @@
#cp $cpv $cpf wrapper.sh $wrapper_dir/opera
generate_wrapper
@@ -190,7 +189,7 @@
# Manual page
debug_msg 1 "Manual page"
-@@ -1210,7 +1159,7 @@
+@@ -1210,7 +1158,7 @@
chmod $chmodv 755 ${man_dir}
mkdir $mkdirv $mkdirp ${man_dir}/man1
chmod $chmodv 755 ${man_dir}/man1
@@ -199,7 +198,7 @@
# Documentation
debug_msg 1 "Documentation"
-@@ -1242,13 +1191,6 @@
+@@ -1242,13 +1190,6 @@
mkdir $mkdirv $mkdirp $share_dir/ini/
chmod $chmodv 755 $share_dir/ini
cp $cpv $cpf $cpR ini/* $share_dir/ini/
@@ -213,7 +212,7 @@
fi
mkdir $mkdirv $mkdirp $share_dir/locale/
-@@ -1340,43 +1282,11 @@
+@@ -1340,43 +1281,11 @@
if test -z "${OPERADESTDIR}"
then
@@ -258,7 +257,7 @@
fi
fi # OPERADESTDIR
-@@ -1428,19 +1338,19 @@
+@@ -1428,19 +1337,19 @@
# arg1 = location
# arg2 = type
@@ -281,7 +280,7 @@
Name[af]=opera
Name[eo]=Opero
Name[zu]=I Opera
-@@ -1464,7 +1374,7 @@
+@@ -1464,7 +1373,7 @@
GenericName[ven]=Buronza ya Webu
GenericName[xh]=Umkhangeli Zincwadi Zokubhaliweyo
GenericName[zu]=Umkhangeli zincwadi we Web
@@ -290,7 +289,7 @@
Terminal=false"
# Application is not a category, according to
-@@ -1479,25 +1389,26 @@
+@@ -1479,25 +1388,26 @@
if test "${2}" = "xdg"; then
desktop_contain="${desktop_contain}
Categories=Application;Qt;Network;WebBrowser;X-Ximian-Main;X-Ximian-Toplevel
@@ -323,7 +322,7 @@
echo "${desktop_contain}" > ${desktop_file}
chmod $chmodv 644 ${desktop_file}
-@@ -1528,55 +1439,28 @@
+@@ -1528,55 +1438,28 @@
debug_msg 0 "in icons()"
diff --git a/www/linux-opera/pkg-message b/www/linux-opera/pkg-message
index f55552e917ce..a8a402ef412f 100644
--- a/www/linux-opera/pkg-message
+++ b/www/linux-opera/pkg-message
@@ -1,5 +1,5 @@
##
-Changelog for 9.20 Final: http://www.opera.com/docs/changelogs/linux/920/
+Changelog for 9.21 Final: http://www.opera.com/docs/changelogs/linux/921/
If you are upgrade from version 7.x or below, it is recommend for you to
backup your personal "~/.linux-opera" directory and remove it. As for the