aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Tiny/Makefile35
-rw-r--r--www/p5-HTTP-Tiny/distinfo2
-rw-r--r--www/p5-HTTP-Tiny/pkg-descr3
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6c985cb67441..d320600b9b92 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1070,6 +1070,7 @@
SUBDIR += p5-HTTP-Session-State-MobileAgentID
SUBDIR += p5-HTTP-SimpleLinkChecker
SUBDIR += p5-HTTP-Size
+ SUBDIR += p5-HTTP-Tiny
SUBDIR += p5-HTTP-WebTest
SUBDIR += p5-HTTPD-Log-Filter
SUBDIR += p5-HTTPD-User-Manage
diff --git a/www/p5-HTTP-Tiny/Makefile b/www/p5-HTTP-Tiny/Makefile
new file mode 100644
index 000000000000..46a5a1bf65e7
--- /dev/null
+++ b/www/p5-HTTP-Tiny/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-HTTP-Tiny
+# Date created: 2011-03-04
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Tiny
+PORTVERSION= 0.010
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DAGOLDEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A small, simple, correct HTTP/1.1 client
+
+OPTIONS= HTTPS "https support" on
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_HTTPS)
+RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
+.endif
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Tiny.3
+PLIST_FILES= %%SITE_PERL%%/HTTP/Tiny.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Tiny/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Tiny
+PLIST_DIRSTRY= %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP \
+ %%SITE_PERL%%/HTTP
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Tiny/distinfo b/www/p5-HTTP-Tiny/distinfo
new file mode 100644
index 000000000000..e95cca3aba7a
--- /dev/null
+++ b/www/p5-HTTP-Tiny/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTTP-Tiny-0.010.tar.gz) = 075ddc2e74ca59d68e3b9196a29c8e80c0e8aeacf0f598113e807697b75fb03c
+SIZE (HTTP-Tiny-0.010.tar.gz) = 31042
diff --git a/www/p5-HTTP-Tiny/pkg-descr b/www/p5-HTTP-Tiny/pkg-descr
new file mode 100644
index 000000000000..52ad857de301
--- /dev/null
+++ b/www/p5-HTTP-Tiny/pkg-descr
@@ -0,0 +1,3 @@
+HTTP::Tiny is a small, simple, correct HTTP/1.1 client.
+
+WWW: http://search.cpan.org/dist/HTTP-Tiny/