aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-servers/XFree86-4-Server-snap/Makefile2
-rw-r--r--x11-servers/XFree86-4-Server/Makefile2
-rw-r--r--x11-servers/XFree86-4-Server/files/patch-common_x86.c32
-rw-r--r--x11/XFree86-4-libraries/Makefile2
-rw-r--r--x11/XFree86-4-libraries/files/patch-common_x86.c (renamed from x11-servers/XFree86-4-Server-snap/files/patch-common_x86.c)0
-rw-r--r--x11/XFree86-4-libraries/files/patch-imLcPrs.c18
6 files changed, 21 insertions, 35 deletions
diff --git a/x11-servers/XFree86-4-Server-snap/Makefile b/x11-servers/XFree86-4-Server-snap/Makefile
index 66cca0215674..551c7035aba6 100644
--- a/x11-servers/XFree86-4-Server-snap/Makefile
+++ b/x11-servers/XFree86-4-Server-snap/Makefile
@@ -31,7 +31,7 @@ DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc
PATCHDIR= ${.CURDIR}/../../x11/XFree86-4-libraries/files
.for pf in patch-text-mode.c patch-xf86Configure.c patch-xf86config.c \
- patch-mga_driver.c patch-common_x86.c patch-alp_xaam.c
+ patch-mga_driver.c patch-alp_xaam.c
EXTRA_PATCHES+= ${.CURDIR}/files/${pf}
.endfor
SCRIPTS_ENV= OSVERSION=${OSVERSION} \
diff --git a/x11-servers/XFree86-4-Server/Makefile b/x11-servers/XFree86-4-Server/Makefile
index 66cca0215674..551c7035aba6 100644
--- a/x11-servers/XFree86-4-Server/Makefile
+++ b/x11-servers/XFree86-4-Server/Makefile
@@ -31,7 +31,7 @@ DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc
PATCHDIR= ${.CURDIR}/../../x11/XFree86-4-libraries/files
.for pf in patch-text-mode.c patch-xf86Configure.c patch-xf86config.c \
- patch-mga_driver.c patch-common_x86.c patch-alp_xaam.c
+ patch-mga_driver.c patch-alp_xaam.c
EXTRA_PATCHES+= ${.CURDIR}/files/${pf}
.endfor
SCRIPTS_ENV= OSVERSION=${OSVERSION} \
diff --git a/x11-servers/XFree86-4-Server/files/patch-common_x86.c b/x11-servers/XFree86-4-Server/files/patch-common_x86.c
deleted file mode 100644
index 9e584c20ac75..000000000000
--- a/x11-servers/XFree86-4-Server/files/patch-common_x86.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- extras/Mesa/src/X86/common_x86.c.orig Fri Aug 17 11:40:11 2001
-+++ extras/Mesa/src/X86/common_x86.c Tue Dec 3 21:51:31 2002
-@@ -38,6 +38,10 @@
- #if defined(USE_KATMAI_ASM) && defined(__linux__)
- #include <signal.h>
- #endif
-+#if defined(USE_KATMAI_ASM) && defined(__FreeBSD__)
-+#include <sys/types.h>
-+#include <sys/sysctl.h>
-+#endif
-
- #include "context.h"
- #include "common_x86_asm.h"
-@@ -213,8 +217,17 @@
- message( "Cannot test OS support for SSE, disabling to be safe.\n" );
- gl_x86_cpu_features &= ~(X86_FEATURE_XMM);
- #endif /* _POSIX_SOURCE && X86_FXSR_MAGIC */
-+#elif defined(__FreeBSD__)
-+ {
-+ int ret, enabled;
-+ size_t len;
-+ len = sizeof(enabled);
-+ ret = sysctlbyname("hw.instruction_sse", &enabled, &len, NULL, 0);
-+ if (ret || !enabled)
-+ gl_x86_cpu_features &= ~(X86_FEATURE_XMM);
-+ }
- #else
-- /* Do nothing on non-Linux platforms for now.
-+ /* Do nothing on other platforms for now.
- */
- message( "Not testing OS support for SSE, leaving enabled.\n" );
- #endif /* __linux__ */
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index cac97fb9f1c1..cec3c622040e 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libraries
PORTVERSION= 4.2.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/} \
${MASTER_SITE_LOCAL:S/$/:local/}
diff --git a/x11-servers/XFree86-4-Server-snap/files/patch-common_x86.c b/x11/XFree86-4-libraries/files/patch-common_x86.c
index 9e584c20ac75..9e584c20ac75 100644
--- a/x11-servers/XFree86-4-Server-snap/files/patch-common_x86.c
+++ b/x11/XFree86-4-libraries/files/patch-common_x86.c
diff --git a/x11/XFree86-4-libraries/files/patch-imLcPrs.c b/x11/XFree86-4-libraries/files/patch-imLcPrs.c
new file mode 100644
index 000000000000..f4e347f9d1bf
--- /dev/null
+++ b/x11/XFree86-4-libraries/files/patch-imLcPrs.c
@@ -0,0 +1,18 @@
+--- lib/X11/imLcPrs.c.orig Wed Dec 4 00:16:59 2002
++++ lib/X11/imLcPrs.c Wed Dec 4 00:17:44 2002
+@@ -518,13 +518,13 @@
+ FILE *fp;
+ DefTree **ptop;
+ {
+- char tb[65535];
++ char tb[8192];
+ char* tbp;
+ struct stat st;
+
+ if (fstat (fileno (fp), &st) != -1) {
+ unsigned long size = (unsigned long) st.st_size;
+- if (size < sizeof tb) tbp = tb;
++ if (size <= sizeof tb) tbp = tb;
+ else tbp = malloc (size);
+
+ if (tbp != NULL) {