aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/lapack95/Makefile1
-rw-r--r--math/suitesparse/Makefile1
-rw-r--r--math/taucs/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/math/lapack95/Makefile b/math/lapack95/Makefile
index 4da74ae9664f..e805a87c8e7a 100644
--- a/math/lapack95/Makefile
+++ b/math/lapack95/Makefile
@@ -20,6 +20,7 @@ COMMENT= LAPACK95, Fortran90/95 wrapper for LAPACK
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
PICFLAG?= -fPIC
+BROKEN= Does not link on sparc64
.else
PICFLAG?= -fpic
.endif
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index b1840158c4fd..3ea2424fabea 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -53,6 +53,7 @@ LAPACK= -pthread -lalapack_r
.if ${ARCH} == "sparc64" || ${ARCH} == "amd64"
FPIC= -fPIC
+BROKEN= Does not link on sparc64
.else
FPIC= -fpic
.endif
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
index 0a19de51fef6..3b341977222e 100644
--- a/math/taucs/Makefile
+++ b/math/taucs/Makefile
@@ -42,6 +42,7 @@ ALL_TARGET=
.if ${ARCH} == "sparc64"
PICFLAG?= -fPIC
+BROKEN= Does not link on sparc64
.else
PICFLAG?= -fpic
.endif