aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/angrysearch/Makefile29
-rw-r--r--sysutils/angrysearch/distinfo3
-rw-r--r--sysutils/angrysearch/files/patch-scandir.py22
-rw-r--r--sysutils/angrysearch/pkg-descr9
5 files changed, 64 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ba0a63e30e21..f536a5f510fd 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -37,6 +37,7 @@
SUBDIR += and
SUBDIR += android-file-transfer
SUBDIR += android-file-transfer-qt5
+ SUBDIR += angrysearch
SUBDIR += ansible
SUBDIR += ansible-sysrc
SUBDIR += ansible27
diff --git a/sysutils/angrysearch/Makefile b/sysutils/angrysearch/Makefile
new file mode 100644
index 000000000000..9236660c9f9b
--- /dev/null
+++ b/sysutils/angrysearch/Makefile
@@ -0,0 +1,29 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= angrysearch
+PORTVERSION= 1.0.2 # untagged, but specified in the setup.py
+CATEGORIES= sysutils python
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Quick search GUI tool for Unix systems
+
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= DoTheEvo
+GH_PROJECT= ANGRYsearch
+GH_TAGNAME= 6f8fccc
+
+USES= python pyqt:5
+USE_PYTHON= autoplist distutils noflavors
+USE_PYQT= core_run gui_run widgets_run
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,Linux,${OPSYS}, ; s,linux,${OPSYS:tl}, \
+ ; s,/usr/share,${PREFIX}/share,' ${WRKSRC}/setup.py \
+ ${WRKSRC}/angrysearch.desktop
+
+.include <bsd.port.mk>
+
+PATCH_ARGS+= -l
diff --git a/sysutils/angrysearch/distinfo b/sysutils/angrysearch/distinfo
new file mode 100644
index 000000000000..7537f73aabe1
--- /dev/null
+++ b/sysutils/angrysearch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532808758
+SHA256 (DoTheEvo-ANGRYsearch-1.0.2-6f8fccc_GH0.tar.gz) = cff66028d346e86c70a6911608fba1ee03e48dc5062c65313564df38b75acf95
+SIZE (DoTheEvo-ANGRYsearch-1.0.2-6f8fccc_GH0.tar.gz) = 504698
diff --git a/sysutils/angrysearch/files/patch-scandir.py b/sysutils/angrysearch/files/patch-scandir.py
new file mode 100644
index 000000000000..98263677803c
--- /dev/null
+++ b/sysutils/angrysearch/files/patch-scandir.py
@@ -0,0 +1,22 @@
+--- scandir.py.orig 2018-07-28 20:12:38 UTC
++++ scandir.py
+@@ -428,7 +428,18 @@ elif sys.platform.startswith(('linux', 'darwin')) or '
+ ('d_type', ctypes.c_byte),
+ ('d_name', ctypes.c_char * 256),
+ )
+- else:
++ elif sys.platform.startswith('freebsd') and int(sys.platform[7:]) > 11:
++ _fields_ = (
++ ('d_ino', ctypes.c_uint64),
++ ('d_off', ctypes.c_uint64),
++ ('d_reclen', ctypes.c_ushort),
++ ('d_type', ctypes.c_byte),
++ ('d_pad0', ctypes.c_byte),
++ ('d_namlen', ctypes.c_ushort),
++ ('d_pad1', ctypes.c_ushort),
++ ('d_name', ctypes.c_char * 256),
++ )
++ else:
+ _fields_ = (
+ ('d_ino', ctypes.c_uint32), # must be uint32, not ulong
+ ('d_reclen', ctypes.c_ushort),
diff --git a/sysutils/angrysearch/pkg-descr b/sysutils/angrysearch/pkg-descr
new file mode 100644
index 000000000000..a86ce568c7b3
--- /dev/null
+++ b/sysutils/angrysearch/pkg-descr
@@ -0,0 +1,9 @@
+Clone of the David Carpenter's "Everything" search engine, which locates
+files and folders by their name instantly, for Unix-like systems.
+
+This simple file search crawls available disks creating a database that
+can be searched using quick and responsive graphical interface.
+Notable difference is that by default, the entire paths are searched,
+not just file and folder names.
+
+WWW: https://github.com/DoTheEvo/ANGRYsearch