aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-OAI-Harvester/Makefile42
-rw-r--r--net/p5-OAI-Harvester/distinfo1
-rw-r--r--net/p5-OAI-Harvester/pkg-descr5
-rw-r--r--net/p5-OAI-Harvester/pkg-plist19
5 files changed, 68 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0a135d5ca1d2..b2ac006123e0 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -481,6 +481,7 @@
SUBDIR += p5-NetAddr-IP
SUBDIR += p5-NetAddr-IP-Count
SUBDIR += p5-NetPacket
+ SUBDIR += p5-OAI-Harvester
SUBDIR += p5-POE-Component-RRDTool
SUBDIR += p5-Parallel-MPI
SUBDIR += p5-Parallel-Pvm
diff --git a/net/p5-OAI-Harvester/Makefile b/net/p5-OAI-Harvester/Makefile
new file mode 100644
index 000000000000..216a04887a41
--- /dev/null
+++ b/net/p5-OAI-Harvester/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-OAI-Harvester
+# Date created: 2003-11-13
+# Whom: Paul Dlug <paul@aps.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= OAI-Harvester
+PORTVERSION= 0.82
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= paul@aps.org
+COMMENT= A module to harvest using the OAI protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OAI::Base.3 \
+ Net::OAI::Error.3 \
+ Net::OAI::GetRecord.3 \
+ Net::OAI::Harvester.3 \
+ Net::OAI::Identify.3 \
+ Net::OAI::ListIdentifiers.3 \
+ Net::OAI::ListMetadataFormats.3 \
+ Net::OAI::ListRecords.3 \
+ Net::OAI::ListSets.3 \
+ Net::OAI::Record.3 \
+ Net::OAI::Record::Header.3 \
+ Net::OAI::Record::OAI_DC.3 \
+ Net::OAI::ResumptionToken.3
+
+MAN1= oai-listsets.1 oai-listrecords.1
+
+.include <bsd.port.mk>
diff --git a/net/p5-OAI-Harvester/distinfo b/net/p5-OAI-Harvester/distinfo
new file mode 100644
index 000000000000..286e4ea6ab7f
--- /dev/null
+++ b/net/p5-OAI-Harvester/distinfo
@@ -0,0 +1 @@
+MD5 (OAI-Harvester-0.82.tar.gz) = e55e79eb8e2910a8a82cdae9a0ecef15
diff --git a/net/p5-OAI-Harvester/pkg-descr b/net/p5-OAI-Harvester/pkg-descr
new file mode 100644
index 000000000000..5bf895a915b3
--- /dev/null
+++ b/net/p5-OAI-Harvester/pkg-descr
@@ -0,0 +1,5 @@
+Perl module query OAI-PMH repositories. The Open Archives Initiative - Protocol
+for Metadata Harvesting allows repositories to share information about their
+contents.
+
+WWW: http://www.openarchives.org/
diff --git a/net/p5-OAI-Harvester/pkg-plist b/net/p5-OAI-Harvester/pkg-plist
new file mode 100644
index 000000000000..c68c2eb4b28c
--- /dev/null
+++ b/net/p5-OAI-Harvester/pkg-plist
@@ -0,0 +1,19 @@
+bin/oai-listrecords
+bin/oai-listsets
+%%SITE_PERL%%/Net/OAI/Base.pm
+%%SITE_PERL%%/Net/OAI/Error.pm
+%%SITE_PERL%%/Net/OAI/GetRecord.pm
+%%SITE_PERL%%/Net/OAI/Harvester.pm
+%%SITE_PERL%%/Net/OAI/Identify.pm
+%%SITE_PERL%%/Net/OAI/ListIdentifiers.pm
+%%SITE_PERL%%/Net/OAI/ListMetadataFormats.pm
+%%SITE_PERL%%/Net/OAI/ListRecords.pm
+%%SITE_PERL%%/Net/OAI/ListSets.pm
+%%SITE_PERL%%/Net/OAI/Record.pm
+%%SITE_PERL%%/Net/OAI/Record/Header.pm
+%%SITE_PERL%%/Net/OAI/Record/OAI_DC.pm
+%%SITE_PERL%%/Net/OAI/ResumptionToken.pm
+%%SITE_PERL%%/mach/auto/OAI-Harvester/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/OAI-Harvester
+@dirrm %%SITE_PERL%%/Net/OAI/Record
+@dirrm %%SITE_PERL%%/Net/OAI