aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-TCLink/Makefile24
-rw-r--r--net/p5-Net-TCLink/distinfo1
-rw-r--r--net/p5-Net-TCLink/pkg-comment1
-rw-r--r--net/p5-Net-TCLink/pkg-descr5
-rw-r--r--net/p5-Net-TCLink/pkg-plist8
6 files changed, 40 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5ed1c8420d31..3671592192f1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -383,6 +383,7 @@
SUBDIR += p5-Net-SSH
SUBDIR += p5-Net-SSH-Perl
SUBDIR += p5-Net-Server
+ SUBDIR += p5-Net-TCLink
SUBDIR += p5-Net-Telnet
SUBDIR += p5-Net-Traceroute
SUBDIR += p5-Net-Traceroute6
diff --git a/net/p5-Net-TCLink/Makefile b/net/p5-Net-TCLink/Makefile
new file mode 100644
index 000000000000..212885b13479
--- /dev/null
+++ b/net/p5-Net-TCLink/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Net::TCLink
+# Date created: 24 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-TCLink
+PORTVERSION= 3.3.1
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+DISTNAME= Net_TCLink.pm-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Net::TCLink.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-TCLink/distinfo b/net/p5-Net-TCLink/distinfo
new file mode 100644
index 000000000000..78ebdb8787b5
--- /dev/null
+++ b/net/p5-Net-TCLink/distinfo
@@ -0,0 +1 @@
+MD5 (Net_TCLink.pm-3.3.1.tar.gz) = df63ec7b707cae400b47b87e3d14b79c
diff --git a/net/p5-Net-TCLink/pkg-comment b/net/p5-Net-TCLink/pkg-comment
new file mode 100644
index 000000000000..3ff9359bfd4a
--- /dev/null
+++ b/net/p5-Net-TCLink/pkg-comment
@@ -0,0 +1 @@
+A client library to for connecting to the TrustCommerce payment gateway
diff --git a/net/p5-Net-TCLink/pkg-descr b/net/p5-Net-TCLink/pkg-descr
new file mode 100644
index 000000000000..6f4ce461ccdd
--- /dev/null
+++ b/net/p5-Net-TCLink/pkg-descr
@@ -0,0 +1,5 @@
+Net::TCLink is a thin client library to allow your e-commerce servers to
+connect to the TrustCommerce payment gateway easily and consistently.
+The protocol (which is the same across all platforms and languages) is
+well-documented in the Web Developer's Guide, so please consult it for
+any questions you may have about the protocol syntax itself.
diff --git a/net/p5-Net-TCLink/pkg-plist b/net/p5-Net-TCLink/pkg-plist
new file mode 100644
index 000000000000..7513a9993027
--- /dev/null
+++ b/net/p5-Net-TCLink/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/TCLink.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/TCLink/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/TCLink/TCLink.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/TCLink/TCLink.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/TCLink/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/TCLink
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net