aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/u-boot-master/Makefile14
-rw-r--r--sysutils/u-boot-pine64/Makefile8
-rw-r--r--sysutils/u-boot-sopine/Makefile8
3 files changed, 16 insertions, 14 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index dca788c5dd68..493e7d328fef 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -5,6 +5,7 @@
PORTNAME= u-boot
PORTVERSION= ${UBOOT_VERSION}
+PORTREVISION= 1
DISTVERSIONPREFIX= ports-v
CATEGORIES= sysutils
PKGNAMESUFFIX?= -${MODEL}
@@ -97,6 +98,12 @@ COMPILER?=${CROSS_COMPILE}gcc
UBOOT_MOVE=${UBOOT_MOVE_${FAMILY:tu}}
.endif
+# Per family dependancies
+.if ${FAMILY} == allwinner64
+BUILD_DEPENDS+= ${LOCALBASE}/share/atf-allwinner/bl31.bin:sysutils/atf-allwinner
+MAKE_ENV+= BL31=${LOCALBASE}/share/atf-allwinner/bl31.bin
+.endif
+
# Each u-boot family has different files to include, bring them in.
.for i in ${UBOOT_PLIST}
PLIST_FILES+= ${UBOOT_DIR}/${i}
@@ -106,6 +113,13 @@ PLIST_FILES+= ${UBOOT_DIR}/README
do-configure:
(cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${MAKE_CMD} ${BOARD_CONFIG})
+# U-Boot for Allwinner 64bits SoCs is splited in two parts
+# Generate a single binary to ease deployement on sdcard
+.if ${FAMILY} == allwinner64
+post-build:
+ ${CAT} ${WRKSRC}/spl/sunxi-spl.bin ${WRKSRC}/u-boot.itb > ${WRKSRC}/u-boot-sunxi-with-spl.bin
+.endif
+
# If we need to put anything into WRKSRC, do so now so we can build the PLIST
# in do-install
.if defined(UBOOT_MOVE)
diff --git a/sysutils/u-boot-pine64/Makefile b/sysutils/u-boot-pine64/Makefile
index 4e802ebb4c8b..83b90a0cf2db 100644
--- a/sysutils/u-boot-pine64/Makefile
+++ b/sysutils/u-boot-pine64/Makefile
@@ -1,16 +1,10 @@
# $FreeBSD$
-MAINTAINER= manu@FreeBSD.org
+MAINTAINER= uboot@FreeBSD.org
MASTERDIR= ${.CURDIR}/../u-boot-master
MODEL= pine64
BOARD_CONFIG= pine64_plus_defconfig
FAMILY= allwinner64
-BUILD_DEPENDS= ${LOCALBASE}/share/atf-allwinner/bl31.bin:sysutils/atf-allwinner
-MAKE_ENV+= BL31=${LOCALBASE}/share/atf-allwinner/bl31.bin
-
-post-build:
- ${CAT} ${WRKSRC}/spl/sunxi-spl.bin ${WRKSRC}/u-boot.itb > ${WRKSRC}/u-boot-sunxi-with-spl.bin
-
.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-sopine/Makefile b/sysutils/u-boot-sopine/Makefile
index 6cded540f906..622a3286d979 100644
--- a/sysutils/u-boot-sopine/Makefile
+++ b/sysutils/u-boot-sopine/Makefile
@@ -1,16 +1,10 @@
# $FreeBSD$
-MAINTAINER= manu@FreeBSD.org
+MAINTAINER= uboot@FreeBSD.org
MASTERDIR= ${.CURDIR}/../u-boot-master
MODEL= sopine
BOARD_CONFIG= sopine_baseboard_defconfig
FAMILY= allwinner64
-BUILD_DEPENDS= ${LOCALBASE}/share/atf-allwinner/bl31.bin:sysutils/atf-allwinner
-MAKE_ENV+= BL31=${LOCALBASE}/share/atf-allwinner/bl31.bin
-
-post-build:
- ${CAT} ${WRKSRC}/spl/sunxi-spl.bin ${WRKSRC}/u-boot.itb > ${WRKSRC}/u-boot-sunxi-with-spl.bin
-
.include "${MASTERDIR}/Makefile"