aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/pear-Math_Combinatorics/Makefile31
-rw-r--r--math/pear-Math_Combinatorics/distinfo3
-rw-r--r--math/pear-Math_Combinatorics/pkg-descr5
4 files changed, 40 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 69168d993e6b..d1398969b308 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -273,6 +273,7 @@
SUBDIR += p5-bignum
SUBDIR += pari
SUBDIR += parmetis
+ SUBDIR += pear-Math_Combinatorics
SUBDIR += pecl-big_int
SUBDIR += pecl-stats
SUBDIR += petsc
diff --git a/math/pear-Math_Combinatorics/Makefile b/math/pear-Math_Combinatorics/Makefile
new file mode 100644
index 000000000000..10e5c9bbc34c
--- /dev/null
+++ b/math/pear-Math_Combinatorics/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pear-Math_Combinatorics
+# Date created: 20 May 2007
+# Whom: Zhen REN <bg1tpt@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math_Combinatorics
+PORTVERSION= 1.0.0r1
+CATEGORIES= math pear
+DISTNAME= ${PORTNAME}-1.0.0RC1
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= A package that produces combinations and permutations
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Math
+FILES= Combinatorics.php
+IGNORE_WITH_PHP=4
+
+TESTS= test_1.phpt test_2.phpt test_3.phpt test_4.phpt \
+ test_5.phpt test_6.phpt
+
+EXAMPLES= example.php
+_EXAMPLESDIR= docs/examples
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/math/pear-Math_Combinatorics/distinfo b/math/pear-Math_Combinatorics/distinfo
new file mode 100644
index 000000000000..4c6542ce1cec
--- /dev/null
+++ b/math/pear-Math_Combinatorics/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Math_Combinatorics-1.0.0RC1.tgz) = a91f452620fc7261388d9498a00a4251
+SHA256 (PEAR/Math_Combinatorics-1.0.0RC1.tgz) = 38505a0cb78dc28510fd49c4afb40b9325256cb8b6e213fe8e9c03f8f25f0617
+SIZE (PEAR/Math_Combinatorics-1.0.0RC1.tgz) = 6458
diff --git a/math/pear-Math_Combinatorics/pkg-descr b/math/pear-Math_Combinatorics/pkg-descr
new file mode 100644
index 000000000000..4f3162bc1d59
--- /dev/null
+++ b/math/pear-Math_Combinatorics/pkg-descr
@@ -0,0 +1,5 @@
+A package that returns all the combinations and
+permutations, without repitition, of a given set
+and subset size. Associative arrays are preserved.
+
+WWW: http://pear.php.net/package/Math_Combinatorics/