aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-cyclocomp/Makefile23
-rw-r--r--devel/R-cran-cyclocomp/distinfo3
-rw-r--r--devel/R-cran-cyclocomp/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6e6d89dedb41..219accf957cc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -33,6 +33,7 @@
SUBDIR += R-cran-covr
SUBDIR += R-cran-cpp11
SUBDIR += R-cran-crayon
+ SUBDIR += R-cran-cyclocomp
SUBDIR += R-cran-data.table
SUBDIR += R-cran-desc
SUBDIR += R-cran-devtools
diff --git a/devel/R-cran-cyclocomp/Makefile b/devel/R-cran-cyclocomp/Makefile
new file mode 100644
index 000000000000..8514dea2258c
--- /dev/null
+++ b/devel/R-cran-cyclocomp/Makefile
@@ -0,0 +1,23 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+
+PORTNAME= cyclocomp
+DISTVERSION= 1.1.0
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= Cyclomatic Complexity of R Code
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= R-cran-callr>0:devel/R-cran-callr \
+ R-cran-crayon>0:devel/R-cran-crayon \
+ R-cran-desc>0:devel/R-cran-desc \
+ R-cran-remotes>0:devel/R-cran-remotes \
+ R-cran-withr>0:devel/R-cran-withr
+TEST_DEPENDS= R-cran-testthat>0:devel/R-cran-testthat
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-cyclocomp/distinfo b/devel/R-cran-cyclocomp/distinfo
new file mode 100644
index 000000000000..9e47e8bd87f5
--- /dev/null
+++ b/devel/R-cran-cyclocomp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1639103732
+SHA256 (cyclocomp_1.1.0.tar.gz) = cdbf65f87bccac53c1527a2f1269ec7840820c18503a7bb854910b30b71e7e3e
+SIZE (cyclocomp_1.1.0.tar.gz) = 8407
diff --git a/devel/R-cran-cyclocomp/pkg-descr b/devel/R-cran-cyclocomp/pkg-descr
new file mode 100644
index 000000000000..ecef6bfc35d4
--- /dev/null
+++ b/devel/R-cran-cyclocomp/pkg-descr
@@ -0,0 +1,6 @@
+Cyclomatic complexity is a software metric (measurement), used to indicate the
+complexity of a program. It is a quantitative measure of the number of linearly
+independent paths through a program's source code. It was developed by Thomas
+J. McCabe, Sr. in 1976.
+
+WWW: https://github.com/MangoTheCat/cyclocomp