aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/dieharder/Makefile28
-rw-r--r--math/dieharder/distinfo3
-rw-r--r--math/dieharder/files/patch-dieharder_dieharder.154
-rw-r--r--math/dieharder/files/patch-libdieharder_libdieharder.319
-rw-r--r--math/dieharder/pkg-descr24
-rw-r--r--math/dieharder/pkg-plist45
7 files changed, 174 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index dfa372ad2d3b..16d0989257c7 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -44,6 +44,7 @@
SUBDIR += cxsc
SUBDIR += dcdflib
SUBDIR += diehard
+ SUBDIR += dieharder
SUBDIR += digitizer
SUBDIR += dislin
SUBDIR += djbfft
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
new file mode 100644
index 000000000000..0f050570b108
--- /dev/null
+++ b/math/dieharder/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: dieharder
+# Date created: 14 November 2008
+# Whom: bf <bf2006a@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dieharder
+PORTVERSION= 2.28.1
+CATEGORIES= math
+MASTER_SITES= http://www.phy.duke.edu/~rgb/General/dieharder/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bf2006a@yahoo.com
+COMMENT= A random number generator testsuite
+
+LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+
+USE_AUTOTOOLS= aclocal:110 autoheader:262 libtool:15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+MAN1= dieharder.1
+MAN3= libdieharder.3
+
+run-autotools:
+ @(cd ${WRKSRC}; ${SETENV} ${AUTOTOOLS_ENV} ${SH} ./autogen.sh)
+
+.include <bsd.port.mk>
diff --git a/math/dieharder/distinfo b/math/dieharder/distinfo
new file mode 100644
index 000000000000..a5479ec2638a
--- /dev/null
+++ b/math/dieharder/distinfo
@@ -0,0 +1,3 @@
+MD5 (dieharder-2.28.1.tgz) = 47819cd609648f506a40ec9110c4463c
+SHA256 (dieharder-2.28.1.tgz) = 748ec4716e64de38807e126f10335e45136fa789056e9f647a6bf73698205286
+SIZE (dieharder-2.28.1.tgz) = 766985
diff --git a/math/dieharder/files/patch-dieharder_dieharder.1 b/math/dieharder/files/patch-dieharder_dieharder.1
new file mode 100644
index 000000000000..7b6380be8e4e
--- /dev/null
+++ b/math/dieharder/files/patch-dieharder_dieharder.1
@@ -0,0 +1,54 @@
+--- dieharder/dieharder.1.orig 2008-09-08 08:37:19.000000000 -0400
++++ dieharder/dieharder.1 2008-11-14 20:05:01.794803058 -0500
+@@ -1,6 +1,6 @@
+ .\" $Id: dieharder.1 425 2008-08-19 10:01:36Z rgb $
+-.TH DieHarder 1 "Copyright 2004 Robert G. Brown" "DieHarder"
++.TH dieharder 1 "Copyright 2004 Robert G. Brown" "DieHarder"
+ .SH NAME
+-rand_rate \- A testing and benchmarking tool for GSL random number
++dieharder \- A testing and benchmarking tool for GSL random number
+ generators
+
+@@ -13,5 +13,5 @@
+ [-v verbose flag] [-x xvalue] [-y yvalue] [-z zvalue]
+
+-.SH DieHarder OPTIONS
++.SH OPTIONS
+
+ .TP
+@@ -40,6 +40,6 @@
+ -l list all known tests.
+ .TP
+--n ntuple - set ntuple length for tests on short bit strings that permit
+-the length to be varied (e.g. rgb bitdist).
++-n ntuple - set ntuple length for tests on short bit strings that
++permit the length to be varied (e.g. rgb bitdist).
+ .TP
+ -p count - sets the number of p-value samples per test (default 100).
+@@ -93,5 +93,4 @@
+
+ .SH DESCRIPTION
+-.B DieHarder
+ This is the current snapshot of the dieharder random number
+ tester. It encapsulates all of the Gnu Scientific Library random number
+@@ -123,5 +122,5 @@
+
+ .SH P-VALUES AND THE NULL HYPOTHESIS
+-.B DieHarder returns "p-values". To understand what a p-value is and
++dieharder returns "p-values". To understand what a p-value is and
+ how to use it, it is essential to understand the
+ .I null hypothesis.
+@@ -405,5 +404,5 @@
+ as prototypes, and can likely be submitted to the GSL for inclusion if
+ they pass the tests as well or better than the generators that are already
+-there. Dieharder is designed to (ultimately) be a
++there. dieharder is designed to (ultimately) be a
+ .I very convenient tool
+ for testing new software RNGs.
+@@ -535,5 +534,5 @@
+
+ .SH PUBLICATION RULES
+-.B DieHarder
++dieharder
+ is entirely original code and can be modified and used at will by any
+ user, provided that:
diff --git a/math/dieharder/files/patch-libdieharder_libdieharder.3 b/math/dieharder/files/patch-libdieharder_libdieharder.3
new file mode 100644
index 000000000000..8eb6b1ad6727
--- /dev/null
+++ b/math/dieharder/files/patch-libdieharder_libdieharder.3
@@ -0,0 +1,19 @@
+--- libdieharder/libdieharder.3.orig 2008-09-08 08:37:18.000000000 -0400
++++ libdieharder/libdieharder.3 2008-11-14 20:07:57.513048813 -0500
+@@ -96,7 +96,6 @@
+
+
+ .SH DESCRIPTION
+-.B libdieharder
+
+ The libdieharder library provides an API to user interface programs
+ wishing to call dieharder tests. Commands are defined for creating
+@@ -121,7 +120,7 @@
+ "standard" application of the library.
+
+ .SH PUBLICATION RULES
+-.B libdieharder
++libdieharder
+ is entirely original code and can be modified and used at will by any
+ user, provided that:
+
diff --git a/math/dieharder/pkg-descr b/math/dieharder/pkg-descr
new file mode 100644
index 000000000000..06437a611638
--- /dev/null
+++ b/math/dieharder/pkg-descr
@@ -0,0 +1,24 @@
+At the suggestion of Linas Vepstas on the Gnu Scientific Library (GSL) list,
+this GPL'd suite of random number tests will be named "Dieharder". Using a
+movie sequel pun for the name is a double tribute to George Marsaglia, whose
+"Diehard battery of tests" of random number generators has enjoyed years of
+enduring usefulness as a test suite.
+
+The dieharder suite is more than just the diehard tests cleaned up and given a
+pretty GPL'd source face in native C: tests from the Statistical Test Suite
+(STS) developed by the National Institute for Standards and Technology (NIST)
+are being incorporated, as are new tests developed by rgb. Where possible,
+tests are parametrized and controllable so that failure, at least, is
+unambiguous.
+
+A further design goal is to provide some indication of *why* a generator fails
+a test, where such information can be extracted during the test process and
+placed in usable form. For example, the bit-distribution tests should
+(eventually) be able to display the actual histogram for the different bit
+n-tuplets.
+
+Dieharder is by design extensible. It is intended to be the "Swiss army knife
+of random number test suites", or if you prefer, "the last suite you'll ever
+ware" for testing random numbers.
+
+WWW: http://www.phy.duke.edu/~rgb/General/dieharder.php
diff --git a/math/dieharder/pkg-plist b/math/dieharder/pkg-plist
new file mode 100644
index 000000000000..1533b24eeff1
--- /dev/null
+++ b/math/dieharder/pkg-plist
@@ -0,0 +1,45 @@
+bin/dieharder
+include/dieharder/Dtest.h
+include/dieharder/Vtest.h
+include/dieharder/Xtest.h
+include/dieharder/copyright.h
+include/dieharder/diehard_2dsphere.h
+include/dieharder/diehard_3dsphere.h
+include/dieharder/diehard_birthdays.h
+include/dieharder/diehard_bitstream.h
+include/dieharder/diehard_count_1s_byte.h
+include/dieharder/diehard_count_1s_stream.h
+include/dieharder/diehard_craps.h
+include/dieharder/diehard_dna.h
+include/dieharder/diehard_operm5.h
+include/dieharder/diehard_opso.h
+include/dieharder/diehard_oqso.h
+include/dieharder/diehard_parking_lot.h
+include/dieharder/diehard_rank_32x32.h
+include/dieharder/diehard_rank_6x8.h
+include/dieharder/diehard_runs.h
+include/dieharder/diehard_squeeze.h
+include/dieharder/diehard_sums.h
+include/dieharder/dieharder_types.h
+include/dieharder/libdieharder.h
+include/dieharder/marsaglia_tsang_gcd.h
+include/dieharder/marsaglia_tsang_gorilla.h
+include/dieharder/parse.h
+include/dieharder/rgb_bitdist.h
+include/dieharder/rgb_lmn.h
+include/dieharder/rgb_minimum_distance.h
+include/dieharder/rgb_operm.h
+include/dieharder/rgb_permutations.h
+include/dieharder/rgb_persist.h
+include/dieharder/rgb_timing.h
+include/dieharder/std_test.h
+include/dieharder/sts_monobit.h
+include/dieharder/sts_runs.h
+include/dieharder/sts_serial.h
+include/dieharder/tests.h
+include/dieharder/verbose.h
+lib/libdieharder.a
+lib/libdieharder.la
+lib/libdieharder.so
+lib/libdieharder.so.2
+@dirrm include/dieharder