aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/debootstrap/Makefile10
-rw-r--r--sysutils/debootstrap/distinfo6
-rw-r--r--sysutils/debootstrap/files/patch-Makefile8
3 files changed, 14 insertions, 10 deletions
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index 021a8c1c5538..fdb808e04908 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -1,9 +1,8 @@
PORTNAME= debootstrap
-PORTVERSION= 1.0.128
-PORTREVISION= 1
+PORTVERSION= ${DEB_VERSION}-${DEB_NMU}
CATEGORIES= sysutils
MASTER_SITES= DEBIAN
-DISTNAME= ${PORTNAME}_${PORTVERSION}+nmu2~bpo11+1
+DISTNAME= ${PORTNAME}_${DEB_VERSION}+nmu${DEB_NMU}
MAINTAINER= nc@FreeBSD.org
COMMENT= Install Debian or Ubuntu base system into a directory
@@ -24,6 +23,11 @@ NO_ARCH= yes
USES= gmake perl5
USE_PERL5= run
+# The +nmu suffix used by debian for "non maintainer uploads" of a Debian
+# native package doesn't play well with our versioning
+DEB_VERSION= 1.0.128
+DEB_NMU= 2
+
post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/Makefile \
diff --git a/sysutils/debootstrap/distinfo b/sysutils/debootstrap/distinfo
index eff91678d5b2..54933414c156 100644
--- a/sysutils/debootstrap/distinfo
+++ b/sysutils/debootstrap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1677062129
-SHA256 (debootstrap_1.0.128+nmu2~bpo11+1.tar.gz) = 140b2ef281a190c70098462b090ba2997bbcd075a6c1a1c7ce90b4c0e10c207d
-SIZE (debootstrap_1.0.128+nmu2~bpo11+1.tar.gz) = 82336
+TIMESTAMP = 1677148183
+SHA256 (debootstrap_1.0.128+nmu2.tar.gz) = 528523228d93a31c9e0cd4eb932977ea8ceec2bfbf8db1103bec2397cc7434fa
+SIZE (debootstrap_1.0.128+nmu2.tar.gz) = 82266
diff --git a/sysutils/debootstrap/files/patch-Makefile b/sysutils/debootstrap/files/patch-Makefile
index 79638ff023e8..8d55f3868d54 100644
--- a/sysutils/debootstrap/files/patch-Makefile
+++ b/sysutils/debootstrap/files/patch-Makefile
@@ -5,11 +5,11 @@
clean:
-DSDIR=$(DESTDIR)/usr/share/debootstrap
-+DSDIR=$(DESTDIR)/usr/local/share/debootstrap
++DSDIR=$(DESTDIR)$(PREFIX)/share/debootstrap
install:
mkdir -p $(DSDIR)/scripts
- mkdir -p $(DESTDIR)/usr/sbin
-+ mkdir -p $(DESTDIR)/usr/local/sbin
++ mkdir -p $(DESTDIR)$(PREFIX)/sbin
cp -a scripts/* $(DSDIR)/scripts/
- install -o root -g root -m 0644 functions $(DSDIR)/
@@ -18,5 +18,5 @@
- sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/sbin/debootstrap
- chown root:root $(DESTDIR)/usr/sbin/debootstrap
- chmod 0755 $(DESTDIR)/usr/sbin/debootstrap
-+ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/local/sbin/debootstrap
-+ chmod 0755 $(DESTDIR)/usr/local/sbin/debootstrap
++ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)$(PREFIX)/sbin/debootstrap
++ chmod 0755 $(DESTDIR)$(PREFIX)/sbin/debootstrap