aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/awgg/Makefile2
-rw-r--r--net-p2p/dclib/Makefile2
-rw-r--r--net-p2p/deluge/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-data/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-gtk/Makefile2
-rw-r--r--net-p2p/gtorrentviewer/Makefile2
-rw-r--r--net-p2p/linuxdcpp/Makefile3
-rw-r--r--net-p2p/microdc2/Makefile2
-rw-r--r--net-p2p/minder/Makefile2
-rw-r--r--net-p2p/tribler/Makefile2
-rw-r--r--net-p2p/vuze/Makefile2
11 files changed, 12 insertions, 11 deletions
diff --git a/net-p2p/awgg/Makefile b/net-p2p/awgg/Makefile
index e5e11228e77a..ceccdc7c6663 100644
--- a/net-p2p/awgg/Makefile
+++ b/net-p2p/awgg/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= aria2c:www/aria2 \
gtk2_CONFLICTS_INSTALL= ${PORTNAME}-qt5
qt5_CONFLICTS_INSTALL= ${PORTNAME}-gtk2
-USES= fpc lazarus:flavors xorg
+USES= fpc gnome lazarus:flavors xorg
USE_FPC= chm fcl-base fcl-db fcl-image fcl-json fcl-registry fcl-xml \
pasjpeg regexpr rtl-extra rtl-objpas x11
USE_XORG= x11
diff --git a/net-p2p/dclib/Makefile b/net-p2p/dclib/Makefile
index 2e1af1793238..94e7262c82b3 100644
--- a/net-p2p/dclib/Makefile
+++ b/net-p2p/dclib/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/${DISTNAME}
-USES= jpeg libtool localbase pathfix ssl tar:bzip2
+USES= gnome jpeg libtool localbase pathfix ssl tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= libxml2
INSTALL_TARGET= install-strip
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index ff9aa2ff48a7..a1efa8aa6126 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:devel/py-dbus@${PY_FLAVOR} \
xdg-utils>=1.0.2:devel/xdg-utils \
deluge:net-p2p/deluge-cli
-USES= python:-2.7 metaport
+USES= gnome metaport python:-2.7
USE_GNOME= librsvg2 pygtk2
.include <bsd.port.mk>
diff --git a/net-p2p/eiskaltdcpp-data/Makefile b/net-p2p/eiskaltdcpp-data/Makefile
index e1c002f963d5..786e05e1ba06 100644
--- a/net-p2p/eiskaltdcpp-data/Makefile
+++ b/net-p2p/eiskaltdcpp-data/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3
MASTERDIR= ${.CURDIR}/../eiskaltdcpp-lib
-USES= cmake shebangfix
+USES= cmake gnome shebangfix
SHEBANG_FILES= data/examples/commands.ru_RU.UTF-8.php \
data/examples/deadbeef.ru_RU.UTF-8.sh \
data/examples/mod.amarok.sh \
diff --git a/net-p2p/eiskaltdcpp-gtk/Makefile b/net-p2p/eiskaltdcpp-gtk/Makefile
index 858aabdcaee1..904af804c59b 100644
--- a/net-p2p/eiskaltdcpp-gtk/Makefile
+++ b/net-p2p/eiskaltdcpp-gtk/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libeiskaltdcpp.so:net-p2p/eiskaltdcpp-lib
MASTERDIR= ${.CURDIR}/../eiskaltdcpp-lib
-USES= cmake gettext compiler:c++11-lib desktop-file-utils ssl
+USES= cmake compiler:c++11-lib desktop-file-utils gettext gnome ssl
USE_GNOME= pango glib20
OPTIONS_DEFINE= LIBNOTIFY FREE_SPACE
diff --git a/net-p2p/gtorrentviewer/Makefile b/net-p2p/gtorrentviewer/Makefile
index e90715f8940d..2fa4bb117e52 100644
--- a/net-p2p/gtorrentviewer/Makefile
+++ b/net-p2p/gtorrentviewer/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= gmake pkgconfig desktop-file-utils
+USES= desktop-file-utils gmake gnome pkgconfig
USE_GNOME= gtk20 intlhack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pixmapsdir=${PREFIX}/share/pixmaps \
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
index b2fd079637fe..f44fac16dc1a 100644
--- a/net-p2p/linuxdcpp/Makefile
+++ b/net-p2p/linuxdcpp/Makefile
@@ -14,7 +14,8 @@ LICENSE_FILE= ${WRKSRC}/License.txt
BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
-USES= compiler:c++11-lang gettext iconv localbase:ldflags pkgconfig scons tar:bzip2 ssl
+USES= compiler:c++11-lang gettext gnome iconv localbase:ldflags \
+ pkgconfig scons ssl tar:bzip2
USE_GNOME= libglade2
PORTDOCS= *
DESTDIRNAME= FAKE_ROOT
diff --git a/net-p2p/microdc2/Makefile b/net-p2p/microdc2/Makefile
index 26fd24455b6b..66756dfe1db2 100644
--- a/net-p2p/microdc2/Makefile
+++ b/net-p2p/microdc2/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
CONFLICTS= tthsum-[0-9]*
-USES= iconv readline
+USES= gnome iconv readline
GNU_CONFIGURE= yes
USE_GNOME= libxml2
diff --git a/net-p2p/minder/Makefile b/net-p2p/minder/Makefile
index 1e059d18f360..e5c34606d80a 100644
--- a/net-p2p/minder/Makefile
+++ b/net-p2p/minder/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2+
LIB_DEPENDS= libSockets.so:net/Sockets
-USES= gmake pkgconfig ssl
+USES= gmake gnome pkgconfig ssl
USE_GNOME= libxml2
CFLAGS+= -DHAVE_OPENSSL
diff --git a/net-p2p/tribler/Makefile b/net-p2p/tribler/Makefile
index 05a1da3a360c..1897c5cf342c 100644
--- a/net-p2p/tribler/Makefile
+++ b/net-p2p/tribler/Makefile
@@ -34,7 +34,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}apsw>0:databases/py-apsw@${PY_FLAVOR} \
NO_ARCH= yes
NO_WRKSUBDIR= yes
-USES= desktop-file-utils python:2.7,run ssl:run tar:xz
+USES= desktop-file-utils gnome python:2.7,run ssl:run tar:xz
USE_WX= 2.8
WX_COMPS= python
INSTALLS_ICONS= yes
diff --git a/net-p2p/vuze/Makefile b/net-p2p/vuze/Makefile
index dcf040d236e6..c2e6b1ec1673 100644
--- a/net-p2p/vuze/Makefile
+++ b/net-p2p/vuze/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${JAVALIBDIR}/log4j.jar:devel/log4j \
${JAVALIBDIR}/swt.jar:x11-toolkits/swt
RUN_DEPENDS= ${JAVALIBDIR}/swt.jar:x11-toolkits/swt
-USES= zip
+USES= gnome zip
USE_JAVA= yes
JAVA_OS= native
USE_ANT= yes