aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mp3stat/Makefile2
-rw-r--r--chinese/fcitx-chewing/Makefile11
-rw-r--r--chinese/fcitx-chewing/pkg-descr2
-rw-r--r--chinese/fcitx-configtool/Makefile2
-rw-r--r--chinese/gcin/Makefile8
-rw-r--r--chinese/scim-fcitx/Makefile10
-rw-r--r--textproc/scim-bridge-qt4/Makefile9
-rw-r--r--textproc/scim-bridge-qt4/pkg-descr2
-rw-r--r--textproc/scim-input-pad/Makefile2
-rw-r--r--textproc/scim-kmfl-imengine/Makefile8
-rw-r--r--textproc/scim-m17n/Makefile11
11 files changed, 20 insertions, 47 deletions
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
index e19f8f1b2a8c..54cf33fa0a75 100644
--- a/audio/mp3stat/Makefile
+++ b/audio/mp3stat/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFAULT= VORBIS
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= gmake
+USES= gmake pkgconfig
USE_GNOME= gtk20
CXX+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
diff --git a/chinese/fcitx-chewing/Makefile b/chinese/fcitx-chewing/Makefile
index 3268ef5827df..17f7df302222 100644
--- a/chinese/fcitx-chewing/Makefile
+++ b/chinese/fcitx-chewing/Makefile
@@ -1,15 +1,12 @@
-# New ports collection makefile for: fcitx-chewing
-# Date created: 6 Feb 2012
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= fcitx-chewing
PORTVERSION= 0.1.3
PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PROJECTHOST= fcitx
DIST_SUBDIR= fcitx
MAINTAINER= lichray@gmail.com
@@ -19,9 +16,7 @@ LIB_DEPENDS= fcitx-config:${PORTSDIR}/chinese/fcitx \
chewing:${PORTSDIR}/chinese/libchewing
USE_XZ= yes
-USES= cmake gettext
+USES= cmake gettext pkgconfig
USE_GNOME= intltool
-PROJECTHOST= fcitx
-
.include <bsd.port.mk>
diff --git a/chinese/fcitx-chewing/pkg-descr b/chinese/fcitx-chewing/pkg-descr
index 1c434f6bb3ec..b9e8d109156d 100644
--- a/chinese/fcitx-chewing/pkg-descr
+++ b/chinese/fcitx-chewing/pkg-descr
@@ -1,4 +1,4 @@
fcitx-chewing provides Chewing, an intelligent phonetic input method
engine, as a back-end to the Fcitx IM framework.
-WWW: http://code.google.com/p/fcitx/
+WWW: http://code.google.com/p/fcitx/
diff --git a/chinese/fcitx-configtool/Makefile b/chinese/fcitx-configtool/Makefile
index 5dbe4e5bf712..770c0bba5bdb 100644
--- a/chinese/fcitx-configtool/Makefile
+++ b/chinese/fcitx-configtool/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= fcitx-config:${PORTSDIR}/chinese/fcitx
USE_XZ= yes
USE_GNOME= intltool gnomehack
-USES= cmake gettext
+USES= cmake gettext pkgconfig
OPTIONS_DEFINE= GTK2 GTK3
OPTIONS_DEFAULT=GTK2
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index 3b6ec438a1a2..083ad1d795ca 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zh-gcin
-# Date created: Feb 18 2004
-# Whom: Shen Chuan-Hsing
-#
+# Created by: Shen Chuan-Hsing
# $FreeBSD$
-#
PORTNAME= gcin
PORTVERSION= 2.8.0
@@ -22,7 +18,7 @@ USE_XZ= YES
HAS_CONFIGURE= YES
CONFIGURE_ARGS+= --use_gtk3=N --use_qt3=N
USE_GNOME= gtk20
-USE_GMAKE= YES
+USES= gmake pkgconfig
USE_XORG= x11 xtst xext
INSTALLS_ICONS= YES
USE_LDCONFIG= YES
diff --git a/chinese/scim-fcitx/Makefile b/chinese/scim-fcitx/Makefile
index c3bcdc84f1c2..7468ff3a831f 100644
--- a/chinese/scim-fcitx/Makefile
+++ b/chinese/scim-fcitx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zh-scim-fcitx
-# Date created: 8 May 2007
-# Whom: Yinghong Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= scim
PORTVERSION= 3.1.1
@@ -14,13 +10,13 @@ PKGNAMESUFFIX= -fcitx
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= An SCIM IMEngine module for fcitx
+COMMENT= SCIM IMEngine module for fcitx
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
BUILD_DEPENDS:= ${RUN_DEPENDS}
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/textproc/scim-bridge-qt4/Makefile b/textproc/scim-bridge-qt4/Makefile
index 9adafadf7719..280e41c2dde8 100644
--- a/textproc/scim-bridge-qt4/Makefile
+++ b/textproc/scim-bridge-qt4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: scim-bridge-qt4
-# Date created: 2008-08-17
-# Whom: Henry Hu <henry.hu.sh@gmail.com>
-#
+# Created by: Henry Hu <henry.hu.sh@gmail.com>
# $FreeBSD$
-#
PORTNAME= scim-bridge
PORTVERSION= 0.4.16
@@ -19,8 +15,7 @@ RUN_DEPENDS= scim-bridge:${PORTSDIR}/textproc/scim-bridge
USE_QT4= corelib gui moc_build
QT_NONSTANDARD= yes
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
LICENSE= GPLv2 LGPL21
diff --git a/textproc/scim-bridge-qt4/pkg-descr b/textproc/scim-bridge-qt4/pkg-descr
index 0a4d7622fbe4..5d71cc579730 100644
--- a/textproc/scim-bridge-qt4/pkg-descr
+++ b/textproc/scim-bridge-qt4/pkg-descr
@@ -4,4 +4,4 @@ the IME server which communicates with SCIM. The clients are IMModules
which communicate only with the agent so that there is no binary
dependency between the clients and SCIM.
-WWW: http://www.scim-im.org/projects/scim_bridge/
+WWW: http://www.scim-im.org/projects/scim_bridge/
diff --git a/textproc/scim-input-pad/Makefile b/textproc/scim-input-pad/Makefile
index f32d69eafd29..dd9a94e0f7d4 100644
--- a/textproc/scim-input-pad/Makefile
+++ b/textproc/scim-input-pad/Makefile
@@ -14,7 +14,7 @@ COMMENT= SCIM add-on to input various symbols with customisable on-screen pad
LIB_DEPENDS= scim-1.0.10:${PORTSDIR}/textproc/scim
USE_LDCONFIG= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/scim-kmfl-imengine/Makefile b/textproc/scim-kmfl-imengine/Makefile
index c530e8c9f6b0..fe57411b10c9 100644
--- a/textproc/scim-kmfl-imengine/Makefile
+++ b/textproc/scim-kmfl-imengine/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: scim-kmfl-imengine
-# Date created: 10 October 2007
-# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
-#
+# Created by: Nikola Lecic <nikola.lecic@anthesphoria.net>
# $FreeBSD$
-#
PORTNAME= scim-kmfl-imengine
PORTVERSION= 0.9.9
@@ -28,7 +24,7 @@ RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
USE_XORG= x11 xkbfile xproto
USE_AUTOTOOLS= libtool
USE_GNOME= glib20 gtk20 intlhack
-USES= gettext iconv
+USES= gettext iconv pkgconfig
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/scim-m17n/Makefile b/textproc/scim-m17n/Makefile
index 3335b0caa554..b7425d3c2d81 100644
--- a/textproc/scim-m17n/Makefile
+++ b/textproc/scim-m17n/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: scim-m17n
-# Date Created: 10 May 2007
-# Whom: Yinghong Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= scim-m17n
PORTVERSION= 0.2.3
@@ -12,16 +8,15 @@ CATEGORIES= textproc
MASTER_SITES= SF/scim/${PORTNAME}/${PORTVERSION} \
http://anthesphoria.net/FreeBSD/ports/distfiles/
-
MAINTAINER= nikola.lecic@anthesphoria.net
-COMMENT= A SCIM IMEngine module which uses m17n library as the backend
+COMMENT= SCIM IMEngine module which uses m17n library as the backend
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
gsed:${PORTSDIR}/textproc/gsed
LIB_DEPENDS= m17n.4:${PORTSDIR}/devel/m17n-lib
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
.include <bsd.port.mk>