aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/sqtop/Makefile33
-rw-r--r--net/sqtop/distinfo3
-rw-r--r--net/sqtop/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f027bc453968..f0186f95350b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1013,6 +1013,7 @@
SUBDIR += spread4
SUBDIR += sprinkle
SUBDIR += spserver
+ SUBDIR += sqtop
SUBDIR += ss5
SUBDIR += ssldump
SUBDIR += sslh
diff --git a/net/sqtop/Makefile b/net/sqtop/Makefile
new file mode 100644
index 000000000000..3be0b9a775d8
--- /dev/null
+++ b/net/sqtop/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sqtop
+# Date created: 2010-09-05
+# Whom: Marco Steinbach <coco@webdev.c0c0.intra>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqtop
+DISTVERSION= 2010-06-03
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= coco@executive-computing.de
+COMMENT= Console-based display of Squid proxy connections
+
+USE_BZIP2= yes
+
+PLIST_FILES= bin/sqtop
+
+MAN1= sqtop.1
+
+GNU_CONFIGURE= yes
+
+OPTIONS= NCURSES "Enable ncurses user interface" On
+
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_NCURSES)
+CONFIGURE_ARGS+= --disable-ui
+.endif
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/net/sqtop/distinfo b/net/sqtop/distinfo
new file mode 100644
index 000000000000..7694afed4891
--- /dev/null
+++ b/net/sqtop/distinfo
@@ -0,0 +1,3 @@
+MD5 (sqtop-2010-06-03.tar.bz2) = 6fc6129e239e8fa3ee6b54c624f472dd
+SHA256 (sqtop-2010-06-03.tar.bz2) = f50707ff55bdc773014337e27b242cf8198320b3546dc990622abdf7134db319
+SIZE (sqtop-2010-06-03.tar.bz2) = 86541
diff --git a/net/sqtop/pkg-descr b/net/sqtop/pkg-descr
new file mode 100644
index 000000000000..4bbf6cddfd74
--- /dev/null
+++ b/net/sqtop/pkg-descr
@@ -0,0 +1,4 @@
+sqtop is a console applicaton to display information about currently active
+client connections for a Squid proxy in a convenient way.
+
+WWW: http://code.google.com/p/sqtop/