aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Slurper/Makefile19
-rw-r--r--devel/p5-File-Slurper/distinfo2
-rw-r--r--devel/p5-File-Slurper/pkg-descr4
-rw-r--r--devel/p5-File-Slurper/pkg-plist2
5 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8704d2413169..6127a574f797 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2271,6 +2271,7 @@
SUBDIR += p5-File-Slurp
SUBDIR += p5-File-Slurp-Tiny
SUBDIR += p5-File-Slurp-Tree
+ SUBDIR += p5-File-Slurper
SUBDIR += p5-File-Spec-Native
SUBDIR += p5-File-Stream
SUBDIR += p5-File-Sync
diff --git a/devel/p5-File-Slurper/Makefile b/devel/p5-File-Slurper/Makefile
new file mode 100644
index 000000000000..b366750493cc
--- /dev/null
+++ b/devel/p5-File-Slurper/Makefile
@@ -0,0 +1,19 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= File-Slurper
+PORTVERSION= 0.008
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Simple, sane and efficient module to slurp a file
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Slurper/distinfo b/devel/p5-File-Slurper/distinfo
new file mode 100644
index 000000000000..9bc57f0447b7
--- /dev/null
+++ b/devel/p5-File-Slurper/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-Slurper-0.008.tar.gz) = 10f685140e2cebdd0381f24b010b028f9ca2574361a78f99f4dfe87af5d5d233
+SIZE (File-Slurper-0.008.tar.gz) = 14760
diff --git a/devel/p5-File-Slurper/pkg-descr b/devel/p5-File-Slurper/pkg-descr
new file mode 100644
index 000000000000..e3b3fb37a009
--- /dev/null
+++ b/devel/p5-File-Slurper/pkg-descr
@@ -0,0 +1,4 @@
+This module provides functions for fast and correct slurping and spewing. All
+functions are optionally exported.
+
+WWW: https://metacpan.org/pod/File::Slurper
diff --git a/devel/p5-File-Slurper/pkg-plist b/devel/p5-File-Slurper/pkg-plist
new file mode 100644
index 000000000000..fefb7e7524a9
--- /dev/null
+++ b/devel/p5-File-Slurper/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/File/Slurper.pm
+%%PERL5_MAN3%%/File::Slurper.3.gz