aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/sflowtool/Makefile27
-rw-r--r--net/sflowtool/distinfo3
-rw-r--r--net/sflowtool/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 003768693a45..14d6b4088853 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -638,6 +638,7 @@
SUBDIR += sendsnpp
SUBDIR += ser
SUBDIR += serveez
+ SUBDIR += sflowtool
SUBDIR += sharity-light
SUBDIR += shmux
SUBDIR += silc-client
diff --git a/net/sflowtool/Makefile b/net/sflowtool/Makefile
new file mode 100644
index 000000000000..6cb8ef3ebb88
--- /dev/null
+++ b/net/sflowtool/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: sflowtool
+# Date created: 21 Mar 2006
+# Whom: Gregory Edigarov <greg@velcom.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sflowtool
+PORTVERSION= 3.9
+CATEGORIES= net
+MASTER_SITES= http://www.inmon.com/bin/
+
+MAINTAINER= greg@velcom.com
+COMMENT= This is a sFlow capture and sFlow-to-NetFlow conversion tool
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/sflowtool
+PORTDOCS= README
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/sflowtool/distinfo b/net/sflowtool/distinfo
new file mode 100644
index 000000000000..6aa757e2e9cb
--- /dev/null
+++ b/net/sflowtool/distinfo
@@ -0,0 +1,3 @@
+MD5 (sflowtool-3.9.tar.gz) = 1e7d2012ea2d84576e0077d695c8462c
+SHA256 (sflowtool-3.9.tar.gz) = 1ff824443354a49b8fb70c925b2e27a35b016ddfa69926da78a55fde5f2bb0a8
+SIZE (sflowtool-3.9.tar.gz) = 114317
diff --git a/net/sflowtool/pkg-descr b/net/sflowtool/pkg-descr
new file mode 100644
index 000000000000..c5a7b430118f
--- /dev/null
+++ b/net/sflowtool/pkg-descr
@@ -0,0 +1,3 @@
+This tool receives sFlow data, and generates either a simple-to-parse
+tagged-ASCII output, or binary output in tcpdump(1) format. It can also generate
+Cisco NetFlow version 5 datagrams and send them to a destination UDP host:port.