aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Astro-Sunrise/Makefile22
-rw-r--r--astro/p5-Astro-Sunrise/distinfo1
-rw-r--r--astro/p5-Astro-Sunrise/pkg-comment1
-rw-r--r--astro/p5-Astro-Sunrise/pkg-descr4
-rw-r--r--astro/p5-Astro-Sunrise/pkg-plist5
6 files changed, 34 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 77fdc01d4243..7d468d001112 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -10,6 +10,7 @@
SUBDIR += luna
SUBDIR += openuniverse
SUBDIR += p5-Astro-MoonPhase
+ SUBDIR += p5-Astro-Sunrise
SUBDIR += p5-Astro-SunTime
SUBDIR += p5-GPS
SUBDIR += p5-Geo-METAR
diff --git a/astro/p5-Astro-Sunrise/Makefile b/astro/p5-Astro-Sunrise/Makefile
new file mode 100644
index 000000000000..3bcb79720854
--- /dev/null
+++ b/astro/p5-Astro-Sunrise/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: astro/p5-Astro-Sunrise
+# Date created: 25 April 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-Sunrise
+PORTVERSION= 0.04
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Astro
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Astro::Sunrise.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-Sunrise/distinfo b/astro/p5-Astro-Sunrise/distinfo
new file mode 100644
index 000000000000..6e0292bced01
--- /dev/null
+++ b/astro/p5-Astro-Sunrise/distinfo
@@ -0,0 +1 @@
+MD5 (Astro-Sunrise-0.04.tar.gz) = 7e4bf28f778251b8542a6d08a225973f
diff --git a/astro/p5-Astro-Sunrise/pkg-comment b/astro/p5-Astro-Sunrise/pkg-comment
new file mode 100644
index 000000000000..8d4bdc90dc09
--- /dev/null
+++ b/astro/p5-Astro-Sunrise/pkg-comment
@@ -0,0 +1 @@
+Perl extension for computing the sunrise/sunset on a given day
diff --git a/astro/p5-Astro-Sunrise/pkg-descr b/astro/p5-Astro-Sunrise/pkg-descr
new file mode 100644
index 000000000000..5333aeea29b3
--- /dev/null
+++ b/astro/p5-Astro-Sunrise/pkg-descr
@@ -0,0 +1,4 @@
+This module returns the sunrise/sunset for a given day.
+
+-Anton
+<tobez@tobez.org>
diff --git a/astro/p5-Astro-Sunrise/pkg-plist b/astro/p5-Astro-Sunrise/pkg-plist
new file mode 100644
index 000000000000..0244a34da07a
--- /dev/null
+++ b/astro/p5-Astro-Sunrise/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro/Sunrise/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Astro/Sunrise.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro/Sunrise
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Astro 2>/dev/null || true