aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/hllib/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/games/hllib/Makefile b/games/hllib/Makefile
index 9ea5222a4ea8..63267d1b0da4 100644
--- a/games/hllib/Makefile
+++ b/games/hllib/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= games devel
MASTER_SITES= http://nemesis.thewavelength.net/files/files/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
-MAINTAINER= danilogondolfo@gmail.com
+MAINTAINER= danilo@FreeBSD.org
COMMENT= Library to work with various Half-Life file formats
LICENSE= LGPL21
@@ -24,11 +24,12 @@ HLLIB_VERS= 2.4.4
PLIST_FILES= include/hl.h lib/libhl.so.${HLLIB_VERS} \
lib/libhl.so.2 lib/libhl.so
-NO_STAGE= yes
+MAKE_ARGS= PREFIX="${STAGEDIR}${PREFIX}"
+
post-patch:
# Allow propagating of CXX, CXXFLAGS, and PREFIX; fix Linuxism and symlinks
- @${REINPLACE_CMD} -E 's,^([CP][^=]*)=,\1?=, ; s,g root,g wheel, ; \
- s,s \$$\(PREFIX\)/lib/,s ,' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E 's,^([CP][^=]*)=,\1?=, ; s,-g root,,g ; \
+ s,-o root,,g ; s,s \$$\(PREFIX\)/lib/,s ,' ${WRKSRC}/Makefile
# Add forgotten file to the source list so it would be picked up by linker
@${REINPLACE_CMD} -e 's,ProcStream\.cpp,& SGAFile.cpp,' \
${WRKSRC}/Makefile