aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Net-DNS-Codes/Makefile22
-rw-r--r--dns/p5-Net-DNS-Codes/distinfo3
-rw-r--r--dns/p5-Net-DNS-Codes/pkg-descr4
-rw-r--r--dns/p5-Net-DNS-Codes/pkg-plist8
5 files changed, 38 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index a49d97e0be82..8109d8da5f28 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -70,6 +70,7 @@
SUBDIR += p5-DNS-ZoneParse
SUBDIR += p5-Data-Validate-Domain
SUBDIR += p5-Net-DNS
+ SUBDIR += p5-Net-DNS-Codes
SUBDIR += p5-Net-DNS-SEC
SUBDIR += p5-Net-DNS-ZoneCheck
SUBDIR += p5-Net-DNS-ZoneFile
diff --git a/dns/p5-Net-DNS-Codes/Makefile b/dns/p5-Net-DNS-Codes/Makefile
new file mode 100644
index 000000000000..cdb880bdbe74
--- /dev/null
+++ b/dns/p5-Net-DNS-Codes/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-DNS-Codes
+# Date created: 2006-09-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNS-Codes
+PORTVERSION= 0.08
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Collection of C library DNS codes
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DNS::Codes.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS-Codes/distinfo b/dns/p5-Net-DNS-Codes/distinfo
new file mode 100644
index 000000000000..d79dfadb2355
--- /dev/null
+++ b/dns/p5-Net-DNS-Codes/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-DNS-Codes-0.08.tar.gz) = aeeb7c8afaa81b93e8c4c05b74d78155
+SHA256 (Net-DNS-Codes-0.08.tar.gz) = 66b956abb76ef6b9088c38e7696a95c9f737b415bf00e76f93bc87594d17190e
+SIZE (Net-DNS-Codes-0.08.tar.gz) = 305694
diff --git a/dns/p5-Net-DNS-Codes/pkg-descr b/dns/p5-Net-DNS-Codes/pkg-descr
new file mode 100644
index 000000000000..d325e9ef4788
--- /dev/null
+++ b/dns/p5-Net-DNS-Codes/pkg-descr
@@ -0,0 +1,4 @@
+Net::DNS::Codes provides forward and reverse lookup for most common C
+library DNS codes as well as all the codes for the DNS HEADER field.
+
+WWW: http://search.cpan.org/dist/Net-DNS-Codes/
diff --git a/dns/p5-Net-DNS-Codes/pkg-plist b/dns/p5-Net-DNS-Codes/pkg-plist
new file mode 100644
index 000000000000..72b57ed9bf7d
--- /dev/null
+++ b/dns/p5-Net-DNS-Codes/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/Codes/.packlist
+%%SITE_PERL%%/Net/DNS/Codes.pm
+@dirrmtry %%SITE_PERL%%/Net/DNS
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/Codes
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net