aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/guacamole-server/Makefile41
-rw-r--r--net/guacamole-server/distinfo5
-rw-r--r--net/guacamole-server/pkg-descr2
-rw-r--r--net/guacamole-server/pkg-plist18
4 files changed, 32 insertions, 34 deletions
diff --git a/net/guacamole-server/Makefile b/net/guacamole-server/Makefile
index 338079fbbd70..8515411da1de 100644
--- a/net/guacamole-server/Makefile
+++ b/net/guacamole-server/Makefile
@@ -2,14 +2,14 @@
# $FreeBSD$
PORTNAME= guacamole-server
-PORTVERSION= 0.9.9
-PORTREVISION= 3
+PORTVERSION= 0.9.10
+DISTVERSIONSUFFIX= -incubating
CATEGORIES= net
MAINTAINER= ultima1252@gmail.com
COMMENT= HTML5 Clientless Remote Desktop
-LICENSE= MIT
+LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libossp-uuid.so:misc/ossp-uuid \
@@ -18,16 +18,19 @@ LIB_DEPENDS= libossp-uuid.so:misc/ossp-uuid \
CONFLICTS_BUILD=pulseaudio-*+jack_* ffmpeg-*+jack_*
USE_GITHUB= yes
-GH_ACCOUNT= glyptodon
+GH_ACCOUNT= apache
+GH_PROJECT= incubator-guacamole-server
-USES= autoreconf jpeg libtool localbase pkgconfig shebangfix ssl
+USES= autoreconf gettext-runtime jpeg libtool localbase \
+ pkgconfig shebangfix ssl
USE_GNOME= cairo
SHEBANG_FILES= ${WRKSRC}/src/protocols/rdp/keymaps/generate.pl
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-guacd-conf=${PREFIX}/etc/guacd/guacd.conf
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
+INSTALL_TARGET= install-strip
+
USERS= guacamole
GROUPS= guacamole
@@ -35,9 +38,11 @@ USE_RC_SUBR= guacd
SUB_LIST+= GUACD_USER=${USERS} \
GUACD_GROUP=${GROUPS}
-OPTIONS_DEFINE= RDP SSH VNC VORBIS PULSEAUDIO WEBP
-OPTIONS_DEFAULT= RDP SSH VNC VORBIS PULSEAUDIO WEBP
+OPTIONS_DEFINE= RDP SSH VNC VORBIS PULSEAUDIO WEBP GUACENC
+OPTIONS_DEFAULT= RDP SSH VNC VORBIS PULSEAUDIO WEBP GUACENC
OPTIONS_SUB= yes
+GUACENC_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
+GUACENC_DESC?= Video Encoding Utility
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_DESC?= VNC audio support (Experimental)
RDP_LIB_DEPENDS= libfreerdp1.so:net/freerdp1
@@ -53,25 +58,11 @@ VORBIS_DESC?= Ogg Vorbis for compression
WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WEBP_DESC?= WebP support
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} 's|/etc/ssl|${PREFIX}/etc/ssl|g ; \
s|/etc/guacamole|${PREFIX}/etc/guacd|g' \
${WRKSRC}/src/guacd/man/guacd.conf.5
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libguac.so.*
-.if ${PORT_OPTIONS:MSSH}
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libguac-client-ssh.so.*
-.endif
-.if ${PORT_OPTIONS:MRDP}
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/freerdp/guacsnd-client.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/freerdp/guacdr-client.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/freerdp/guacsvc-client.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libguac-client-rdp.so.*
-.endif
-.if ${PORT_OPTIONS:MVNC}
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libguac-client-vnc.so.*
-.endif
+ @${REINPLACE_CMD} 's/-Werror//' \
+ ${WRKSRC}/src/guacenc/Makefile.am
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/guacamole-server/distinfo b/net/guacamole-server/distinfo
index a3ffa8ba3f8b..cf47478906c5 100644
--- a/net/guacamole-server/distinfo
+++ b/net/guacamole-server/distinfo
@@ -1,2 +1,3 @@
-SHA256 (glyptodon-guacamole-server-0.9.9_GH0.tar.gz) = 53d26e2e7e028b0d9fbc502b94acd02e2d04e3a491c8be4a3e16290c2ec58321
-SIZE (glyptodon-guacamole-server-0.9.9_GH0.tar.gz) = 265031
+TIMESTAMP = 1485059653
+SHA256 (apache-incubator-guacamole-server-0.9.10-incubating_GH0.tar.gz) = e123d1a43d03b0104dc41c480612e0757cd34a636dee538b62a6c4f810efd65e
+SIZE (apache-incubator-guacamole-server-0.9.10-incubating_GH0.tar.gz) = 377895
diff --git a/net/guacamole-server/pkg-descr b/net/guacamole-server/pkg-descr
index 7707649e2e32..b61d6109abf5 100644
--- a/net/guacamole-server/pkg-descr
+++ b/net/guacamole-server/pkg-descr
@@ -10,4 +10,4 @@ operations needed for efficient remote desktop access, but would
be easy for JavaScript programs to process. guacd is the proxy which
translates between arbitrary protocols and the Guacamole protocol.
-WWW: https://github.com/glyptodon/guacamole-server
+WWW: http://guacamole.incubator.apache.org
diff --git a/net/guacamole-server/pkg-plist b/net/guacamole-server/pkg-plist
index d253239757a6..927ed94478fb 100644
--- a/net/guacamole-server/pkg-plist
+++ b/net/guacamole-server/pkg-plist
@@ -8,15 +8,14 @@ include/guacamole/client.h
include/guacamole/error-types.h
include/guacamole/error.h
include/guacamole/hash.h
-include/guacamole/instruction-constants.h
-include/guacamole/instruction-types.h
-include/guacamole/instruction.h
+include/guacamole/parser-constants.h
+include/guacamole/parser-types.h
+include/guacamole/parser.h
include/guacamole/layer-types.h
include/guacamole/layer.h
include/guacamole/object-types.h
include/guacamole/object.h
include/guacamole/plugin-constants.h
-include/guacamole/plugin-types.h
include/guacamole/plugin.h
include/guacamole/pool-types.h
include/guacamole/pool.h
@@ -31,6 +30,11 @@ include/guacamole/stream.h
include/guacamole/timestamp-types.h
include/guacamole/timestamp.h
include/guacamole/unicode.h
+include/guacamole/user-constants.h
+include/guacamole/user-fntypes.h
+include/guacamole/user-types.h
+include/guacamole/user.h
+%%RDP%%lib/freerdp/guacai-client.so
%%RDP%%lib/freerdp/guacdr-client.so
%%RDP%%lib/freerdp/guacsnd-client.so
%%RDP%%lib/freerdp/guacsvc-client.so
@@ -48,8 +52,10 @@ include/guacamole/unicode.h
%%VNC%%lib/libguac-client-vnc.so.0.0.0
lib/libguac.a
lib/libguac.so
-lib/libguac.so.11
-lib/libguac.so.11.0.0
+lib/libguac.so.12
+lib/libguac.so.12.0.0
man/man5/guacd.conf.5.gz
man/man8/guacd.8.gz
+%%GUACENC%%man/man1/guacenc.1.gz
sbin/guacd
+%%GUACENC%%bin/guacenc