aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/gauche-gdbm/Makefile2
-rw-r--r--lang/gauche/Makefile2
-rw-r--r--lang/gauche/distinfo2
-rw-r--r--lang/gauche/files/patch-src-gauche-arith_i386.h20
-rw-r--r--lang/gauche/pkg-plist10
5 files changed, 13 insertions, 23 deletions
diff --git a/databases/gauche-gdbm/Makefile b/databases/gauche-gdbm/Makefile
index 7e25f4aa8aad..dc4ae4500a2d 100644
--- a/databases/gauche-gdbm/Makefile
+++ b/databases/gauche-gdbm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gdbm
-PORTVERSION= 0.6.5
+PORTVERSION= 0.6.6 # Keep this in sync with lang/gauche
CATEGORIES= databases
MASTER_SITES= # none
PKGNAMEPREFIX= gauche-
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index dbb8003b6a92..a6e4d184da49 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gauche
-PORTVERSION= 0.6.5
+PORTVERSION= 0.6.6 # Keep databases/gauche-gdbm in sync with this
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/lang/gauche/distinfo b/lang/gauche/distinfo
index ed6a361b1135..4b9de9f4c30e 100644
--- a/lang/gauche/distinfo
+++ b/lang/gauche/distinfo
@@ -1 +1 @@
-MD5 (Gauche-0.6.5.tgz) = b11ddd0c91cea063b727518ca4c9199a
+MD5 (Gauche-0.6.6.tgz) = 6e32f2c52ebd4f38c0c207ec6a2fc339
diff --git a/lang/gauche/files/patch-src-gauche-arith_i386.h b/lang/gauche/files/patch-src-gauche-arith_i386.h
deleted file mode 100644
index 020d0040dc67..000000000000
--- a/lang/gauche/files/patch-src-gauche-arith_i386.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/gauche/arith_i386.h.orig Sun Sep 22 19:48:19 2002
-+++ src/gauche/arith_i386.h Sun Sep 22 19:49:05 2002
-@@ -23,6 +23,8 @@
- * r <- x + y + c mod wordsize
- * c <- 1 if carry, 0 otherwise
- */
-+/* bad register voodoo... let the 'portable' version catch this.
-+ fails on both 4.2-release and 5.0-current
-
- #define UADD(r, c, x, y) \
- asm("shrl $1, %2;" \
-@@ -32,7 +34,7 @@
- "rcll $1, %1;" \
- :"=&r" (r), "=&r" (c) \
- :"1" (c), "g"(x), "g"(y))
--
-+*/
- /*-----------------------------------------------------------------
- * UADDOV(r, v, x, y) unsigned word add with overflow check
- * u_long : r, v, x, y;
diff --git a/lang/gauche/pkg-plist b/lang/gauche/pkg-plist
index 1a0f60eb7714..6ab61effdc7a 100644
--- a/lang/gauche/pkg-plist
+++ b/lang/gauche/pkg-plist
@@ -9,8 +9,10 @@ lib/gauche/%%VERSION%%/%%TARGET%%/libgauche.a
lib/gauche/%%VERSION%%/%%TARGET%%/libgauche.so
lib/gauche/%%VERSION%%/%%TARGET%%/libnet.so
lib/gauche/%%VERSION%%/%%TARGET%%/libuvector.so
+lib/gauche/%%VERSION%%/%%TARGET%%/md5.so
lib/gauche/%%VERSION%%/%%TARGET%%/mt-random.so
lib/gauche/%%VERSION%%/%%TARGET%%/ndbm.so
+lib/gauche/%%VERSION%%/%%TARGET%%/sha1.so
lib/gauche/%%VERSION%%/%%TARGET%%/syslog.so
lib/gauche/%%VERSION%%/%%TARGET%%/termios.so
lib/gauche/%%VERSION%%/%%TARGET%%/threads.so
@@ -63,11 +65,13 @@ share/gauche/%%VERSION%%/lib/gauche/common-macros.scm
share/gauche/%%VERSION%%/lib/gauche/config.scm
share/gauche/%%VERSION%%/lib/gauche/defvalues.scm
share/gauche/%%VERSION%%/lib/gauche/fcntl.scm
+share/gauche/%%VERSION%%/lib/gauche/hook.scm
share/gauche/%%VERSION%%/lib/gauche/interactive.scm
share/gauche/%%VERSION%%/lib/gauche/interactive/info.scm
share/gauche/%%VERSION%%/lib/gauche/interpolate.scm
share/gauche/%%VERSION%%/lib/gauche/let-opt.scm
share/gauche/%%VERSION%%/lib/gauche/listener.scm
+share/gauche/%%VERSION%%/lib/gauche/listutil.scm
share/gauche/%%VERSION%%/lib/gauche/logger.scm
share/gauche/%%VERSION%%/lib/gauche/logical.scm
share/gauche/%%VERSION%%/lib/gauche/macroutil.scm
@@ -91,6 +95,7 @@ share/gauche/%%VERSION%%/lib/gauche/serializer.scm
share/gauche/%%VERSION%%/lib/gauche/serializer/aserializer.scm
share/gauche/%%VERSION%%/lib/gauche/signal.scm
share/gauche/%%VERSION%%/lib/gauche/singleton.scm
+share/gauche/%%VERSION%%/lib/gauche/stringutil.scm
share/gauche/%%VERSION%%/lib/gauche/syslog.scm
share/gauche/%%VERSION%%/lib/gauche/termios.scm
share/gauche/%%VERSION%%/lib/gauche/test.scm
@@ -108,8 +113,11 @@ share/gauche/%%VERSION%%/lib/math/mt-random.scm
share/gauche/%%VERSION%%/lib/rfc/822.scm
share/gauche/%%VERSION%%/lib/rfc/base64.scm
share/gauche/%%VERSION%%/lib/rfc/cookie.scm
+share/gauche/%%VERSION%%/lib/rfc/hmac.scm
share/gauche/%%VERSION%%/lib/rfc/http.scm
+share/gauche/%%VERSION%%/lib/rfc/md5.scm
share/gauche/%%VERSION%%/lib/rfc/quoted-printable.scm
+share/gauche/%%VERSION%%/lib/rfc/sha1.scm
share/gauche/%%VERSION%%/lib/rfc/uri.scm
share/gauche/%%VERSION%%/lib/slib.scm
share/gauche/%%VERSION%%/lib/srfi-0.scm
@@ -152,6 +160,7 @@ share/gauche/%%VERSION%%/lib/srfi-19/read-tai.scm
share/gauche/%%VERSION%%/lib/srfi-2.scm
share/gauche/%%VERSION%%/lib/srfi-26.scm
share/gauche/%%VERSION%%/lib/srfi-27.scm
+share/gauche/%%VERSION%%/lib/srfi-31.scm
share/gauche/%%VERSION%%/lib/srfi-4.scm
share/gauche/%%VERSION%%/lib/srfi-9.scm
share/gauche/%%VERSION%%/lib/text/csv.scm
@@ -160,6 +169,7 @@ share/gauche/%%VERSION%%/lib/text/info.scm
share/gauche/%%VERSION%%/lib/text/parse.scm
share/gauche/%%VERSION%%/lib/text/tr.scm
share/gauche/%%VERSION%%/lib/text/tree.scm
+share/gauche/%%VERSION%%/lib/util/digest.scm
share/gauche/%%VERSION%%/lib/util/isomorph.scm
share/gauche/%%VERSION%%/lib/util/queue.scm
share/gauche/%%VERSION%%/lib/util/toposort.scm