aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING15
-rw-r--r--mail/maildrop/Makefile16
-rw-r--r--mail/maildrop/pkg-plist1
3 files changed, 26 insertions, 6 deletions
diff --git a/UPDATING b/UPDATING
index 6f97b880164c..de63761e0816 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,21 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20140930:
+ AFFECTS: users of mail/maildrop
+ AUTHOR: madpilot@FreeBSD.org
+
+ Due to the way pkg works please note that the configuration
+ variables MAILDROP_SUID and MAILDROP_SGID, despite keeping their
+ old names, are now required to contain a valid username and
+ groupname existing on the system in which the package will be
+ installed, while in the past numeric uids and gids worked fine.
+
+ Wrong values will cause pkg to skip installing the setuid binaries
+ on the system.
+
+ Please check your configuration.
+
+20140930:
AFFECTS: users of finance/gnucash
AUTHOR: madpilot@FreeBSD.org
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index 0adcd00170bb..7715cc0316c9 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -3,14 +3,20 @@
# You can define the following to enable further compile time
# customizations:
-# MAILDROP_SUID=<uid>,
-# MAILDROP_SGID=<gid> Maildrop will be installed with suid permissions for
-# MAILDROP_SUID, and sgid permissions for MAILDROP_SGID.
+# MAILDROP_SUID=<username>,
+# MAILDROP_SGID=<groupname> Maildrop will be installed with suid
+# permissions for MAILDROP_SUID, and sgid
+# permissions for MAILDROP_SGID.
+# NOTE: must be a valid username/groupname
+# at installation time, numeric uids/gids
+# and non existing users will cause the
+# installed package to miss files.
# MAILDROP_TRUSTED_USERS=<user> Specify users allowed to use the -d option
# MAILDROP_LOG_COLUMNS lenght of 'File:' line in log - 8; default: 72
PORTNAME= maildrop
PORTVERSION= 2.7.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/courier/${PORTNAME}/${PORTVERSION}
@@ -78,10 +84,10 @@ CONFIGURE_ARGS+= --enable-maildrop-uid="${MAILDROP_SUID}" --enable-maildrop-gid=
PLIST_SUB+= MMODE='6755' MUID='${MAILDROP_SUID}' MGID='${MAILDROP_SGID}'
.elif defined(MAILDROP_SUID)
CONFIGURE_ARGS+= --enable-maildrop-uid="${MAILDROP_SUID}"
-PLIST_SUB+= MMODE='4755' MUID='${MAILDROP_SUID}'
+PLIST_SUB+= MMODE='4755' MUID='${MAILDROP_SUID}' MGID='mail'
.elif defined(MAILDROP_SGID)
CONFIGURE_ARGS+= --enable-maildrop-gid="${MAILDROP_SGID}"
-PLIST_SUB+= MMODE='2755' MGID='${MAILDROP_SGID}'
+PLIST_SUB+= MMODE='2755' MGID='${MAILDROP_SGID}' MUID='root'
.else
PLIST_SUB+= MMODE='' MUID='root' MGID='mail'
.endif
diff --git a/mail/maildrop/pkg-plist b/mail/maildrop/pkg-plist
index ff64c102fe3d..93a98de08fec 100644
--- a/mail/maildrop/pkg-plist
+++ b/mail/maildrop/pkg-plist
@@ -63,4 +63,3 @@ man/man8/maildrop-deliverquota.8.gz
%%PORTDOCS%%%%DOCSDIR%%/reformime.html
%%PORTDOCS%%%%DOCSDIR%%/rfc2045.html
%%PORTDOCS%%%%DOCSDIR%%/rfc822.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%