aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/timeless/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/timeless/Makefile b/graphics/timeless/Makefile
index 99ef4874a435..ff9324d53341 100644
--- a/graphics/timeless/Makefile
+++ b/graphics/timeless/Makefile
@@ -12,9 +12,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= FreeBSD/SDL port of Tran's Timeless Demo with Sound
USE_SDL= sdl mixer
+LDFLAGS+= -lm
-PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/time.s3m
+PLIST_FILES= bin/timeless %%DATADIR%%/time.s3m
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/timeless ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/time.s3m ${STAGEDIR}${DATADIR}
+
.include <bsd.port.mk>