aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/gnome-gmail-notifier/Makefile29
-rw-r--r--mail/gnome-gmail-notifier/distinfo3
-rw-r--r--mail/gnome-gmail-notifier/pkg-descr12
-rw-r--r--mail/gnome-gmail-notifier/pkg-plist15
5 files changed, 60 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index c1f9e94e6a52..e359997c667a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -153,6 +153,7 @@
SUBDIR += gmime2-sharp
SUBDIR += gnarwl
SUBDIR += gnubiff
+ SUBDIR += gnome-gmail-notifier
SUBDIR += gnumail
SUBDIR += gotmail
SUBDIR += grepmail
diff --git a/mail/gnome-gmail-notifier/Makefile b/mail/gnome-gmail-notifier/Makefile
new file mode 100644
index 000000000000..d04695f645b3
--- /dev/null
+++ b/mail/gnome-gmail-notifier/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gnome-gmail-notifier
+# Date created: Nov 16 2007
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-gmail-notifier
+PORTVERSION= 0.9.1
+CATEGORIES= mail deskutils
+MASTER_SITES= http://${PORTNAME}.googlecode.com/files/
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= A Gmail Inbox Monitor for the GNOME2 desktop
+
+LIB_PC_DEPENDS= libnotify:devel/libnotify \
+ libsoup-2.2:devel/libsoup \
+ gnutls:security:/gnutls
+
+BUILD_DEPENDS= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|:C|:|.pc:${PORTSDIR}/|}
+RUN_DEPENDS= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|:C|:|.pc:${PORTSDIR}/|}
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 gtk20 libgnome libgnomeui libxml2 libglade2
+
+.include <bsd.port.mk>
+
diff --git a/mail/gnome-gmail-notifier/distinfo b/mail/gnome-gmail-notifier/distinfo
new file mode 100644
index 000000000000..ce3fae8b649d
--- /dev/null
+++ b/mail/gnome-gmail-notifier/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome-gmail-notifier-0.9.1.tar.bz2) = 69d8fd8950c9a5cab2f7f25208f295e9
+SHA256 (gnome-gmail-notifier-0.9.1.tar.bz2) = f17024807a267304efb0ea13c4a0ed777bf635830d6ff8ca2a7ff99b2eb669bd
+SIZE (gnome-gmail-notifier-0.9.1.tar.bz2) = 252901
diff --git a/mail/gnome-gmail-notifier/pkg-descr b/mail/gnome-gmail-notifier/pkg-descr
new file mode 100644
index 000000000000..b8a68c94a353
--- /dev/null
+++ b/mail/gnome-gmail-notifier/pkg-descr
@@ -0,0 +1,12 @@
+The Gnome Gmail Notifier project aims to provide a stable, efficient
+GTK+2.0 application that provides periodic updates that pertain to the
+user's gmail inbox.
+
+The Notifier presents itself as a system tray icon in the GNOME2
+desktop, displaying a small balloon popup when the user recieves new
+mail.
+
+WWW: http://code.google.com/p/gnome-gmail-notifier/
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/mail/gnome-gmail-notifier/pkg-plist b/mail/gnome-gmail-notifier/pkg-plist
new file mode 100644
index 000000000000..6769dd9064bb
--- /dev/null
+++ b/mail/gnome-gmail-notifier/pkg-plist
@@ -0,0 +1,15 @@
+bin/gnome-gmail-notifier
+share/applications/gnome-gmail-notifier.desktop
+share/gnome-gmail-notifier/ggn-about.glade
+share/gnome-gmail-notifier/ggn-edit.glade
+share/gnome-gmail-notifier/ggn-error.svg
+share/gnome-gmail-notifier/ggn-menu.glade
+share/gnome-gmail-notifier/ggn-new.svg
+share/gnome-gmail-notifier/ggn-normal.svg
+share/gnome-gmail-notifier/ggn-prefs.glade
+share/gnome-gmail-notifier/ggn-wait.svg
+share/gnome-gmail-notifier/welcome-logo.png
+share/gnome-gmail-notifier/welcome-shot.png
+share/gnome-gmail-notifier/welcome.css
+share/gnome-gmail-notifier/welcome.html
+@dirrm share/gnome-gmail-notifier