aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/plasma5-plasma-workspace/Makefile6
-rw-r--r--x11/plasma5-plasma-workspace/files/patch-setup_xdg_environment28
2 files changed, 13 insertions, 21 deletions
diff --git a/x11/plasma5-plasma-workspace/Makefile b/x11/plasma5-plasma-workspace/Makefile
index f0d6fb6851ec..ec8d942be7a4 100644
--- a/x11/plasma5-plasma-workspace/Makefile
+++ b/x11/plasma5-plasma-workspace/Makefile
@@ -1,6 +1,6 @@
PORTNAME= plasma-workspace
DISTVERSION= ${KDE_PLASMA_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -60,6 +60,10 @@ CMAKE_OFF= BUILD_TESTING
# In 5.15 a file was moved from x11/plasma5-plasma-desktop to x11/plasma5-plasma-workspace:
CONFLICTS_INSTALL= plasma5-plasma-desktop-5.14.*
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${PATCH_WRKSRC}/startkde/startplasma.cpp
+
post-stage:
${INSTALL_SCRIPT} ${FILESDIR}/startplasma-wayland.sh ${STAGEDIR}/${LOCALBASE}/bin/
diff --git a/x11/plasma5-plasma-workspace/files/patch-setup_xdg_environment b/x11/plasma5-plasma-workspace/files/patch-setup_xdg_environment
index 29f094a1ef93..9b580910b77a 100644
--- a/x11/plasma5-plasma-workspace/files/patch-setup_xdg_environment
+++ b/x11/plasma5-plasma-workspace/files/patch-setup_xdg_environment
@@ -1,23 +1,11 @@
--- startkde/startplasma.cpp.orig 2019-10-19 18:43:24.172713000 +0200
+++ startkde/startplasma.cpp 2019-10-19 18:45:50.953945000 +0200
-@@ -192,6 +192,10 @@
- if (!qEnvironmentVariableIsSet("XDG_DATA_DIRS")) {
- qputenv("XDG_DATA_DIRS", KDE_INSTALL_FULL_DATAROOTDIR ":/usr/share:/usr/local/share");
+@@ -362,6 +362,6 @@
+ // Add kdedefaults dir to allow config defaults overriding from a writable location
+ QByteArray currentConfigDirs = qgetenv("XDG_CONFIG_DIRS");
+ if (currentConfigDirs.isEmpty()) {
+- currentConfigDirs = "/etc/xdg";
++ currentConfigDirs = "%%LOCALBASE%%/etc/xdg:/etc/xdg";
}
-+ // Additionally also set default value for XDG_CONFIG_DIRS which is not set by default on FreeBSD.
-+ if (!qEnvironmentVariableIsSet("XDG_CONFIG_DIRS")) {
-+ qputenv("XDG_CONFIG_DIRS", KDE_INSTALL_FULL_CONFDIR ":/etc/xdg:/usr/local/etc/xdg");
-+ }
- }
-
-
---- startkde/config-startplasma.h.cmake.orig 2019-10-19 18:56:51.844465000 +0200
-+++ startkde/config-startplasma.h.cmake 2019-10-19 18:57:22.843807000 +0200
-@@ -3,6 +3,7 @@
-
- #define CMAKE_INSTALL_FULL_BINDIR "@CMAKE_INSTALL_FULL_BINDIR@"
- #define KDE_INSTALL_FULL_DATAROOTDIR "@KDE_INSTALL_FULL_DATAROOTDIR@"
-+#define KDE_INSTALL_FULL_CONFDIR "@KDE_INSTALL_FULL_CONFDIR@"
- #define CMAKE_INSTALL_FULL_LIBEXECDIR "@CMAKE_INSTALL_FULL_LIBEXECDIR@"
- #define CMAKE_INSTALL_FULL_LIBEXECDIR_KF5 "@CMAKE_INSTALL_FULL_LIBEXECDIR_KF5@"
- #define KWIN_WAYLAND_BIN_PATH "@KWIN_WAYLAND_BIN_PATH@"
+ const auto extraConfigDir = QStandardPaths::writableLocation(QStandardPaths::GenericConfigLocation).toUtf8() + "/kdedefaults";
+ QDir().mkpath(QString::fromUtf8(extraConfigDir));