aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/kid3-kde4/Makefile73
-rw-r--r--deskutils/kchmviewer-kde4/Makefile6
-rw-r--r--editors/kile-kde4/Makefile8
-rw-r--r--irc/konversation-kde4/Makefile6
-rw-r--r--multimedia/subtitlecomposer-kde4/Makefile4
-rw-r--r--net/knemo-kde4/Makefile9
-rw-r--r--science/kst2/Makefile30
-rw-r--r--sysutils/krename-kde4/Makefile8
-rw-r--r--x11-toolkits/qwt5-designerplugin/Makefile4
-rw-r--r--x11-toolkits/qwt5/Makefile1
-rw-r--r--x11-toolkits/qwt6-designerplugin/Makefile6
-rw-r--r--x11-toolkits/qwt6/Makefile7
12 files changed, 50 insertions, 112 deletions
diff --git a/audio/kid3-kde4/Makefile b/audio/kid3-kde4/Makefile
index c3708a24ed37..9dcd5a4b8e56 100644
--- a/audio/kid3-kde4/Makefile
+++ b/audio/kid3-kde4/Makefile
@@ -11,8 +11,6 @@ COMMENT= MP3/Ogg/FLAC tag editor for KDE
LICENSE= GPLv2
-LATEST_LINK= ${PORTNAME}-kde4
-
USE_KDE4= kdelibs kdeprefix kdehier automoc4
NO_STAGE= yes
USE_QT4= qmake_build moc_build rcc_build uic_build
@@ -22,57 +20,36 @@ OPTIONS_DEFINE= FLAC ID3LIB MP4V2 VORBIS TAGLIB CHROMAPRINT
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
FLAC_DESC= Support for FLAC files
-ID3LIB_DESC= Support for mp3 files
-MP4V2_DESC= Support for mp4 files
-VORBIS_DESC= Support for Ogg/Vorbis files
-TAGLIB_DESC= Support for various audio formats
-CHROMAPRINT_DESC= Support for Chromaprint audio fingerprints
-
-.include <bsd.port.options.mk>
+FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
+FLAC_CMAKE_ON= -DWITH_FLAC=ON
+FLAC_CMAKE_OFF= -DWITH_FLAC=OFF
-.if ${PORT_OPTIONS:MFLAC}
-CMAKE_ARGS+= -DWITH_FLAC=ON
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
-.else
-CMAKE_ARGS+= -DWITH_FLAC=OFF
-.endif
-
-.if ${PORT_OPTIONS:MID3LIB}
-CMAKE_ARGS+= -DWITH_ID3LIB=ON
-LIB_DEPENDS+= id3-3.8.3:${PORTSDIR}/audio/id3lib
-.else
-CMAKE_ARGS+= -DWITH_ID3LIB=OFF
-.endif
+ID3LIB_DESC= Support for mp3 files
+ID3LIB_LIB_DEPENDS= libid3-3.8.so:${PORTSDIR}/audio/id3lib
+ID3LIB_CMAKE_ON= -DWITH_ID3LIB=ON
+ID3LIB_CMAKE_OFF= -DWITH_ID3LIB=OFF
-.if ${PORT_OPTIONS:MMP4V2}
-CMAKE_ARGS+= -DWITH_MP4V2=ON
-LIB_DEPENDS+= mp4v2.10:${PORTSDIR}/multimedia/mp4v2
-.else
-CMAKE_ARGS+= -DWITH_MP4V2=OFF
-.endif
+MP4V2_DESC= Support for mp4 files
+MP4V2_LIB_DEPENDS= libmp4v2.so:${PORTSDIR}/multimedia/mp4v2
+MP4V2_CMAKE_ON= -DWITH_MP4V2=ON
+MP4V2_CMAKE_OFF= -DWITH_MP4V2=OFF
-.if ${PORT_OPTIONS:MVORBIS}
-CMAKE_ARGS+= -DWITH_VORBIS=ON
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis \
- ogg:${PORTSDIR}/audio/libogg
-.else
-CMAKE_ARGS+= -DWITH_VORBIS=OFF
-.endif
+VORBIS_DESC= Support for Ogg/Vorbis files
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libogg.so:${PORTSDIR}/audio/libogg
+VORBIS_CMAKE_ON= -DWITH_VORBIS=ON
+VORBIS_CMAKE_OFF= -DWITH_VORBIS=OFF
-.if ${PORT_OPTIONS:MTAGLIB}
-CMAKE_ARGS+= -DWITH_TAGLIB=ON
-LIB_DEPENDS+= tag.1:${PORTSDIR}/audio/taglib
-.else
-CMAKE_ARGS+= -DWITH_TAGLIB=OFF
-.endif
+TAGLIB_DESC= Support for various audio formats
+TAGLIB_LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib
+TAGLIB_CMAKE_ON= -DWITH_TAGLIB=ON
+TAGLIB_CMAKE_OFF= -DWITH_TAGLIB=OFF
-.if ${PORT_OPTIONS:MCHROMAPRINT}
-CMAKE_ARGS+= -DWITH_CHROMAPRINT=ON \
- -DWITH_FFMPEG=ON
-LIB_DEPENDS+= chromaprint:${PORTSDIR}/audio/chromaprint
-.else
-CMAKE_ARGS+= -DWITH_CHROMAPRINT=OFF
-.endif
+CHROMAPRINT_DESC= Support for Chromaprint audio fingerprints
+CHROMAPRINT_LIB_DEPENDS= libchromaprint.so:${PORTSDIR}/audio/chromaprint
+CHROMAPRINT_CMAKE_ON= -DWITH_CHROMAPRINT=ON \
+ -DWITH_FFMPEG=ON
+CHROMAPRINT_CMAKE_OFF= -DWITH_CHROMAPRINT=OFF
pre-configure:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/CMakeLists.txt
diff --git a/deskutils/kchmviewer-kde4/Makefile b/deskutils/kchmviewer-kde4/Makefile
index 7b4d9f8e3730..ebb2f88e1ed8 100644
--- a/deskutils/kchmviewer-kde4/Makefile
+++ b/deskutils/kchmviewer-kde4/Makefile
@@ -8,11 +8,9 @@ CATEGORIES= deskutils kde
MASTER_SITES= SF
MAINTAINER= makc@FreeBSD.org
-COMMENT= A Qt/KDE viewer for CHM files
+COMMENT= Qt/KDE viewer for CHM files
-LIB_DEPENDS= chm.0:${PORTSDIR}/misc/chmlib
-
-LATEST_LINK= ${PORTNAME}-kde4
+LIB_DEPENDS= libchm.so:${PORTSDIR}/misc/chmlib
USES= cmake
USE_KDE4= kdeprefix kdelibs automoc4
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index cd5f02fcea25..dfbb4558cd3a 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -17,16 +17,10 @@ USE_QT4= qmake_build moc_build rcc_build uic_build
USE_KDE4= kdeprefix kdelibs automoc4 sharedmime kate_run
USE_TEX= latex
-LATEST_LINK= ${PORTNAME}-kde4
-
OPTIONS_DEFINE= OKULAR
OKULAR_DESC= Use Okular for viewing
+OKULAR_USE= KDE4=okular_run
NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOKULAR}
-USE_KDE4+= okular_run
-.endif
.include <bsd.port.mk>
diff --git a/irc/konversation-kde4/Makefile b/irc/konversation-kde4/Makefile
index 112d3bfe3996..e3ab0b922d03 100644
--- a/irc/konversation-kde4/Makefile
+++ b/irc/konversation-kde4/Makefile
@@ -9,11 +9,9 @@ MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${DISTVERSION}/src
MAINTAINER= makc@FreeBSD.org
-COMMENT= A user friendly IRC client for KDE
+COMMENT= User friendly IRC client for KDE
-LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
-
-LATEST_LINK= ${PORTNAME}-kde4
+LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca
USE_XZ= yes
USES= cmake
diff --git a/multimedia/subtitlecomposer-kde4/Makefile b/multimedia/subtitlecomposer-kde4/Makefile
index 942c29f87397..641fbe933e25 100644
--- a/multimedia/subtitlecomposer-kde4/Makefile
+++ b/multimedia/subtitlecomposer-kde4/Makefile
@@ -14,8 +14,6 @@ USES= cmake
USE_KDE4= kdeprefix kdelibs automoc4 sharedmime
USE_QT4= gui qmake_build moc_build rcc_build uic_build
-LATEST_LINK= ${PORTNAME}-kde4
-
OPTIONS_DEFINE= GSTREAMER MPLAYER XINE
OPTIONS_DEFAULT= MPLAYER
@@ -31,7 +29,7 @@ RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
.if ${PORT_OPTIONS:MXINE}
-LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS+= libxine.so:${PORTSDIR}/multimedia/libxine
.else
CMAKE_ARGS+= -DWITH_Xine:Bool=Off
.endif
diff --git a/net/knemo-kde4/Makefile b/net/knemo-kde4/Makefile
index 909c0e3bd95f..eb205fe50aa1 100644
--- a/net/knemo-kde4/Makefile
+++ b/net/knemo-kde4/Makefile
@@ -9,8 +9,6 @@ DISTNAME= 12956-${PORTNAME}-${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= KDE network monitor
-LATEST_LINK= ${PORTNAME}-kde4
-
USE_BZIP2= yes
USES= cmake
USE_QT4= qmake_build moc_build uic_build rcc_build
@@ -19,10 +17,5 @@ USE_KDE4= kdeprefix kdelibs workspace automoc4
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800000
-BROKEN= does not build on 7.X
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index c39a45e7187b..fb508c7ae2c9 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -12,8 +12,6 @@ COMMENT= Data viewing and plotting tool
LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
-LATEST_LINK= kst2
-
USES= cmake
USE_QT4= gui xml designer svg opengl \
qmake_build moc_build rcc_build uic_build
@@ -28,33 +26,19 @@ PLIST_SUB= SHLIB_VER=${PORTVERSION}
OPTIONS_DEFINE= FITS MATLAB NETCDF
FITS_DESC= Support for data in FITS format
+FITS_LIB_DEPENDS= libcfitsio.so:${PORTSDIR}/astro/cfitsio
+
MATLAB_DESC= Support for data in MATLAB format
+MATLAB_BUILD_DEPENDS= ${LOCALBASE}/lib/libmatio.a:${PORTSDIR}/math/matio
+
NETCDF_DESC= Support for data in NetCDF format
+NETCDF_LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
+
+OPTIONS_SUB= yes
NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MFITS}
-LIB_DEPENDS+= cfitsio.0:${PORTSDIR}/astro/cfitsio
-PLIST_SUB+= FITS=""
-.else
-PLIST_SUB+= FITS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMATLAB}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libmatio.a:${PORTSDIR}/math/matio
-PLIST_SUB+= MATLAB=""
-.else
-PLIST_SUB+= MATLAB="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNETCDF}
-LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
-PLIST_SUB+= NETCDF=""
-.else
-PLIST_SUB+= NETCDF="@comment "
-.endif
-
post-patch:
${REINPLACE_CMD} -e '/^Exec=kst2/s,\(kst2\).*,\1 %f,' \
${WRKSRC}/src/kst/kst2.desktop
diff --git a/sysutils/krename-kde4/Makefile b/sysutils/krename-kde4/Makefile
index fc679ca3397d..a8481c29f902 100644
--- a/sysutils/krename-kde4/Makefile
+++ b/sysutils/krename-kde4/Makefile
@@ -9,11 +9,9 @@ MASTER_SITES= SF/${PORTNAME}/KDE4%20${PORTNAME}-stable/${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Very powerful batch file renamer for KDE
-LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib \
- exiv2.12:${PORTSDIR}/graphics/exiv2 \
- podofo.0:${PORTSDIR}/graphics/podofo
-
-LATEST_LINK= ${PORTNAME}-kde4
+LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
+ libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libpodofo.so:${PORTSDIR}/graphics/podofo
USE_BZIP2= yes
USES= cmake:outsource
diff --git a/x11-toolkits/qwt5-designerplugin/Makefile b/x11-toolkits/qwt5-designerplugin/Makefile
index 7637196a87c6..59156a325d19 100644
--- a/x11-toolkits/qwt5-designerplugin/Makefile
+++ b/x11-toolkits/qwt5-designerplugin/Makefile
@@ -4,12 +4,12 @@ PORTNAME= qwt
PORTVERSION= 5.2.3
CATEGORIES= x11-toolkits devel
MASTER_SITES= SF
-PKGNAMESUFFIX= -designerplugin
+PKGNAMESUFFIX= 5-designerplugin
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt Designer plugin for Qwt
-LIB_DEPENDS= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+LIB_DEPENDS= libqwt.so:${PORTSDIR}/x11-toolkits/qwt5
USE_QT4= designer moc_build qmake_build rcc_build
USE_BZIP2= yes
diff --git a/x11-toolkits/qwt5/Makefile b/x11-toolkits/qwt5/Makefile
index 19a3fa57f112..2a797d0b6202 100644
--- a/x11-toolkits/qwt5/Makefile
+++ b/x11-toolkits/qwt5/Makefile
@@ -4,6 +4,7 @@ PORTNAME= qwt
PORTVERSION= 5.2.3
CATEGORIES= x11-toolkits
MASTER_SITES= SF
+PKGNAMESUFFIX= 5
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt Widgets for Technical Applications
diff --git a/x11-toolkits/qwt6-designerplugin/Makefile b/x11-toolkits/qwt6-designerplugin/Makefile
index 3d03b331869f..155ec476c68c 100644
--- a/x11-toolkits/qwt6-designerplugin/Makefile
+++ b/x11-toolkits/qwt6-designerplugin/Makefile
@@ -4,12 +4,12 @@ PORTNAME= qwt
PORTVERSION= 6.1.0
CATEGORIES= x11-toolkits devel
MASTER_SITES= SF
-PKGNAMESUFFIX= -designerplugin
+PKGNAMESUFFIX= 6-designerplugin
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt Designer plugin for Qwt
-LIB_DEPENDS= qwt6.6:${PORTSDIR}/x11-toolkits/qwt6
+LIB_DEPENDS= libqwt6.so:${PORTSDIR}/x11-toolkits/qwt6
USE_QT4= designer moc_build qmake_build rcc_build
USE_BZIP2= yes
@@ -18,8 +18,6 @@ QMAKE_ARGS+= -recursive CONFIG+=QwtDesigner \
PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
HAS_CONFIGURE= yes
-LATEST_LINK= qwt6${PKGNAMESUFFIX}
-
PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/libqwt6_designer_plugin.so
PLIST_DIRSTRY= ${QT_PLUGINDIR_REL}/designer \
${QT_PLUGINDIR_REL}
diff --git a/x11-toolkits/qwt6/Makefile b/x11-toolkits/qwt6/Makefile
index 6cede5faa6ff..d7d4e0e6f284 100644
--- a/x11-toolkits/qwt6/Makefile
+++ b/x11-toolkits/qwt6/Makefile
@@ -4,6 +4,7 @@ PORTNAME= qwt
PORTVERSION= 6.1.0
CATEGORIES= x11-toolkits
MASTER_SITES= SF
+PKGNAMESUFFIX= 6
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt Widgets for Technical Applications
@@ -14,12 +15,10 @@ USE_GMAKE= yes
QMAKE_ARGS+= -recursive PREFIX=${PREFIX}
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
-DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
-
-LATEST_LINK= qwt6
+DOCSDIR= ${PREFIX}/share/doc/qwt6
PORTDOCS= *
-PLIST_SUB= INCLUDEDIR=include/${LATEST_LINK} \
+PLIST_SUB= INCLUDEDIR=include/qwt6 \
SHLIB_VER=${PORTVERSION} \
SHLIB_SHVER=${PORTVERSION:R} \
QT_MKSPECDIR=share/qt4/mkspecs