aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/openoffice-1.1-devel/Makefile13
-rw-r--r--editors/openoffice-1.1/Makefile13
-rw-r--r--editors/openoffice.org-1.1-devel/Makefile13
-rw-r--r--editors/openoffice.org-1.1/Makefile13
4 files changed, 40 insertions, 12 deletions
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 6c5d623d2538..c520b2af8e31 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -77,8 +77,10 @@ CC= gcc32
CXX= g++32
.endif
-BUILD_DEPENDS+= ${JDKDIR}/bin/java:${PORTSDIR}/java/jdk14 \
- zip:${PORTSDIR}/archivers/zip \
+.if !defined(WITHOUT_JAVA)
+BUILD_DEPENDS+= ${JDKDIR}/bin/java:${PORTSDIR}/java/jdk14
+.endif
+BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
${ANT}:${PORTSDIR}/devel/apache-ant \
@@ -108,7 +110,12 @@ DISPLAYHACK=localhost:1001
CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-jdk-home=${JDKDIR}
+CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp
+.if defined(WITHOUT_JAVA)
+CONFIGURE_ARGS+= --disable-java
+.else
+CONFIGURE_ARGS+= --with-jdk-home=${JDKDIR}
+.endif
.if defined(WITHOUT_MOZILLA)
CONFIGURE_ARGS+= --disable-mozilla
.endif
diff --git a/editors/openoffice-1.1/Makefile b/editors/openoffice-1.1/Makefile
index c057eb47d365..086b4c0990cd 100644
--- a/editors/openoffice-1.1/Makefile
+++ b/editors/openoffice-1.1/Makefile
@@ -77,8 +77,10 @@ CC= gcc32
CXX= g++32
.endif
-BUILD_DEPENDS+= ${JDKDIR}/bin/java:${PORTSDIR}/java/jdk14 \
- zip:${PORTSDIR}/archivers/zip \
+.if !defined(WITHOUT_JAVA)
+BUILD_DEPENDS+= ${JDKDIR}/bin/java:${PORTSDIR}/java/jdk14
+.endif
+BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
${ANT}:${PORTSDIR}/devel/apache-ant \
@@ -108,7 +110,12 @@ DISPLAYHACK=localhost:1001
CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-jdk-home=${JDKDIR}
+CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp
+.if defined(WITHOUT_JAVA)
+CONFIGURE_ARGS+= --disable-java
+.else
+CONFIGURE_ARGS+= --with-jdk-home=${JDKDIR}
+.endif
.if defined(WITHOUT_MOZILLA)
CONFIGURE_ARGS+= --disable-mozilla
.endif
diff --git a/editors/openoffice.org-1.1-devel/Makefile b/editors/openoffice.org-1.1-devel/Makefile
index 6c5d623d2538..c520b2af8e31 100644
--- a/editors/openoffice.org-1.1-devel/Makefile
+++ b/editors/openoffice.org-1.1-devel/Makefile
@@ -77,8 +77,10 @@ CC= gcc32
CXX= g++32
.endif
-BUILD_DEPENDS+= ${JDKDIR}/bin/java:${PORTSDIR}/java/jdk14 \
- zip:${PORTSDIR}/archivers/zip \
+.if !defined(WITHOUT_JAVA)
+BUILD_DEPENDS+= ${JDKDIR}/bin/java:${PORTSDIR}/java/jdk14
+.endif
+BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
${ANT}:${PORTSDIR}/devel/apache-ant \
@@ -108,7 +110,12 @@ DISPLAYHACK=localhost:1001
CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-jdk-home=${JDKDIR}
+CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp
+.if defined(WITHOUT_JAVA)
+CONFIGURE_ARGS+= --disable-java
+.else
+CONFIGURE_ARGS+= --with-jdk-home=${JDKDIR}
+.endif
.if defined(WITHOUT_MOZILLA)
CONFIGURE_ARGS+= --disable-mozilla
.endif
diff --git a/editors/openoffice.org-1.1/Makefile b/editors/openoffice.org-1.1/Makefile
index c057eb47d365..086b4c0990cd 100644
--- a/editors/openoffice.org-1.1/Makefile
+++ b/editors/openoffice.org-1.1/Makefile
@@ -77,8 +77,10 @@ CC= gcc32
CXX= g++32
.endif
-BUILD_DEPENDS+= ${JDKDIR}/bin/java:${PORTSDIR}/java/jdk14 \
- zip:${PORTSDIR}/archivers/zip \
+.if !defined(WITHOUT_JAVA)
+BUILD_DEPENDS+= ${JDKDIR}/bin/java:${PORTSDIR}/java/jdk14
+.endif
+BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
${ANT}:${PORTSDIR}/devel/apache-ant \
@@ -108,7 +110,12 @@ DISPLAYHACK=localhost:1001
CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-jdk-home=${JDKDIR}
+CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp
+.if defined(WITHOUT_JAVA)
+CONFIGURE_ARGS+= --disable-java
+.else
+CONFIGURE_ARGS+= --with-jdk-home=${JDKDIR}
+.endif
.if defined(WITHOUT_MOZILLA)
CONFIGURE_ARGS+= --disable-mozilla
.endif