aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/quixote/Makefile12
-rw-r--r--www/quixote/distinfo2
-rw-r--r--www/quixote/pkg-plist2
3 files changed, 11 insertions, 5 deletions
diff --git a/www/quixote/Makefile b/www/quixote/Makefile
index 9158563570d2..8a6a8c94a5e7 100644
--- a/www/quixote/Makefile
+++ b/www/quixote/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= quixote
-PORTVERSION= 0.4.2
+PORTVERSION= 0.4.3
CATEGORIES= www python
MASTER_SITES= http://www.mems-exchange.org/software/files/quixote/
DISTNAME= Quixote-${PORTVERSION}
@@ -14,11 +14,15 @@ DISTNAME= Quixote-${PORTVERSION}
MAINTAINER= wjv@FreeBSD.org
BUILD_DEPENDS= ${PYDISTUTILS}
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/compiler/__init__.py:${PORTSDIR}/lang/py-compiler
USE_PYTHON= yes
PYTHON_SETUP= ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
-EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 220
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/compiler/__init__.py:${PORTSDIR}/lang/py-compiler
+.endif
do-build:
@ cd ${WRKSRC} && ${PYTHON_SETUP} build
@@ -43,4 +47,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/quixote/distinfo b/www/quixote/distinfo
index c2ec24faef5b..ab675974f5ab 100644
--- a/www/quixote/distinfo
+++ b/www/quixote/distinfo
@@ -1 +1 @@
-MD5 (Quixote-0.4.2.tar.gz) = ea0fb4c52b7e734e50ec22168725aa57
+MD5 (Quixote-0.4.3.tar.gz) = 3919dc8950900207b6c169453ac386b0
diff --git a/www/quixote/pkg-plist b/www/quixote/pkg-plist
index ef1b272ab8e1..fb8a72079a82 100644
--- a/www/quixote/pkg-plist
+++ b/www/quixote/pkg-plist
@@ -8,6 +8,7 @@
%%PORTDOCS%%share/doc/quixote/demo.txt
%%PORTDOCS%%share/doc/quixote/programming.txt
%%PORTDOCS%%share/doc/quixote/web-server.txt
+%%PORTDOCS%%share/doc/quixote/widgets.txt
lib/%%PYTHON_VERSION%%/site-packages/quixote/TemplateIO.py
lib/%%PYTHON_VERSION%%/site-packages/quixote/TemplateIO.pyc
lib/%%PYTHON_VERSION%%/site-packages/quixote/TemplateIO.pyo
@@ -25,6 +26,7 @@ lib/%%PYTHON_VERSION%%/site-packages/quixote/demo/integer_ui.pyc
lib/%%PYTHON_VERSION%%/site-packages/quixote/demo/integer_ui.pyo
lib/%%PYTHON_VERSION%%/site-packages/quixote/demo/pages.ptl
lib/%%PYTHON_VERSION%%/site-packages/quixote/demo/pages.ptlc
+lib/%%PYTHON_VERSION%%/site-packages/quixote/demo/widgets.ptl
lib/%%PYTHON_VERSION%%/site-packages/quixote/errors.py
lib/%%PYTHON_VERSION%%/site-packages/quixote/errors.pyc
lib/%%PYTHON_VERSION%%/site-packages/quixote/errors.pyo