aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/sbcl/Makefile19
-rw-r--r--lang/sbcl/distinfo6
-rw-r--r--lang/sbcl/pkg-plist14
3 files changed, 32 insertions, 7 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index 7bfd3fdec10d..57f491b6118e 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -9,13 +9,13 @@
#
PORTNAME= sbcl
-PORTVERSION= 1.0.30.0
+PORTVERSION= 1.0.31.0
PORTREVISION= 0
CATEGORIES= lang lisp
-#MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R} \
-# ftp://ftp.SpringDaemons.com/soft/sbcl-binary/:binaries
-MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/ \
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R} \
ftp://ftp.SpringDaemons.com/soft/sbcl-binary/:binaries
+#MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/ \
+# ftp://ftp.SpringDaemons.com/soft/sbcl-binary/:binaries
#MASTER_SITE_SUBDIR= sbcl/${PORTVERSION:R}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-source${SBCLPATCHLEVEL}
@@ -38,6 +38,7 @@ INFO= asdf sbcl
INFODIR= ${PREFIX}/${INFO_PATH}
OSVER_MAJOR= ${OSVERSION:C/([0-9]).*/\1/}
+NEWBOOTNAME= ${PORTNAME}-${PORTVERSION:R}-${ARCH}-freebsd${OSVER_MAJOR}
.if ${PORTVERSION:E} == 0
SBCLPATCHLEVEL= #empty
@@ -71,7 +72,11 @@ BOOT_VERSION= 1.0.17
BOOT_ARCH_OS_LIST= amd64-freebsd8 amd64-freebsd7 amd64-freebsd6 \
i386-freebsd8 i386-freebsd7 i386-freebsd6
. else
+. if ${OSVER_MAJOR} == 9 # We'll use 8.x bootstrap for now
+BOOT_ARCH_OS_LIST= ${ARCH}-freebsd8
+. else
BOOT_ARCH_OS_LIST= ${ARCH}-freebsd${OSVER_MAJOR}
+. endif
. endif
. if ${ARCH} == "i386"
@@ -128,4 +133,10 @@ post-install:
test: build
(cd ${WRKSRC}/tests && ${SH} run-tests.sh)
+bootstrap:
+ ${CP} -r ${WRKSRC} ${WRKDIR}/${NEWBOOTNAME}
+ (cd ${WRKDIR}/ && \
+ ${WRKDIR}/${NEWBOOTNAME}/binary-distribution.sh ${NEWBOOTNAME})
+ (cd ${WRKDIR}/ && ${BZIP2_CMD} ${NEWBOOTNAME}-binary.tar)
+
.include <bsd.port.post.mk>
diff --git a/lang/sbcl/distinfo b/lang/sbcl/distinfo
index edd8285370b4..1082317df5ef 100644
--- a/lang/sbcl/distinfo
+++ b/lang/sbcl/distinfo
@@ -1,6 +1,6 @@
-MD5 (sbcl-1.0.30-source.tar.bz2) = 64a96ad21a5d57f27639c0801c00fe74
-SHA256 (sbcl-1.0.30-source.tar.bz2) = d8b6f6437d6fb082e7942cb5bbef905a1b84abd68ca15a0602c5d627c3314933
-SIZE (sbcl-1.0.30-source.tar.bz2) = 3348181
+MD5 (sbcl-1.0.31-source.tar.bz2) = a61fd099a72c2d3fa10a57298f3c9bf6
+SHA256 (sbcl-1.0.31-source.tar.bz2) = d0264d6e4a49e6d181c27348f07de733c09860c9cd74a1fbe8e6e3cb7ca289dc
+SIZE (sbcl-1.0.31-source.tar.bz2) = 3354506
MD5 (sbcl-1.0.17-amd64-freebsd8-binary.tar.bz2) = 97c0acdaab6a0ad0101cf6d23e03176f
SHA256 (sbcl-1.0.17-amd64-freebsd8-binary.tar.bz2) = 19f7a1311e2b0c7a174cce2182c9a240f0b1fe12eeb61de6e1cc253d47c4dc27
SIZE (sbcl-1.0.17-amd64-freebsd8-binary.tar.bz2) = 7786927
diff --git a/lang/sbcl/pkg-plist b/lang/sbcl/pkg-plist
index 212adc561c27..e785f3ddd0d9 100644
--- a/lang/sbcl/pkg-plist
+++ b/lang/sbcl/pkg-plist
@@ -112,7 +112,21 @@ lib/sbcl/sb-grovel/sb-grovel.asd
lib/sbcl/sb-grovel/sb-grovel.fasl
lib/sbcl/sb-grovel/sb-grovel.texinfo
lib/sbcl/sb-grovel/test-passed
+lib/sbcl/sb-introspect/.cvsignore
+lib/sbcl/sb-introspect/Makefile
+lib/sbcl/sb-introspect/introspect.fasl
+lib/sbcl/sb-introspect/introspect.lisp
+lib/sbcl/sb-introspect/sb-introspect.asd
lib/sbcl/sb-introspect/sb-introspect.fasl
+lib/sbcl/sb-introspect/test-driver.fasl
+lib/sbcl/sb-introspect/test-driver.lisp
+lib/sbcl/sb-introspect/test-passed
+lib/sbcl/sb-introspect/test.fasl
+lib/sbcl/sb-introspect/test.lisp
+lib/sbcl/sb-introspect/xref-test-data.fasl
+lib/sbcl/sb-introspect/xref-test-data.lisp
+lib/sbcl/sb-introspect/xref-test.fasl
+lib/sbcl/sb-introspect/xref-test.lisp
lib/sbcl/sb-md5/.cvsignore
lib/sbcl/sb-md5/Makefile
lib/sbcl/sb-md5/README