aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/saxon-devel/Makefile18
-rw-r--r--textproc/saxon-devel/distinfo8
-rw-r--r--textproc/saxon-devel/pkg-descr4
3 files changed, 18 insertions, 12 deletions
diff --git a/textproc/saxon-devel/Makefile b/textproc/saxon-devel/Makefile
index a00c5048554b..9a6403473e41 100644
--- a/textproc/saxon-devel/Makefile
+++ b/textproc/saxon-devel/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= saxon
-PORTVERSION= 8.9.0.4
-PORTREVISION= 1
+PORTVERSION= 9.1.0.7
PORTEPOCH= 1
CATEGORIES= textproc java
MASTER_SITES= SF/${PORTNAME}/Saxon-B/${PORTVERSION}
PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}b${PORTVERSION:S,.,-,g}j.zip \
- ${PORTNAME}-resources8-9
+ ${PORTNAME}-resources9-1-0-1
MAINTAINER= hq@FreeBSD.org
COMMENT= An XSLT 2.0 / XPath 2.0 / XQuery 1.0 processor for Java
@@ -21,6 +20,7 @@ COMMENT= An XSLT 2.0 / XPath 2.0 / XQuery 1.0 processor for Java
RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
OPTIONS= JDOM "Install Jdom support" off \
+ DOM4J "Install dom4j support" off \
XOM "Install XOM support" off
USE_ZIP= yes
@@ -31,7 +31,8 @@ NO_BUILD= yes
CONFLICTS= saxon-6.*
-JARFILES= saxon8-sql.jar saxon8.jar saxon8-xpath.jar saxon8-dom.jar
+JARFILES= saxon9-sql.jar saxon9.jar saxon9-xpath.jar saxon9-dom.jar \
+ saxon9-xqj.jar saxon9-s9api.jar
PLIST_FILES+= ${JARFILES:S,^,%%JAVAJARDIR%%/,} bin/saxon bin/saxon-xquery
.if !defined(NOPORTDOCS)
PORTDOCS= *
@@ -40,12 +41,17 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if defined(WITH_JDOM)
-JARFILES+= saxon8-jdom.jar
+JARFILES+= saxon9-jdom.jar
RUN_DEPENDS+= ${JAVALIBDIR}/jdom.jar:${PORTSDIR}/java/jdom
.endif
+.if defined(WITH_DOM4J)
+JARFILES+= saxon9-dom4j.jar
+RUN_DEPENDS+= ${JAVALIBDIR}/dom4j.jar:${PORTSDIR}/textproc/dom4j
+.endif
+
.if defined(WITH_XOM)
-JARFILES+= saxon8-xom.jar
+JARFILES+= saxon9-xom.jar
RUN_DEPENDS+= ${JAVALIBDIR}/xom.jar:${PORTSDIR}/textproc/xom
.endif
diff --git a/textproc/saxon-devel/distinfo b/textproc/saxon-devel/distinfo
index 611d771a321e..b6fcb6180f2a 100644
--- a/textproc/saxon-devel/distinfo
+++ b/textproc/saxon-devel/distinfo
@@ -1,4 +1,4 @@
-SHA256 (saxonb8-9-0-4j.zip) = 23e12d90d7990bee4ae715345dc8f555b5aab662710256dec22bed70b3f54058
-SIZE (saxonb8-9-0-4j.zip) = 1492988
-SHA256 (saxon-resources8-9.zip) = bfab671b938047128427acf675d64249f714e40e8e80dc1585df0a2c8840a9bd
-SIZE (saxon-resources8-9.zip) = 10836211
+SHA256 (saxonb9-1-0-7j.zip) = 89142710cb03a18a70014f106927fb01c2c7fe0c58b3dbbdaf5e592917f1de81
+SIZE (saxonb9-1-0-7j.zip) = 2039013
+SHA256 (saxon-resources9-1-0-1.zip) = 371fbb245d283396f734555e893c41d6df150ebe1576e38211f12df93fc34def
+SIZE (saxon-resources9-1-0-1.zip) = 12219434
diff --git a/textproc/saxon-devel/pkg-descr b/textproc/saxon-devel/pkg-descr
index f1c67d88e2eb..e4248cca686c 100644
--- a/textproc/saxon-devel/pkg-descr
+++ b/textproc/saxon-devel/pkg-descr
@@ -1,4 +1,4 @@
-The Saxon 8.0 package is a collection of tools for processing XML documents.
+The Saxon-B 9.1 package is a collection of tools for processing XML documents.
The main components are:
- An XSLT 2.0 processor, that can be used from the command line, or invoked
@@ -19,4 +19,4 @@ So you can use Saxon to process XML by writing XSLT stylesheets, by writing
XQuery queries, by writing Java applications, or by combinations of the
approaches.
-WWW: http://www.saxonica.com/
+WWW: http://saxon.sourceforge.net/