aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/geographiclib/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index 30bba17d135a..7a58ee99f264 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -15,7 +15,12 @@ WWW= https://geographiclib.sourceforge.io/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake compiler:c++14-lang localbase python:env
+USES= cmake localbase python:env
+.if !exists(/usr/include/omp.h)
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++14-lang
+.endif
USE_LDCONFIG= yes
USE_PYTHON= optsuffix
CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q} \