aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING20
-rw-r--r--net-im/matterircd/Makefile2
-rw-r--r--net-im/matterircd/distinfo6
-rw-r--r--net-im/matterircd/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go24
4 files changed, 24 insertions, 28 deletions
diff --git a/UPDATING b/UPDATING
index ace6d2a6c1a4..2a71badcd0f9 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,26 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20210114:
+ AFFECTS: users of net-im/matterircd
+ AUTHOR: norrland@nullbyte.se
+
+ Commandline switches
+
+ Switched to viper for cmdline parsing, which does not support "short" flags.
+ You'll need to use --flag instead of -flag. Eg ./matterircd --debug
+ Bridge specific configuration is now only in configuration file. This means
+ the following flags have been removed: -restrict,-mmteam,-mmserver,
+ -mminsecure,-mmskiptlsverify.
+ You can set those in matterircd.toml, see the example file.
+
+ Config changes
+
+ BlacklistUser feature for slack has been renamed to DenyUsers.
+ JoinMpImOnTalk feature has been renamed to JoinDM and is available for
+ slack/mattermost
+ JoinInclude, JoinExclude now support regexp (see matterircd.toml.example)
+
20210113:
AFFECTS: users of databases/redis[-devel]
AUTHOR: osa@FreeBSD.org
diff --git a/net-im/matterircd/Makefile b/net-im/matterircd/Makefile
index 23b5b8ae833b..0095eb6ae4a6 100644
--- a/net-im/matterircd/Makefile
+++ b/net-im/matterircd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= matterircd
DISTVERSIONPREFIX= v
-DISTVERSION= 0.19.4
+DISTVERSION= 0.22.0
CATEGORIES= net-im irc
MAINTAINER= norrland@nullbyte.se
diff --git a/net-im/matterircd/distinfo b/net-im/matterircd/distinfo
index f7f0bf05096e..8f80f32b4059 100644
--- a/net-im/matterircd/distinfo
+++ b/net-im/matterircd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1585674650
-SHA256 (42wim-matterircd-v0.19.4_GH0.tar.gz) = 5175b8970e22f218a9aff16f0ec5677efb9d13f7af5d895c1a079d09c29809c4
-SIZE (42wim-matterircd-v0.19.4_GH0.tar.gz) = 2234367
+TIMESTAMP = 1610626865
+SHA256 (42wim-matterircd-v0.22.0_GH0.tar.gz) = f3bdb5aa9904a63fd6c52fa35ab4e8e916d54ac8c5bea5ceb3e49168e677c61e
+SIZE (42wim-matterircd-v0.22.0_GH0.tar.gz) = 2580639
diff --git a/net-im/matterircd/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go b/net-im/matterircd/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go
deleted file mode 100644
index 0e0603b77cee..000000000000
--- a/net-im/matterircd/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go
+++ /dev/null
@@ -1,24 +0,0 @@
-From 33540a1f603772f9d4b761f416f5c10dade23e96 Mon Sep 17 00:00:00 2001
-From: Tobias Klauser <tklauser@distanz.ch>
-Date: Fri, 25 Oct 2019 21:13:51 +0200
-Subject: [PATCH] unix: don't use non-existing uint128 type on freebsd/arm64
-
-CL 179099 introduced type FpReg on freebsd, on freebsd/arm64 using a
-type uint128. This type doesn't exist in Go.
-
-Change-Id: Ie7f065f38f2cc2c163abdfa7dddad886b8edbe3b
-Reviewed-on: https://go-review.googlesource.com/c/sys/+/203419
-Run-TryBot: Tobias Klauser <tobias.klauser@gmail.com>
-TryBot-Result: Gobot Gobot <gobot@golang.org>
-Reviewed-by: Brad Fitzpatrick <bradfitz@golang.org>
---- vendor/golang.org/x/sys/unix/ztypes_freebsd_arm64.go.orig 2019-08-18 13:42:05 UTC
-+++ vendor/golang.org/x/sys/unix/ztypes_freebsd_arm64.go
-@@ -397,7 +397,7 @@ type Reg struct {
- }
-
- type FpReg struct {
-- Fp_q [32]uint128
-+ Fp_q [512]uint8
- Fp_sr uint32
- Fp_cr uint32
- }