aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/recode/Makefile5
-rw-r--r--devel/ptl/Makefile1
-rw-r--r--dns/dhisd/Makefile2
-rw-r--r--dns/odsclient/Makefile3
-rw-r--r--games/nethack33/Makefile7
-rw-r--r--games/slashem-tty/Makefile4
-rw-r--r--games/unnethack/Makefile4
-rw-r--r--japanese/esecanna-module-vje30/Makefile1
-rw-r--r--japanese/xjman/Makefile3
-rw-r--r--korean/hpscat/Makefile1
-rw-r--r--lang/dylan/Makefile1
-rw-r--r--mail/bsmtp/Makefile2
-rw-r--r--mail/ifile/Makefile3
-rw-r--r--misc/libelysium/Makefile2
-rw-r--r--net-mgmt/net-snmp-devel/Makefile1
-rw-r--r--net-mgmt/net-snmp/Makefile1
-rw-r--r--net-mgmt/net-snmp53/Makefile1
-rw-r--r--net/dhisd/Makefile2
-rw-r--r--net/net-snmp/Makefile1
-rw-r--r--net/odsclient/Makefile3
-rw-r--r--security/bjorb/Makefile1
-rw-r--r--security/pam_smb/Makefile1
-rw-r--r--sysutils/clockspeed/Makefile3
-rw-r--r--www/knowledgekit/Makefile3
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid25/Makefile2
-rw-r--r--www/squid26/Makefile2
-rw-r--r--www/squid27/Makefile2
-rw-r--r--www/squid30/Makefile2
-rw-r--r--www/squid31/Makefile2
-rw-r--r--www/znavigator/Makefile4
31 files changed, 55 insertions, 17 deletions
diff --git a/converters/recode/Makefile b/converters/recode/Makefile
index 719d415de4a4..b23d1e923899 100644
--- a/converters/recode/Makefile
+++ b/converters/recode/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= demon@FreeBSD.org
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --without-included-gettext
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -35,7 +36,7 @@ remove-info-files:
post-patch: patch-po-files patch-makeinfo
patch-po-files:
- @${PERL} -pi -e '\
+ @${REINPLACE_CMD} -e '\
if (/Project-Id-Version/) { \
s/3\.[45](r|\.[0-9])?/3.6/; \
s/: (Free )?recode/: GNU recode/; \
@@ -43,7 +44,7 @@ patch-po-files:
' ${WRKSRC}/i18n/*.po
patch-makeinfo:
- @${PERL} -pi.fbsd -e 's|\@MAKEINFO\@|\@MAKEINFO\@ --no-split|g' \
+ @${REINPLACE_CMD} -e 's|\@MAKEINFO\@|\@MAKEINFO\@ --no-split|g' \
${WRKSRC}/doc/Makefile.in
.include <bsd.port.mk>
diff --git a/devel/ptl/Makefile b/devel/ptl/Makefile
index 3cbf24eed8c6..3bea8a23e7ba 100644
--- a/devel/ptl/Makefile
+++ b/devel/ptl/Makefile
@@ -23,6 +23,7 @@ PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
PATCHFILES= ${DISTNAME}_readdir-patch
PATCH_DIST_STRIP= -p1
+USE_PERL5= yes
USE_REINPLACE= yes
MAKE_ARGS= prefix="${PREFIX}"
INSTALLS_SHLIB= yes
diff --git a/dns/dhisd/Makefile b/dns/dhisd/Makefile
index 14278b5a883a..745ef58f3484 100644
--- a/dns/dhisd/Makefile
+++ b/dns/dhisd/Makefile
@@ -21,7 +21,7 @@ USE_REINPLACE= yes
post-patch:
${CP} ${FILESDIR}/dhisd.sh ${WRKSRC}/dhisd.sh
- cd ${WRKSRC} && ${REINPLACE_CMD} -p e "s^__PREFIX__^${PREFIX}^g" \
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e "s^__PREFIX__^${PREFIX}^g" \
Makefile dhisd.h dhisd.sh ${DOCFILES}
do-install:
diff --git a/dns/odsclient/Makefile b/dns/odsclient/Makefile
index cd8a3bbefe3e..0553c98c40ee 100644
--- a/dns/odsclient/Makefile
+++ b/dns/odsclient/Makefile
@@ -12,10 +12,11 @@ MASTER_SITES= http://www.ods.org/
MAINTAINER= geniusj@ods.org
+USE_REINPLACE= yes
ALL_TARGET= odsclient
post-patch:
- @${PERL} -pi -e "s/^(CC|CFLAGS).+//g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s/^(CC|CFLAGS).+//g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/odsclient ${PREFIX}/bin
diff --git a/games/nethack33/Makefile b/games/nethack33/Makefile
index 43a4fdffe468..de0a9370a383 100644
--- a/games/nethack33/Makefile
+++ b/games/nethack33/Makefile
@@ -20,6 +20,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_LATEST_LINK= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
MAKE_ENV= CXX="${CXX}" GRAPHICS="${GRAPHICS}"
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
@@ -65,8 +66,10 @@ pre-everything::
.endif
post-patch:
- @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/include/config.h
- @${PERL} -pi -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/win/Qt/qt_win.cpp
+ @${REINPLACE_CMD} -e \
+ 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/include/config.h
+ @${REINPLACE_CMD} -e \
+ 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/win/Qt/qt_win.cpp
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
diff --git a/games/slashem-tty/Makefile b/games/slashem-tty/Makefile
index 4a2b1bf7609d..f5debfea5bf4 100644
--- a/games/slashem-tty/Makefile
+++ b/games/slashem-tty/Makefile
@@ -16,12 +16,14 @@ DISTNAME= se${PORTVERSION:S/.//g:L}
MAINTAINER= adam-ports@blacktabby.org
USE_GMAKE= yes
+USE_REINPLACE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 slashem-tty.6 recover.6
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
post-patch:
- ${PERL} -pi -e "s@/usr/local@${PREFIX}@g" ${WRKSRC}/include/config.h
+ ${REINPLACE_CMD} -e \
+ "s@/usr/local@${PREFIX}@g" ${WRKSRC}/include/config.h
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index 4a2b1bf7609d..f5debfea5bf4 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -16,12 +16,14 @@ DISTNAME= se${PORTVERSION:S/.//g:L}
MAINTAINER= adam-ports@blacktabby.org
USE_GMAKE= yes
+USE_REINPLACE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 slashem-tty.6 recover.6
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
post-patch:
- ${PERL} -pi -e "s@/usr/local@${PREFIX}@g" ${WRKSRC}/include/config.h
+ ${REINPLACE_CMD} -e \
+ "s@/usr/local@${PREFIX}@g" ${WRKSRC}/include/config.h
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
diff --git a/japanese/esecanna-module-vje30/Makefile b/japanese/esecanna-module-vje30/Makefile
index cd2cf9cf8132..249cf3b4787f 100644
--- a/japanese/esecanna-module-vje30/Makefile
+++ b/japanese/esecanna-module-vje30/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/sbin/esecannaserver:${PORTSDIR}/japanese/esecanna
+USE_PERL5= yes
USE_REINPLACE= yes
USE_AUTOCONF= yes
USE_GMAKE= yes
diff --git a/japanese/xjman/Makefile b/japanese/xjman/Makefile
index 4d873a5eaa4b..c355ab93f7f7 100644
--- a/japanese/xjman/Makefile
+++ b/japanese/xjman/Makefile
@@ -17,6 +17,7 @@ MAINTAINER?= sada@FreeBSD.org
RUN_DEPENDS= jman:${PORTSDIR}/japanese/man
+USE_REINPLACE= yes
NO_MTREE= yes
PLIST= ${WRKDIR}/PLIST
USE_BZIP2= yes
@@ -32,7 +33,7 @@ post-extract:
.for sec in ${MANSECS}
(cd ${WRKSRC}/man${sec}; \
for f in *.${sec}x; do ${CP} $$f $${f%x}; done; \
- ${PERL} -pi -e 's/^(\.so .*)x$$/$$1/' *.${sec})
+ ${REINPLACE_CMD} -e 's/^(\.so .*)x$$/$$1/' *.${sec})
.endfor
post-build:
diff --git a/korean/hpscat/Makefile b/korean/hpscat/Makefile
index 7e0d438ed628..ce15c8026b9a 100644
--- a/korean/hpscat/Makefile
+++ b/korean/hpscat/Makefile
@@ -20,6 +20,7 @@ MAINTAINER= cjh@FreeBSD.org
RUN_DEPENDS= hcode:${PORTSDIR}/korean/hcode
+USE_PERL5= yes
USE_REINPLACE= yes
pre-patch:
diff --git a/lang/dylan/Makefile b/lang/dylan/Makefile
index b5afc348c7ec..c344394c2bf3 100644
--- a/lang/dylan/Makefile
+++ b/lang/dylan/Makefile
@@ -28,6 +28,7 @@ MAINTAINER= housel@acm.org
RUN_DEPENDS= libtool:${PORTSDIR}/devel/libtool
+USE_PERL5= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --srcdir=$(WRKSRC) --enable-debug
CONFIGURE_ENV= D2C="$(WRKDIR)/d2c -p$(WRKSRC)/d2c/compiler/platforms.descr"
diff --git a/mail/bsmtp/Makefile b/mail/bsmtp/Makefile
index edeb0859c2b2..4733104b1f6d 100644
--- a/mail/bsmtp/Makefile
+++ b/mail/bsmtp/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.stud.uni-karlsruhe.de/~uk1o/bsmtp/
MAINTAINER= naddy@FreeBSD.org
-USE_PERL= yes
+USE_PERL5= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --redo
diff --git a/mail/ifile/Makefile b/mail/ifile/Makefile
index 51aa5f0ac633..8abf20c40095 100644
--- a/mail/ifile/Makefile
+++ b/mail/ifile/Makefile
@@ -12,13 +12,14 @@ MASTER_SITES= http://www.ai.mit.edu/~jrennie/ifile/
MAINTAINER= david+ports@bushong.net
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= ifile.1
post-patch:
.for file in argp-help.c strndup.c
- @${PERL} -pi -e 's/malloc\.h/stdlib.h/g' ${WRKSRC}/argp/${file}
+ @${REINPLACE_CMD} -e 's/malloc\.h/stdlib.h/g' ${WRKSRC}/argp/${file}
.endfor
.include <bsd.port.mk>
diff --git a/misc/libelysium/Makefile b/misc/libelysium/Makefile
index d9c60515135a..ab6035ffdee3 100644
--- a/misc/libelysium/Makefile
+++ b/misc/libelysium/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/net-mgmt/net-snmp-devel/Makefile b/net-mgmt/net-snmp-devel/Makefile
index 2e54654d465d..eec720db9ec6 100644
--- a/net-mgmt/net-snmp-devel/Makefile
+++ b/net-mgmt/net-snmp-devel/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= net-snmp
MAINTAINER= kuriyama@FreeBSD.org
+USE_PERL5= yes
USE_REINPLACE= yes
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 2e54654d465d..eec720db9ec6 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= net-snmp
MAINTAINER= kuriyama@FreeBSD.org
+USE_PERL5= yes
USE_REINPLACE= yes
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
diff --git a/net-mgmt/net-snmp53/Makefile b/net-mgmt/net-snmp53/Makefile
index 2e54654d465d..eec720db9ec6 100644
--- a/net-mgmt/net-snmp53/Makefile
+++ b/net-mgmt/net-snmp53/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= net-snmp
MAINTAINER= kuriyama@FreeBSD.org
+USE_PERL5= yes
USE_REINPLACE= yes
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
diff --git a/net/dhisd/Makefile b/net/dhisd/Makefile
index 14278b5a883a..745ef58f3484 100644
--- a/net/dhisd/Makefile
+++ b/net/dhisd/Makefile
@@ -21,7 +21,7 @@ USE_REINPLACE= yes
post-patch:
${CP} ${FILESDIR}/dhisd.sh ${WRKSRC}/dhisd.sh
- cd ${WRKSRC} && ${REINPLACE_CMD} -p e "s^__PREFIX__^${PREFIX}^g" \
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e "s^__PREFIX__^${PREFIX}^g" \
Makefile dhisd.h dhisd.sh ${DOCFILES}
do-install:
diff --git a/net/net-snmp/Makefile b/net/net-snmp/Makefile
index 2e54654d465d..eec720db9ec6 100644
--- a/net/net-snmp/Makefile
+++ b/net/net-snmp/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= net-snmp
MAINTAINER= kuriyama@FreeBSD.org
+USE_PERL5= yes
USE_REINPLACE= yes
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
diff --git a/net/odsclient/Makefile b/net/odsclient/Makefile
index cd8a3bbefe3e..0553c98c40ee 100644
--- a/net/odsclient/Makefile
+++ b/net/odsclient/Makefile
@@ -12,10 +12,11 @@ MASTER_SITES= http://www.ods.org/
MAINTAINER= geniusj@ods.org
+USE_REINPLACE= yes
ALL_TARGET= odsclient
post-patch:
- @${PERL} -pi -e "s/^(CC|CFLAGS).+//g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s/^(CC|CFLAGS).+//g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/odsclient ${PREFIX}/bin
diff --git a/security/bjorb/Makefile b/security/bjorb/Makefile
index 886502b12369..3cc8386968b8 100644
--- a/security/bjorb/Makefile
+++ b/security/bjorb/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= ftp://ftp.hitachi-ms.co.jp/pub/bjorb/
MAINTAINER= ports@FreeBSD.org
USE_OPENSSL= YES
+USE_PERL5= yes
.if !defined(BATCH)
INSTALL_TARGET= install certificate
diff --git a/security/pam_smb/Makefile b/security/pam_smb/Makefile
index 4bf6d05927e7..da3817ff779a 100644
--- a/security/pam_smb/Makefile
+++ b/security/pam_smb/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= ports@FreeBSD.org
USE_AUTOCONF_VER=213
USE_GMAKE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
STARTUP_SCRIPT= pam_smbd.sh.sample
diff --git a/sysutils/clockspeed/Makefile b/sysutils/clockspeed/Makefile
index 0682131f1718..a22b05c71fdf 100644
--- a/sysutils/clockspeed/Makefile
+++ b/sysutils/clockspeed/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= lioux@FreeBSD.org
LIB_DEPENDS= tai.1:${PORTSDIR}/devel/libtai
ALL_TARGET= it
+USE_REINPLACE= yes
INSTALL_TARGET= setup check
MAN1= clockadd.1 clockspeed.1 clockview.1 sntpclock.1 \
@@ -44,7 +45,7 @@ real-post-patch:
@${SED} "s!/usr/local/!${PREFIX}!" ${CLOCKSPEED_RC_SCRIPT_SAMPLE} > \
${WRKDIR}/${CLOCKSPEED_RC_SCRIPT_SAMPLE:T}
.for file in ${PREFIX_FIX_FILES}
- @${PERL} -pi -ne "s|%%PREFIX%%|${PREFIX}|g" ${file}
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${file}
.endfor
real-post-install:
diff --git a/www/knowledgekit/Makefile b/www/knowledgekit/Makefile
index 5e63d1c3b053..f1ba0a8dcc8c 100644
--- a/www/knowledgekit/Makefile
+++ b/www/knowledgekit/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= nbm@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
+USE_REINPLACE= yes
NO_BUILD= YES
PKGMESSAGE= ${WRKDIR}/.MESSAGE
@@ -34,7 +35,7 @@ PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
do-install:
@${CP} ${WRKSRC}/* \
${ZOPEBASEDIR}/import
- @perl -pe 's#%%PREFIX%%#${PREFIX}#; s#%%VER%%#${PORTVERSION}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
+ @${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#; s#%%VER%%#${PORTVERSION}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid26/Makefile b/www/squid26/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid26/Makefile
+++ b/www/squid26/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/znavigator/Makefile b/www/znavigator/Makefile
index f7f4852ae7d2..97d7bb8372e2 100644
--- a/www/znavigator/Makefile
+++ b/www/znavigator/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= nbm@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
NO_BUILD= YES
+USE_REINPLACE= yes
# You can change this in the environment if you like.
SZOPEBASEDIR?= www/Zope
@@ -38,7 +39,8 @@ do-install:
${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}/
@${CP} ${ZOPEPRODUCTSRC}/demo/navigator_demo.zexp \
${ZOPEBASEDIR}/import
- @perl -pe 's#%%PREFIX%%#${PREFIX}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
+ @${REINPLACE_CMD} -e \
+ 's#%%PREFIX%%#${PREFIX}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>