aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/mol2ps/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/science/mol2ps/Makefile b/science/mol2ps/Makefile
index 936b25feac5e..545a25a952db 100644
--- a/science/mol2ps/Makefile
+++ b/science/mol2ps/Makefile
@@ -26,14 +26,13 @@ USE_FPC= yes
PLIST_FILES= bin/${PORTNAME} bin/mol2svg %%DATADIR%%/color.conf
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
do-build:
(cd ${WRKSRC} && ${LOCALBASE}/bin/fpc ${EXTRACT_ONLY} -S2 -O3)
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin)
- (cd ${PREFIX}/bin && ${LN} ${PORTNAME} mol2svg)
- @${MKDIR} ${DATADIR}
- (cd ${FILESDIR} && ${INSTALL_DATA} color.conf ${DATADIR})
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${STAGEDIR}${PREFIX}/bin)
+ (cd ${STAGEDIR}${PREFIX}/bin && ${LN} ${PORTNAME} mol2svg)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${FILESDIR} && ${INSTALL_DATA} color.conf ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>