aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/py-fontfeatures/Makefile26
-rw-r--r--x11-fonts/py-fontfeatures/distinfo3
-rw-r--r--x11-fonts/py-fontfeatures/pkg-descr18
4 files changed, 48 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 893180e9158b..ef74a971bd21 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -235,6 +235,7 @@
SUBDIR += py-cu2qu
SUBDIR += py-defcon
SUBDIR += py-fontMath
+ SUBDIR += py-fontfeatures
SUBDIR += py-fontmake
SUBDIR += py-gflanguages
SUBDIR += py-glyphsLib
diff --git a/x11-fonts/py-fontfeatures/Makefile b/x11-fonts/py-fontfeatures/Makefile
new file mode 100644
index 000000000000..e6ed3b0ff84a
--- /dev/null
+++ b/x11-fonts/py-fontfeatures/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= fontfeatures
+PORTVERSION= 1.7.3
+CATEGORIES= x11-fonts python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= fontFeatures-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python library for manipulating OpenType font features
+WWW= https://github.com/simoncozens/fontFeatures
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beziers>=0.1.0:graphics/py-beziers@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fonttools>=4.28.0:print/py-fonttools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fs2>=0:devel/py-fs2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}glyphtools>=0.7.0:print/py-glyphtools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/py-fontfeatures/distinfo b/x11-fonts/py-fontfeatures/distinfo
new file mode 100644
index 000000000000..976409a4f3dd
--- /dev/null
+++ b/x11-fonts/py-fontfeatures/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1669057519
+SHA256 (fontFeatures-1.7.3.tar.gz) = cb3a4526a8b3ceae5a104b7ac046434e39bc989c39160a554d434d4df65ab269
+SIZE (fontFeatures-1.7.3.tar.gz) = 1235730
diff --git a/x11-fonts/py-fontfeatures/pkg-descr b/x11-fonts/py-fontfeatures/pkg-descr
new file mode 100644
index 000000000000..f07374c63932
--- /dev/null
+++ b/x11-fonts/py-fontfeatures/pkg-descr
@@ -0,0 +1,18 @@
+OpenType fonts are "programmed" using features, which are normally authored in
+Adobe's feature file format. This like source code to a computer program: it's a
+user-friendly, but computer-unfriendly, way to represent the features.
+
+Inside a font, the features are compiled in an efficient internal format. This
+is like the binary of a computer program: computers can use it, but they can't
+do else anything with it, and people can't read it.
+
+The purpose of this library is to provide a middle ground for representing
+features in a machine-manipulable format, kind of like the abstract syntax tree
+of a computer programmer. This is so that:
+- features can be represented in a structured human-readable and
+ machine-readable way, analogous to the XML files of the Unified Font Object
+ format.
+- features can be more directly authored by programs (such as font editors),
+ rather than them having to output AFDKO feature file format.
+- features can be easily manipulated by programs - for example, features from
+ two files merged together, or lookups moved between languages.