aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--benchmarks/hey/Makefile2
-rw-r--r--benchmarks/vegeta/Makefile2
-rw-r--r--databases/influxdb/Makefile2
-rw-r--r--devel/arduino-builder/Makefile2
-rw-r--r--devel/arduinoOTA/Makefile2
-rw-r--r--devel/awless/Makefile2
-rw-r--r--devel/git-codereview/Makefile2
-rw-r--r--devel/git-town/Makefile2
-rw-r--r--devel/gitlab-runner/Makefile2
-rw-r--r--devel/grv/Makefile2
-rw-r--r--devel/hub/Makefile2
-rw-r--r--devel/jfrog-cli/Makefile4
-rw-r--r--editors/micro/Makefile2
-rw-r--r--finance/fixc/Makefile4
-rw-r--r--misc/exercism/Makefile2
-rw-r--r--net-mgmt/intel-snap/Makefile6
-rw-r--r--net-mgmt/kapacitor/Makefile4
-rw-r--r--net-mgmt/telegraf/Makefile2
-rw-r--r--net/goreplay/Makefile2
-rw-r--r--net/syncthing-cli/Makefile2
-rw-r--r--net/syncthing-discosrv/Makefile2
-rw-r--r--net/syncthing-inotify/Makefile2
-rw-r--r--net/syncthing/Makefile2
-rw-r--r--print/cups-connector/Makefile2
-rw-r--r--security/sops/Makefile2
-rw-r--r--security/vault/Makefile2
-rw-r--r--sysutils/amazon-ssm-agent/Makefile2
-rw-r--r--sysutils/circonus-agent/Makefile2
-rw-r--r--sysutils/consul/Makefile2
-rw-r--r--sysutils/consul_exporter/Makefile2
-rw-r--r--sysutils/envconsul/Makefile2
-rw-r--r--sysutils/serf/Makefile2
-rw-r--r--textproc/consul-template/Makefile2
-rw-r--r--textproc/spiff/Makefile2
-rw-r--r--www/gobuffalo/Makefile2
-rw-r--r--www/grafana2/Makefile4
-rw-r--r--www/grafana3/Makefile2
-rw-r--r--www/mattermost-server/Makefile2
-rw-r--r--www/minio-client/Makefile2
-rw-r--r--www/minio/Makefile2
-rw-r--r--www/uchiwa/Makefile2
41 files changed, 47 insertions, 47 deletions
diff --git a/benchmarks/hey/Makefile b/benchmarks/hey/Makefile
index 18e2b0ec6447..d7c595678eb5 100644
--- a/benchmarks/hey/Makefile
+++ b/benchmarks/hey/Makefile
@@ -24,7 +24,7 @@ do-build:
cd src/github.com/rakyll/hey; \
${LN} -s ../../../../requester . )
( cd ${WRKSRC}; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} CC=clang \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} CC=clang \
go build ${BUILD_FLAGS} )
do-install:
diff --git a/benchmarks/vegeta/Makefile b/benchmarks/vegeta/Makefile
index 96989067c6ca..117920acb7e1 100644
--- a/benchmarks/vegeta/Makefile
+++ b/benchmarks/vegeta/Makefile
@@ -27,7 +27,7 @@ do-build:
@${RLN} ${WRKSRC} ${WRKSRC}/github.com/${GH_ACCOUNT}/${PORTNAME}
@${RLN} ${WRKSRC} ${WRKSRC}/src
@cd ${WRKSRC} && \
- ${SETENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
+ ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
go build -ldflags "-X main.Version=${DISTVERSION}" -o bin/${PORTNAME}
do-install:
diff --git a/databases/influxdb/Makefile b/databases/influxdb/Makefile
index 7aee8fc7234f..d62b5a7957b4 100644
--- a/databases/influxdb/Makefile
+++ b/databases/influxdb/Makefile
@@ -107,7 +107,7 @@ post-patch:
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${GH_PROJECT} && \
- ${SETENV} GOPATH=${WRKSRC} go install -ldflags "-X main.version=${DISTVERSION}" ./...
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install -ldflags "-X main.version=${DISTVERSION}" ./...
do-build-MANPAGES-on:
@cd ${WRKSRC}/src/github.com/influxdata/influxdb/man && ${SETENV} ${MAKE_ENV} ${MAKE_CMD}
diff --git a/devel/arduino-builder/Makefile b/devel/arduino-builder/Makefile
index c85fa71985ee..ca34e6bf62c0 100644
--- a/devel/arduino-builder/Makefile
+++ b/devel/arduino-builder/Makefile
@@ -41,7 +41,7 @@ do-patch-TOOLS-on:
${WRKSRC}/arduino-builder.options
do-build:
- @( cd ${WRKSRC} ; ${SETENV} ${GO_ENV} go build arduino.cc/arduino-builder )
+ @( cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GO_ENV} go build arduino.cc/arduino-builder )
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/devel/arduinoOTA/Makefile b/devel/arduinoOTA/Makefile
index 0af6f152845d..6cabc557e337 100644
--- a/devel/arduinoOTA/Makefile
+++ b/devel/arduinoOTA/Makefile
@@ -19,7 +19,7 @@ PLIST_FILES= bin/${PORTNAME}
COMPILEINFO= ${OPSYS}${OSREL}-${ARCH}-${GH_TAGNAME}
do-build:
- (cd ${WRKSRC} && ${SETENV} ${GO_ENV} go build -o ${PORTNAME} -ldflags "-X main.compileInfo=${COMPILEINFO}" main.go)
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GO_ENV} go build -o ${PORTNAME} -ldflags "-X main.compileInfo=${COMPILEINFO}" main.go
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/devel/awless/Makefile b/devel/awless/Makefile
index c016ddbd68d3..38c042d7c49b 100644
--- a/devel/awless/Makefile
+++ b/devel/awless/Makefile
@@ -24,7 +24,7 @@ PLIST_FILES= bin/awless
PORTDOCS= README.md CHANGELOG.md
do-build:
- @(cd ${WRKSRC} && ${SETENV} GOPATH=${WRKSRC} go build -o ${PORTNAME} )
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build -o ${PORTNAME} )
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/git-codereview/Makefile b/devel/git-codereview/Makefile
index c968279a8ff4..d19109c468da 100644
--- a/devel/git-codereview/Makefile
+++ b/devel/git-codereview/Makefile
@@ -24,7 +24,7 @@ post-patch:
.endfor
do-build:
- cd ${WRKSRC}/src/golang.org/x/review ; ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go install ./...
+ @cd ${WRKSRC}/src/golang.org/x/review ; ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go install ./...
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/devel/git-town/Makefile b/devel/git-town/Makefile
index c695a19b1a8a..1239f3bd7b8a 100644
--- a/devel/git-town/Makefile
+++ b/devel/git-town/Makefile
@@ -25,7 +25,7 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= *
do-build:
- @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} GOPATH=${WRKSRC} go build
+ @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
diff --git a/devel/gitlab-runner/Makefile b/devel/gitlab-runner/Makefile
index 03a5e05c17a1..14f57caa92df 100644
--- a/devel/gitlab-runner/Makefile
+++ b/devel/gitlab-runner/Makefile
@@ -66,7 +66,7 @@ do-build:
@${MKDIR} ${WRKSRC}/src/gitlab.com/gitlab-org
@${LN} -s ${WRKSRC} ${WRKSRC}/src/gitlab.com/gitlab-org/gitlab-runner
@cd ${WRKSRC} && \
- ${SETENV} CGO_ENABLED=0 GOPATH=${WRKSRC} go build \
+ ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} go build \
-ldflags="${GO_LDFLAGS}" \
-o gitlab-runner
diff --git a/devel/grv/Makefile b/devel/grv/Makefile
index 619d7d16f08e..0a558def040e 100644
--- a/devel/grv/Makefile
+++ b/devel/grv/Makefile
@@ -37,7 +37,7 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= *
do-build:
- @cd ${WRKSRC} && ${SETENV} GOPATH=${WRKSRC} go build ./cmd/${PORTNAME}
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build ./cmd/${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/hub/Makefile b/devel/hub/Makefile
index ae01c1e0a90f..bd4146d65b68 100644
--- a/devel/hub/Makefile
+++ b/devel/hub/Makefile
@@ -22,7 +22,7 @@ PLIST_FILES= bin/hub \
share/zsh/site-functions/_hub \
man/man1/hub.1.gz
do-build:
- @cd ${WRKSRC} ; ${SETENV} ${LOCALBASE}/bin/bash script/build
+ @cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/bash script/build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/hub ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/jfrog-cli/Makefile b/devel/jfrog-cli/Makefile
index ae0d1fa25030..ec6746f8e489 100644
--- a/devel/jfrog-cli/Makefile
+++ b/devel/jfrog-cli/Makefile
@@ -21,8 +21,8 @@ post-extract:
@${MV} ${WRKSRC}/jfrog-cli ${WRKSRC}/jfrog-client ${WRKSRC}/src/github.com/jfrogdev/jfrog-cli-go
do-build:
- cd ${WRKSRC}/src/github.com/jfrogdev/jfrog-cli-go ; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go install ./...
+ @cd ${WRKSRC}/src/github.com/jfrogdev/jfrog-cli-go ; \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go install ./...
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/jfrog ${STAGEDIR}${PREFIX}/bin/jfrog
diff --git a/editors/micro/Makefile b/editors/micro/Makefile
index f7291a6933c0..e4daebed6a71 100644
--- a/editors/micro/Makefile
+++ b/editors/micro/Makefile
@@ -42,7 +42,7 @@ PORTDOCS= README.md
do-build:
@(cd ${WRKSRC} ; \
- ${SETENV} GOPATH=${WRKSRC} go build -ldflags \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build -ldflags \
"-s -w -X main.Version=${PORTVERSION} -X main.CommitHash=${BUILD_HASH} -X 'main.CompileDate=${BUILD_DATE}' " ./cmd/micro )
do-install:
diff --git a/finance/fixc/Makefile b/finance/fixc/Makefile
index 077be668f8aa..028176e2903c 100644
--- a/finance/fixc/Makefile
+++ b/finance/fixc/Makefile
@@ -15,8 +15,8 @@ USE_GITHUB= yes
GH_ACCOUNT= blttll
do-build:
- cd ${WRKSRC} && \
- go build -o fixc main.go
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} go build -o fixc main.go
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fixc ${STAGEDIR}${PREFIX}/bin
diff --git a/misc/exercism/Makefile b/misc/exercism/Makefile
index 59b30dbc066a..f56788cc6674 100644
--- a/misc/exercism/Makefile
+++ b/misc/exercism/Makefile
@@ -25,7 +25,7 @@ post-patch:
do-build:
@(cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT} ; \
- ${SETENV} GO15VENDOREXPERIMENT=1 GOPATH=${WRKSRC} go build -o bin/exercism exercism/main.go)
+ ${SETENV} ${MAKE_ENV} GO15VENDOREXPERIMENT=1 GOPATH=${WRKSRC} go build -o bin/exercism exercism/main.go)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/bin/exercism ${STAGEDIR}${PREFIX}/bin
diff --git a/net-mgmt/intel-snap/Makefile b/net-mgmt/intel-snap/Makefile
index 8f8f5f1e0642..a2d2dfaa3435 100644
--- a/net-mgmt/intel-snap/Makefile
+++ b/net-mgmt/intel-snap/Makefile
@@ -50,13 +50,13 @@ PLIST_FILES= bin/snapctl bin/snapd
do-build:
( cd ${WRKSRC}; ${LN} -s ${WRKSRC} ${WRKSRC}/src/github.com/intelsdi-x/snap )
( cd ${WRKSRC}/src/github.com/appc/spec; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} CC=clang \
+ ${SETENV} ${BUILD_ENV} ${MAKE_ENV} GOPATH=${WRKSRC} CC=clang \
go build -o bin/actool github.com/appc/spec/actool )
( cd ${WRKSRC}; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} CC=clang \
+ ${SETENV} ${BUILD_ENV} ${MAKE_ENV} GOPATH=${WRKSRC} CC=clang \
go build ${BUILD_FLAGS} -o bin/snapd )
( cd ${WRKSRC}/cmd/snapctl; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} CC=clang \
+ ${SETENV} ${BUILD_ENV} ${MAKE_ENV} GOPATH=${WRKSRC} CC=clang \
go build ${BUILD_FLAGS} -o bin/snapctl )
do-install:
diff --git a/net-mgmt/kapacitor/Makefile b/net-mgmt/kapacitor/Makefile
index 76c69f2d7788..29816013f411 100644
--- a/net-mgmt/kapacitor/Makefile
+++ b/net-mgmt/kapacitor/Makefile
@@ -51,8 +51,8 @@ post-patch:
do-build:
@cd ${WRKSRC}/src/github.com/influxdata/${PORTNAME} \
- && ${SETENV} GOPATH=${WRKSRC} go install -ldflags "-X main.version=${DISTVERSION}" ./cmd/${PORTNAME} \
- && ${SETENV} GOPATH=${WRKSRC} go install -ldflags "-X main.version=${DISTVERSION}" ./cmd/${PORTNAME}d
+ && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install -ldflags "-X main.version=${DISTVERSION}" ./cmd/${PORTNAME} \
+ && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install -ldflags "-X main.version=${DISTVERSION}" ./cmd/${PORTNAME}d
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/net-mgmt/telegraf/Makefile b/net-mgmt/telegraf/Makefile
index ca03c03bf4c2..911fadda05ed 100644
--- a/net-mgmt/telegraf/Makefile
+++ b/net-mgmt/telegraf/Makefile
@@ -126,7 +126,7 @@ post-patch:
do-build:
@cd ${WRKSRC}/src/github.com/influxdata/${PORTNAME} && \
- ${SETENV} GOPATH=${WRKSRC} go install -ldflags "-X main.version=${DISTVERSION}" ./...
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install -ldflags "-X main.version=${DISTVERSION}" ./...
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/net/goreplay/Makefile b/net/goreplay/Makefile
index d50ad76b6179..57c32cba2be3 100644
--- a/net/goreplay/Makefile
+++ b/net/goreplay/Makefile
@@ -25,7 +25,7 @@ GH_SUBDIR= src/github.com/buger/goreplay
PLIST_FILES= bin/${PORTNAME}
do-build:
- @cd ${WRKSRC}/${GH_SUBDIR} ; ${SETENV} GOPATH=${WRKSRC} go build
+ @cd ${WRKSRC}/${GH_SUBDIR} ; ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/goreplay \
diff --git a/net/syncthing-cli/Makefile b/net/syncthing-cli/Makefile
index 9245d2b5bd73..41bccb2fce9d 100644
--- a/net/syncthing-cli/Makefile
+++ b/net/syncthing-cli/Makefile
@@ -17,7 +17,7 @@ GH_TAGNAME= 9594d39
PLIST_FILES= bin/syncthing-cli
do-build:
- @cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC}/Godeps/_workspace:${WRKSRC} go build
+ @cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC}/Godeps/_workspace:${WRKSRC} go build
@${MV} ${WRKSRC}/syncthing-cli-${GH_TAGNAME} ${WRKSRC}/syncthing-cli
do-install:
diff --git a/net/syncthing-discosrv/Makefile b/net/syncthing-discosrv/Makefile
index 30763259a757..f376d2b7d544 100644
--- a/net/syncthing-discosrv/Makefile
+++ b/net/syncthing-discosrv/Makefile
@@ -30,7 +30,7 @@ post-patch:
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT} ; \
- ${SETENV} GOPATH=${WRKSRC} go build
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build
@${MV} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/discosrv ${WRKSRC}/syncthing-discosrv
do-install:
diff --git a/net/syncthing-inotify/Makefile b/net/syncthing-inotify/Makefile
index 603f8c14ade2..1a3e8e80834f 100644
--- a/net/syncthing-inotify/Makefile
+++ b/net/syncthing-inotify/Makefile
@@ -16,7 +16,7 @@ GH_SUBDIR= src/github.com/syncthing/syncthing-inotify
PLIST_FILES= bin/syncthing-inotify
do-build:
- @cd ${WRKSRC}/${GH_SUBDIR} ; ${SETENV} CGO_ENABLED=0 GOPATH=${WRKSRC} go build
+ @cd ${WRKSRC}/${GH_SUBDIR} ; ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} go build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/syncthing-inotify ${STAGEDIR}${PREFIX}/bin/
diff --git a/net/syncthing/Makefile b/net/syncthing/Makefile
index e4a1e4112b25..80903e0a2503 100644
--- a/net/syncthing/Makefile
+++ b/net/syncthing/Makefile
@@ -22,7 +22,7 @@ GROUPS= syncthing
do-build:
@cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME} ; \
- ${SETENV} go run build.go -no-upgrade=true -version v${PORTVERSION}
+ ${SETENV} ${MAKE_ENV} go run build.go -no-upgrade=true -version v${PORTVERSION}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/syncthing \
diff --git a/print/cups-connector/Makefile b/print/cups-connector/Makefile
index 96e7852fee7d..62d81a1c0424 100644
--- a/print/cups-connector/Makefile
+++ b/print/cups-connector/Makefile
@@ -37,7 +37,7 @@ post-patch:
do-build:
.for bin in ${BIN_FILES}
@cd ${WRKSRC}/src/github.com/google/cups-connector; ${SETENV} \
- ${BUILD_ENV} GOPATH=${WRKSRC} go build -o \
+ ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -o \
${WRKSRC}/bin/${bin} ./${bin}
.endfor
diff --git a/security/sops/Makefile b/security/sops/Makefile
index c61b32cd999b..26875356de42 100644
--- a/security/sops/Makefile
+++ b/security/sops/Makefile
@@ -23,7 +23,7 @@ PORTDOCS= README.rst CHANGELOG.rst
do-build:
@cd ${WRKSRC}/${GH_SUBDIR} && \
- ${SETENV} GOPATH=${WRKSRC} go build -o ${PORTNAME} ./cmd/sops
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build -o ${PORTNAME} ./cmd/sops
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/security/vault/Makefile b/security/vault/Makefile
index 76deb4115f76..46caa4e314be 100644
--- a/security/vault/Makefile
+++ b/security/vault/Makefile
@@ -27,7 +27,7 @@ PLIST_FILES= bin/${PORTNAME}
do-build:
@cd ${WRKSRC}; \
- ${SETENV} ${BUILD_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
go build \
-ldflags "\
-X github.com/hashicorp/vault/version.Version=${PORTVERSION} \
diff --git a/sysutils/amazon-ssm-agent/Makefile b/sysutils/amazon-ssm-agent/Makefile
index 7d35229b9d9d..133e71efdbb4 100644
--- a/sysutils/amazon-ssm-agent/Makefile
+++ b/sysutils/amazon-ssm-agent/Makefile
@@ -26,7 +26,7 @@ USE_RC_SUBR= amazon-ssm-agent
do-build:
@cd ${WRKSRC}; \
- ${SETENV} GOPATH=${WRKSRC}:${WRKSRC}/vendor CGO_ENABLED=0 \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC}:${WRKSRC}/vendor CGO_ENABLED=0 \
go build -ldflags "-s -w" -o amazon-ssm-agent \
agent/agent.go agent/agent_unix.go agent/agent_parser.go
diff --git a/sysutils/circonus-agent/Makefile b/sysutils/circonus-agent/Makefile
index d73529fef0a5..79712ba0268b 100644
--- a/sysutils/circonus-agent/Makefile
+++ b/sysutils/circonus-agent/Makefile
@@ -51,7 +51,7 @@ PLIST_FILES= bin/circonus-agentd "@dir ${ETCDIR}"
do-build:
( cd ${WRKSRC}; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} \
go build ${BUILD_FLAGS} -o bin/circonus-agentd )
do-install:
diff --git a/sysutils/consul/Makefile b/sysutils/consul/Makefile
index 8ed35be2f4f9..d973c7dd953b 100644
--- a/sysutils/consul/Makefile
+++ b/sysutils/consul/Makefile
@@ -29,7 +29,7 @@ post-extract:
@${MV} ${WRKSRC}/vendor/ ${WRKSRC}/src/
do-build:
- @cd ${WRKSRC}/src/github.com/hashicorp/consul; ${SETENV} CGO_ENABLED=0 ${BUILD_ENV} GOPATH=${WRKSRC} go build \
+ @cd ${WRKSRC}/src/github.com/hashicorp/consul; ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 ${BUILD_ENV} GOPATH=${WRKSRC} go build \
-ldflags "\
-X github.com/hashicorp/consul/version.Version=${PORTVERSION} \
-X github.com/hashicorp/consul/version.VersionPrerelease= \
diff --git a/sysutils/consul_exporter/Makefile b/sysutils/consul_exporter/Makefile
index 139d5ae64fa9..72f75bf23276 100644
--- a/sysutils/consul_exporter/Makefile
+++ b/sysutils/consul_exporter/Makefile
@@ -26,7 +26,7 @@ post-extract:
@${MV} ${WRKSRC}/vendor/ ${WRKSRC}/src/
do-build:
- @cd ${WRKSRC}/src/github.com/prometheus/consul_exporter; ${SETENV} CGO_ENABLED=0 ${BUILD_ENV} GOPATH=${WRKSRC} go build \
+ @cd ${WRKSRC}/src/github.com/prometheus/consul_exporter; ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 ${BUILD_ENV} GOPATH=${WRKSRC} go build \
-ldflags "\
-X github.com/prometheus/consul_exporter/version.Version=${PORTVERSION} \
-X github.com/prometheus/consul_exporter/version.VersionPrerelease= \
diff --git a/sysutils/envconsul/Makefile b/sysutils/envconsul/Makefile
index 383007399287..44174b604ed6 100644
--- a/sysutils/envconsul/Makefile
+++ b/sysutils/envconsul/Makefile
@@ -30,7 +30,7 @@ GO_LDFLAGS= -ldflags="-s -w \
do-build:
@cd ${WRKSRC}/src/github.com/hashicorp/envconsul; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} \
go build ${GO_LDFLAGS}\
-o bin/envconsul
diff --git a/sysutils/serf/Makefile b/sysutils/serf/Makefile
index ed6d4e2ea523..0e20aeba474e 100644
--- a/sysutils/serf/Makefile
+++ b/sysutils/serf/Makefile
@@ -27,7 +27,7 @@ PLIST_FILES= bin/serf
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}; \
- ${SETENV} GOPATH=${WRKSRC}:${WRKSRC}/vendor/ \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC}:${WRKSRC}/vendor/ \
go build -o bin/${PORTNAME} ./cmd/serf/
do-install:
diff --git a/textproc/consul-template/Makefile b/textproc/consul-template/Makefile
index 8c9b67592f7b..64cc725c4364 100644
--- a/textproc/consul-template/Makefile
+++ b/textproc/consul-template/Makefile
@@ -24,7 +24,7 @@ USE_RC_SUBR= consul-template
do-build:
@cd ${WRKSRC}/src/github.com/hashicorp/consul-template ; \
- ${SETENV} GOPATH=${WRKSRC} go build
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build
do-install:
${INSTALL_PROGRAM} \
diff --git a/textproc/spiff/Makefile b/textproc/spiff/Makefile
index c8683649e034..6270ed1db370 100644
--- a/textproc/spiff/Makefile
+++ b/textproc/spiff/Makefile
@@ -30,7 +30,7 @@ post-patch:
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT} ; \
- ${SETENV} GOPATH=${WRKSRC} go build spiff.go
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build spiff.go
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/${PORTNAME} \
diff --git a/www/gobuffalo/Makefile b/www/gobuffalo/Makefile
index 07f8f18f1299..ace9465dea66 100644
--- a/www/gobuffalo/Makefile
+++ b/www/gobuffalo/Makefile
@@ -82,7 +82,7 @@ GH_SUBDIR= src/github.com/gobuffalo/buffalo
PLIST_FILES= bin/buffalo
do-build:
- @cd ${WRKSRC}/${GH_SUBDIR}/buffalo ; ${SETENV} GOPATH=${WRKSRC} go build
+ @cd ${WRKSRC}/${GH_SUBDIR}/buffalo ; ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build
post-build:
@${STRIP_CMD} ${WRKSRC}/${GH_SUBDIR}/buffalo/buffalo
diff --git a/www/grafana2/Makefile b/www/grafana2/Makefile
index 02a3d0c1595c..6d01bcf8676f 100644
--- a/www/grafana2/Makefile
+++ b/www/grafana2/Makefile
@@ -81,8 +81,8 @@ post-extract:
${RM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/public/app/._.DS_Store
do-build:
- cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go run build.go build
+ @cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}; \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go run build.go build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/grafana-server \
diff --git a/www/grafana3/Makefile b/www/grafana3/Makefile
index e8e027be08b4..99001128c5b3 100644
--- a/www/grafana3/Makefile
+++ b/www/grafana3/Makefile
@@ -116,7 +116,7 @@ post-extract:
do-build:
cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/grafana; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go run build.go build
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go run build.go build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/grafana/grafana/bin/grafana-server \
diff --git a/www/mattermost-server/Makefile b/www/mattermost-server/Makefile
index c952fddd3866..d2925619c702 100644
--- a/www/mattermost-server/Makefile
+++ b/www/mattermost-server/Makefile
@@ -43,7 +43,7 @@ pre-build:
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${GH_PROJECT} && \
- ${SETENV} GOPATH=${WRKSRC} go install -ldflags="${GO_LDFLAGS}" ./...
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install -ldflags="${GO_LDFLAGS}" ./...
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/platform ${STAGEDIR}${PREFIX}/bin/mattermostd
diff --git a/www/minio-client/Makefile b/www/minio-client/Makefile
index e7565d5dd86f..52051e306cae 100644
--- a/www/minio-client/Makefile
+++ b/www/minio-client/Makefile
@@ -35,7 +35,7 @@ PLIST_FILES= bin/${MC}
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
-ldflags "-X main.GitDescribe=v${PORTVERSION}" -o bin/${MC}
do-install:
diff --git a/www/minio/Makefile b/www/minio/Makefile
index 22abf2495f6c..3751469ce784 100644
--- a/www/minio/Makefile
+++ b/www/minio/Makefile
@@ -30,7 +30,7 @@ SUB_LIST= USER="${USERS}" \
do-build:
@cd ${WRKSRC}/${GH_SUBDIR} ; \
- ${SETENV} GOPATH=${WRKSRC} CGO_ENABLED=0 go build \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} CGO_ENABLED=0 go build \
--ldflags '-X github.com/minio/minio/cmd.Version=${GH_TAGNAME:C/RELEASE\.//:C|(..)-(..)-(..)Z|\1:\2:\3Z|} -X github.com/minio/minio/cmd.ReleaseTag=${GH_TAGNAME} -X github.com/minio/minio/cmd.CommitID=${COMMIT_ID} -X github.com/minio/minio/cmd.GOPATH=${WRKSRC} -s -w' -o ${WRKSRC}/bin/minio
do-install:
diff --git a/www/uchiwa/Makefile b/www/uchiwa/Makefile
index 6d2a7588edc7..8d05d631d378 100644
--- a/www/uchiwa/Makefile
+++ b/www/uchiwa/Makefile
@@ -56,7 +56,7 @@ post-extract:
.endfor
do-build:
- @cd ${WRKSRC}/src/github.com/sensu && ${SETENV} GOPATH=${WRKSRC} go install ./...
+ @cd ${WRKSRC}/src/github.com/sensu && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install ./...
do-install:
${MKDIR} ${STAGEDIR}${UCHIWA_LOGDIR} \