aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/nmap/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 820e26ffb6ca..c3b20bc1ae9d 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -21,6 +21,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
.if !defined(MASTERDIR)
USES= tar:bzip2 gmake cpe
+
+# XXX limit results if we do a grep in the sources!
+EXTRACT_AFTER_ARGS= --exclude ${DISTNAME}/mswin32 \
+ --no-same-owner --no-same-permissions
+
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
@@ -54,10 +59,6 @@ CONFIGURE_ARGS+=--without-localdirs \
.include <bsd.port.options.mk>
-# XXX limit results if we do a grep in the sources!
-post-extract:
- @${RM} -r ${WRKSRC}/mswin32
-
.if exists(/usr/lib/libibverbs.a)
# Link with libibverbs is needed by static libpcap
post-patch-PCAP-on: