aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/efax-gtk/Makefile3
-rw-r--r--comms/minicom/Makefile2
-rw-r--r--comms/obexapp/Makefile2
-rw-r--r--comms/scmxx/Makefile3
-rw-r--r--converters/libiconv/Makefile5
-rw-r--r--lang/fpc/Makefile.units2
-rw-r--r--lang/gcc-aux/Makefile.common2
-rw-r--r--lang/ghc/bsd.cabal.mk2
-rw-r--r--lang/gnat-aux/Makefile.common2
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php52/Makefile.ext4
-rw-r--r--lang/php53/Makefile.ext4
-rw-r--r--multimedia/avidemux2/Makefile.common3
-rw-r--r--multimedia/mplayer/Makefile.shared2
-rw-r--r--print/ghostscript8/files/Makefile.drivers_post2
-rw-r--r--print/ghostscript9/files/Makefile.drivers_post2
-rw-r--r--x11-toolkits/gtkglext/Makefile3
-rw-r--r--x11-toolkits/open-motif/Makefile2
-rw-r--r--x11-toolkits/p5-Prima/Makefile2
-rw-r--r--x11-toolkits/ruby-wx/Makefile2
-rw-r--r--x11-toolkits/scintilla/Makefile2
-rw-r--r--x11-toolkits/termit/Makefile3
-rw-r--r--x11-toolkits/wxgtk26/Makefile8
-rw-r--r--x11-toolkits/wxgtk28/Makefile2
-rw-r--r--x11-toolkits/wxgtk29/Makefile2
25 files changed, 28 insertions, 42 deletions
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
index ef9838544e2d..59e547992b61 100644
--- a/comms/efax-gtk/Makefile
+++ b/comms/efax-gtk/Makefile
@@ -27,8 +27,7 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= ggv:${PORTSDIR}/print/ggv
-USES= pkgconfig
-USE_ICONV= yes
+USES= pkgconfig iconv
USE_GHOSTSCRIPT_RUN=yes
USE_GNOME= gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 1b208349cc28..8b26717b1725 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -14,7 +14,7 @@ OPTIONS_DEFINE= LRZSZ
OPTIONS_DEFAULT=LRZSZ
LRZSZ_DESC= Install X/Y/ZMODEM protocol handlers
-USE_ICONV= yes
+USES= iconv
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
diff --git a/comms/obexapp/Makefile b/comms/obexapp/Makefile
index 60b5993f6911..ca6572cb1c4c 100644
--- a/comms/obexapp/Makefile
+++ b/comms/obexapp/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= openobex:${PORTSDIR}/comms/openobex \
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_ICONV= yes
+USES= iconv
PLIST_FILES= bin/obexapp
MAKE_JOBS_SAFE= yes
diff --git a/comms/scmxx/Makefile b/comms/scmxx/Makefile
index 51d087f86887..a20402f9bbc3 100644
--- a/comms/scmxx/Makefile
+++ b/comms/scmxx/Makefile
@@ -12,8 +12,7 @@ COMMENT= Data exchange utility for Siemens mobile phones
USE_BZIP2= yes
USE_GMAKE= yes
-USE_ICONV= yes
-USES= gettext
+USES= gettext iconv
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index 58b1b143dd90..4ed0ac2be8a4 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -30,11 +30,6 @@ OPTIONS_DEFAULT=ENCODINGS
ENCODINGS_DESC= Include extra character sets
PATCHES_DESC= Apply patches to fix CP932, add EUCJP-MS
-.ifdef USE_ICONV
-.error USE_ICONV is defined as an environment variable, or in the arguments \
- to "make". Please unset it and restart the build.
-.endif
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MENCODINGS}
diff --git a/lang/fpc/Makefile.units b/lang/fpc/Makefile.units
index 3bedf197ec54..3d83adcbf317 100644
--- a/lang/fpc/Makefile.units
+++ b/lang/fpc/Makefile.units
@@ -139,7 +139,7 @@ USE_FIREBIRD= yes
.endif
.if ${PKGNAMESUFFIX} == "-iconvenc"
-USE_ICONV= yes
+USES+= iconv
.endif
.if ${PKGNAMESUFFIX} == "-ide"
diff --git a/lang/gcc-aux/Makefile.common b/lang/gcc-aux/Makefile.common
index 834ff8bdd45f..b491618c4ebc 100644
--- a/lang/gcc-aux/Makefile.common
+++ b/lang/gcc-aux/Makefile.common
@@ -9,7 +9,7 @@ ONLY_FOR_ARCHS= i386 amd64
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
USE_PERL5_BUILD= yes
ALL_TARGET= default
MAKE_JOBS_SAFE= yes
diff --git a/lang/ghc/bsd.cabal.mk b/lang/ghc/bsd.cabal.mk
index 39ef7366e4e0..88f9e56d460b 100644
--- a/lang/ghc/bsd.cabal.mk
+++ b/lang/ghc/bsd.cabal.mk
@@ -99,7 +99,7 @@ CONFIGURE_ARGS+= --with-c2hs=${C2HS_CMD}
.if defined(EXECUTABLE)
LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
-USE_ICONV= yes
+USES+= iconv
.endif
.if defined(USE_CABAL)
diff --git a/lang/gnat-aux/Makefile.common b/lang/gnat-aux/Makefile.common
index aeb9a22eaf87..17414119c29d 100644
--- a/lang/gnat-aux/Makefile.common
+++ b/lang/gnat-aux/Makefile.common
@@ -9,7 +9,7 @@ ONLY_FOR_ARCHS= i386 amd64
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
USE_PERL5_BUILD= yes
ALL_TARGET= default
MAKE_JOBS_SAFE= yes
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 52ad9db482df..24cb5a06dfa8 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -128,7 +128,7 @@ CONFIGURE_ARGS+=--enable-hash \
.if ${PHP_MODNAME} == "iconv"
CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
.endif
.if ${PHP_MODNAME} == "imap"
@@ -427,7 +427,7 @@ CONFIGURE_ARGS+=--with-xmlrpc \
--with-libxml-dir=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
diff --git a/lang/php52/Makefile.ext b/lang/php52/Makefile.ext
index 8822180a7b68..61238449d000 100644
--- a/lang/php52/Makefile.ext
+++ b/lang/php52/Makefile.ext
@@ -136,7 +136,7 @@ CONFIGURE_ARGS+=--enable-hash
CONFIGURE_ARGS+=--with-iconv=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
.endif
.if ${PHP_MODNAME} == "imap"
@@ -481,7 +481,7 @@ CONFIGURE_ARGS+=--with-xmlrpc \
--with-libxml-dir=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 5ab590dc81ae..506597091cbe 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -127,7 +127,7 @@ CONFIGURE_ARGS+=--enable-hash \
.if ${PHP_MODNAME} == "iconv"
CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
.endif
.if ${PHP_MODNAME} == "imap"
@@ -432,7 +432,7 @@ CONFIGURE_ARGS+=--with-xmlrpc \
--with-libxml-dir=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
diff --git a/multimedia/avidemux2/Makefile.common b/multimedia/avidemux2/Makefile.common
index 04898dcbee69..5d303b268aff 100644
--- a/multimedia/avidemux2/Makefile.common
+++ b/multimedia/avidemux2/Makefile.common
@@ -23,9 +23,8 @@ USE_GNOME= libxml2
USE_QT4= # empty
USE_GMAKE= yes
-USE_ICONV= yes
WANT_SDL= yes
-USES= cmake:outsource pkgconfig
+USES= cmake:outsource pkgconfig iconv
CMAKE_USE_PTHREAD=yes
CMAKE_ARGS+= -DTHREADS_HAVE_PTHREAD_ARG:STRING="${PTHREAD_LIBS}"
MAKE_JOBS_UNSAFE= yes
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index 8fa696c99106..38df00112178 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -22,9 +22,9 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
BUILD_DEPENDS= ${LOCALBASE}/bin/yasm:${PORTSDIR}/devel/yasm
+USES= iconv
USE_XZ= yes
USE_GMAKE= yes
-USE_ICONV= yes
USE_NCURSES= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
diff --git a/print/ghostscript8/files/Makefile.drivers_post b/print/ghostscript8/files/Makefile.drivers_post
index ee68a8ffaafd..0f3a0271232d 100644
--- a/print/ghostscript8/files/Makefile.drivers_post
+++ b/print/ghostscript8/files/Makefile.drivers_post
@@ -108,7 +108,7 @@ PORT_OPTIONS:= ${PORT_OPTIONS:NGS_${D}}
.endfor
.if defined(_ICONV_DEVS)
-USE_ICONV= yes
+USES+= iconv
CONFIGURE_ARGS+=--with-libiconv=gnu
EXTRALIBS+= -liconv
.else
diff --git a/print/ghostscript9/files/Makefile.drivers_post b/print/ghostscript9/files/Makefile.drivers_post
index 09230870cc8c..8e8c4edf2163 100644
--- a/print/ghostscript9/files/Makefile.drivers_post
+++ b/print/ghostscript9/files/Makefile.drivers_post
@@ -110,7 +110,7 @@ PORT_OPTIONS:= ${PORT_OPTIONS:NGS_${D}}
.endfor
.if defined(_ICONV_DEVS)
-USE_ICONV= yes
+USES+= iconv
CONFIGURE_ARGS+=--with-libiconv=gnu
EXTRALIBS+= -liconv
.else
diff --git a/x11-toolkits/gtkglext/Makefile b/x11-toolkits/gtkglext/Makefile
index 5db5e0c0d14e..5ca4d06a5f3a 100644
--- a/x11-toolkits/gtkglext/Makefile
+++ b/x11-toolkits/gtkglext/Makefile
@@ -26,13 +26,12 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
OPTIONS_DEFINE= DOCS
USE_BZIP2= yes
-USE_ICONV= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xmu xrandr xrender xt xxf86vm
USE_GL= glu
-USES= pathfix pkgconfig gettext
+USES= pathfix pkgconfig gettext iconv
USE_GNOME= gdkpixbuf2 gtk20
USE_LDCONFIG= yes
diff --git a/x11-toolkits/open-motif/Makefile b/x11-toolkits/open-motif/Makefile
index 57e09e278219..afc3181b5bd1 100644
--- a/x11-toolkits/open-motif/Makefile
+++ b/x11-toolkits/open-motif/Makefile
@@ -23,8 +23,8 @@ CONFLICTS= lesstif-[0-9]*
# WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WRKSRC= ${WRKDIR}/motif-${PORTVERSION}
+USES= iconv
USE_AUTOTOOLS= libtool autoconf:env automake:env
-USE_ICONV= yes
USE_GMAKE= yes
USE_XORG= xaw xbitmaps xft
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/p5-Prima/Makefile b/x11-toolkits/p5-Prima/Makefile
index 2e0b2b0cd01e..f566ed4b7722 100644
--- a/x11-toolkits/p5-Prima/Makefile
+++ b/x11-toolkits/p5-Prima/Makefile
@@ -136,7 +136,7 @@ MAN3= Prima.3 \
.if ${PORT_OPTIONS:MXFT}
USE_XORG+= xft
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
.else
CONFIGURE_ARGS+=WITH_ICONV=0
.endif
diff --git a/x11-toolkits/ruby-wx/Makefile b/x11-toolkits/ruby-wx/Makefile
index 72dcbc30963f..67c87c7527bd 100644
--- a/x11-toolkits/ruby-wx/Makefile
+++ b/x11-toolkits/ruby-wx/Makefile
@@ -17,7 +17,7 @@ COMMENT= Ruby bindings for wxWindows (aka wxWidgets)
DEPRECATED= Does not work with Ruby 1.9
EXPIRATION_DATE= 2013-05-02
-USE_ICONV= yes
+USES= iconv
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_WX= 2.4
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 6e951f8c0f5c..02077b5b9691 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -13,8 +13,8 @@ COMMENT= Full-featured free source code editing component for GTK+
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
+USES= iconv
USE_GMAKE= yes
-USE_ICONV= yes
MAKEFILE= makefile
USE_LDCONFIG= yes
USE_GNOME= gtk20
diff --git a/x11-toolkits/termit/Makefile b/x11-toolkits/termit/Makefile
index 92d99452a797..838dc28bf8d1 100644
--- a/x11-toolkits/termit/Makefile
+++ b/x11-toolkits/termit/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
xcb:${PORTSDIR}/x11/libxcb
USE_BZIP2= yes
-USES= cmake pkgconfig
-USE_ICONV= yes
+USES= cmake pkgconfig iconv
USE_LUA= yes
USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
xi xinerama xrandr xrender
diff --git a/x11-toolkits/wxgtk26/Makefile b/x11-toolkits/wxgtk26/Makefile
index fb376c6fd172..9159b71601ab 100644
--- a/x11-toolkits/wxgtk26/Makefile
+++ b/x11-toolkits/wxgtk26/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wxgtk26
-# Date created: June 27, 2004
-# Whom: fjoe@FreeBSD.ORG
-#
+# Created by: fjoe@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= wx
PORTVERSION= 2.6.4
@@ -22,12 +18,12 @@ LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png\
expat.6:${PORTSDIR}/textproc/expat2\
mspack.1:${PORTSDIR}/archivers/libmspack
+USES= iconv
USE_BZIP2= yes
USE_XORG= x11 sm xxf86vm xinerama
USE_GL= glu
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-USE_ICONV= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libpng=sys\
diff --git a/x11-toolkits/wxgtk28/Makefile b/x11-toolkits/wxgtk28/Makefile
index 9519d4b33039..f6e4aa469b1c 100644
--- a/x11-toolkits/wxgtk28/Makefile
+++ b/x11-toolkits/wxgtk28/Makefile
@@ -17,12 +17,12 @@ LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png\
tiff.4:${PORTSDIR}/graphics/tiff\
expat.6:${PORTSDIR}/textproc/expat2
+USES= iconv
USE_BZIP2= yes
USE_XORG= x11 sm xxf86vm xinerama
USE_GL= glu
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-USE_ICONV= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libpng=sys\
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
index b6dda7a7d70d..a7e9d2981f84 100644
--- a/x11-toolkits/wxgtk29/Makefile
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -19,13 +19,13 @@ LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png\
inotify.0:${PORTSDIR}/devel/libinotify\
webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
+USES+= iconv
USE_BZIP2= yes
USE_GCC= any
USE_XORG= x11 sm xxf86vm xinerama
USE_GL= glu
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-USE_ICONV= yes
USE_GNOME= gtk20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes