aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/3proxy/Makefile11
-rw-r--r--net/3proxy/distinfo4
-rw-r--r--net/3proxy/files/patch-Makefile.unix8
-rw-r--r--net/3proxy/files/patch-cfg_3proxy.cfg.sample17
-rw-r--r--net/3proxy/files/patch-man36
-rw-r--r--net/3proxy/pkg-plist14
6 files changed, 55 insertions, 35 deletions
diff --git a/net/3proxy/Makefile b/net/3proxy/Makefile
index 15494ebe06ff..37e3d63c8f1f 100644
--- a/net/3proxy/Makefile
+++ b/net/3proxy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= 3proxy
-PORTVERSION= 0.8.11
+PORTVERSION= 0.8.12
CATEGORIES= net
MAINTAINER= timp87@gmail.com
@@ -13,26 +13,31 @@ LICENSE_COMB= dual
OPTIONS_DEFINE= DOCS
+3PROXY_LOGDIR= /var/log/${PORTNAME}
+
MAKEFILE= Makefile.unix
-USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
USE_RC_SUBR= 3proxy
USE_GITHUB= yes
GH_ACCOUNT= z3APA3A
+PLIST_SUB= PORTNAME=${PORTNAME} \
+ 3PROXY_LOGDIR=${3PROXY_LOGDIR}
PORTDOCS= README
post-patch:
@${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|%%3PROXY_LOGDIR%%|${3PROXY_LOGDIR}|' ${WRKSRC}/cfg/3proxy.cfg.sample
post-build:
${MV} ${WRKSRC}/src/proxy ${WRKSRC}/src/httppr
${MV} ${WRKSRC}/man/proxy.8 ${WRKSRC}/man/httppr.8
do-install:
+ @${MKDIR} ${STAGEDIR}/${3PROXY_LOGDIR}
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/
cd ${WRKSRC}/src/ && ${INSTALL_PROGRAM} 3proxy dighosts ftppr icqpr mycrypt pop3p httppr smtpp socks tcppm udppm ${STAGEDIR}${PREFIX}/bin/
cd ${WRKSRC}/cfg/ && ${INSTALL_DATA} 3proxy.cfg.sample ${STAGEDIR}${PREFIX}/etc/
- cd ${WRKSRC}/src/ && ${INSTALL_LIB} PCREPlugin.so StringsPlugin.so TrafficPlugin.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/
+ cd ${WRKSRC}/src/ && ${INSTALL_LIB} PCREPlugin.so StringsPlugin.so TrafficPlugin.so pamauth.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/
cd ${WRKSRC}/man/ && ${INSTALL_MAN} 3proxy.cfg.3 ${STAGEDIR}${PREFIX}/man/man3/
cd ${WRKSRC}/man/ && ${INSTALL_MAN} 3proxy.8 ftppr.8 pop3p.8 httppr.8 socks.8 tcppm.8 udppm.8 ${STAGEDIR}${PREFIX}/man/man8/
diff --git a/net/3proxy/distinfo b/net/3proxy/distinfo
index 7a42ad6feaed..e2ce737568d1 100644
--- a/net/3proxy/distinfo
+++ b/net/3proxy/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1498592146
-SHA256 (z3APA3A-3proxy-0.8.11_GH0.tar.gz) = fc4295e1a462baa61977fcc21747db7861c4e3d0dcca86cbaa3e06017e5c66c9
-SIZE (z3APA3A-3proxy-0.8.11_GH0.tar.gz) = 497117
+SHA256 (z3APA3A-3proxy-0.8.12_GH0.tar.gz) = c2ad3798b4f0df06cfcc7b49f658304e451d60e4834e2705ef83ddb85a03f849
+SIZE (z3APA3A-3proxy-0.8.12_GH0.tar.gz) = 528990
diff --git a/net/3proxy/files/patch-Makefile.unix b/net/3proxy/files/patch-Makefile.unix
index 52b7d64f792d..61792ec201fd 100644
--- a/net/3proxy/files/patch-Makefile.unix
+++ b/net/3proxy/files/patch-Makefile.unix
@@ -1,4 +1,4 @@
---- Makefile.unix.orig 2017-10-19 14:54:31 UTC
+--- Makefile.unix.orig 2018-04-18 19:48:45 UTC
+++ Makefile.unix
@@ -8,18 +8,18 @@
# library support. Add -DSAFESQL for poorely written ODBC library / drivers.
@@ -8,13 +8,13 @@
+CC ?= gcc
# you may need -L/usr/pkg/lib for older NetBSD versions
--CFLAGS = -g -O2 -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
+-CFLAGS = -g -O2 -fno-strict-aliasing -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
+CFLAGS = -c -O2 -pipe -fstack-protector -fno-strict-aliasing -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
COUT = -o
-LN = gcc
--LDFLAGS = -O2 -pthread
+-LDFLAGS = -O2 -fno-strict-aliasing -pthread
+LN ?= ${CC}
-+LDFLAGS = -pthread
++LDFLAGS = -fno-strict-aliasing -pthread
# -lpthreads may be reuqired on some platforms instead of -pthreads
# -ldl or -lld may be required for some platforms
DCFLAGS = -fpic
diff --git a/net/3proxy/files/patch-cfg_3proxy.cfg.sample b/net/3proxy/files/patch-cfg_3proxy.cfg.sample
index 9496239afbe5..448f2518a3cf 100644
--- a/net/3proxy/files/patch-cfg_3proxy.cfg.sample
+++ b/net/3proxy/files/patch-cfg_3proxy.cfg.sample
@@ -1,4 +1,4 @@
---- cfg/3proxy.cfg.sample.orig 2017-10-20 15:02:38 UTC
+--- cfg/3proxy.cfg.sample.orig 2018-04-18 19:48:45 UTC
+++ cfg/3proxy.cfg.sample
@@ -30,15 +30,15 @@ users 3APA3A:CL:3apa3a "test:CR:$1$qwer$
# this example shows you how to include passwd file. For included files
@@ -15,8 +15,21 @@
-#log /var/log/3proxy/log D
-log c:\3proxy\logs\3proxy.log D
-+log /var/log/3proxy/log D
++log %%3PROXY_LOGDIR%%/log D
+#log c:\3proxy\logs\3proxy.log D
# log allows to specify log file location and rotation, D means logfile
# is created daily
+@@ -72,10 +72,10 @@ log c:\3proxy\logs\3proxy.log D
+ logformat "- +_L%t.%. %N.%p %E %U %C:%c %R:%r %O %I %h %T"
+
+
+-#archiver gz /bin/gzip %F
++archiver gz /usr/bin/gzip %F
+ #archiver zip zip -m -qq %A %F
+ #archiver zip pkzipc -add -silent -move %A %F
+-archiver rar rar a -df -inul %A %F
++#archiver rar rar a -df -inul %A %F
+ # if archiver specified log file will be compressed after closing.
+ # you should specify extension, path to archiver and command line, %A will be
+ # substituted with archive file name, %f - with original file name.
diff --git a/net/3proxy/files/patch-man b/net/3proxy/files/patch-man
index 638fe3f6fa58..36104f8ddce6 100644
--- a/net/3proxy/files/patch-man
+++ b/net/3proxy/files/patch-man
@@ -1,4 +1,4 @@
---- man/3proxy.8.orig 2016-01-19 22:20:05 UTC
+--- man/3proxy.8.orig 2018-04-18 19:48:45 UTC
+++ man/3proxy.8
@@ -26,7 +26,7 @@ It can establish multiple
gateways with HTTP and HTTPS proxy with FTP over HTTP support, SOCKS v4,
@@ -35,7 +35,7 @@
kill(1), syslogd(8),
.br
http://3proxy.ru/
---- man/3proxy.cfg.3.orig 2016-01-19 22:20:05 UTC
+--- man/3proxy.cfg.3.orig 2018-04-18 19:48:45 UTC
+++ man/3proxy.cfg.3
@@ -153,7 +153,7 @@ listen on given local HOST:port for inco
connect to given remote HOST:port instead of listening local connection on -p or default port. Can be used with another 3proxy service running -R option for connect back functionality. Most commonly used with proxy or socks. HOST can be given as IP or hostname, useful in case of dynamic DNS.
@@ -46,7 +46,7 @@
.BR socks (8)
.BR pop3p (8)
.BR tcppm (8)
-@@ -927,7 +927,7 @@ corruption and/or Content-Length chaging
+@@ -954,7 +954,7 @@ corruption and/or Content-Length chaging
Report all bugs to
.BR 3proxy@3proxy.ru
.SH SEE ALSO
@@ -55,9 +55,9 @@
.br
http://3proxy.ru/
.SH TRIVIA
---- man/ftppr.8.orig 2016-01-19 22:20:05 UTC
+--- man/ftppr.8.orig 2018-04-18 19:48:45 UTC
+++ man/ftppr.8
-@@ -75,7 +75,7 @@ Only cleartext authentication is current
+@@ -79,7 +79,7 @@ Only cleartext authentication is current
Report all bugs to
.BR 3proxy@3proxy.ru
.SH SEE ALSO
@@ -66,9 +66,9 @@
.br
http://3proxy.ru/
.SH AUTHORS
---- man/icqpr.8.orig 2016-01-19 22:20:05 UTC
+--- man/icqpr.8.orig 2018-04-18 19:48:45 UTC
+++ man/icqpr.8
-@@ -68,7 +68,7 @@ as a destination in client application.
+@@ -72,7 +72,7 @@ as a destination in client application.
Report all bugs to
.BR 3proxy@3proxy.ru
.SH SEE ALSO
@@ -77,9 +77,9 @@
.br
http://3proxy.ru/
.SH AUTHORS
---- man/pop3p.8.orig 2016-01-19 22:20:05 UTC
+--- man/pop3p.8.orig 2018-04-18 19:48:45 UTC
+++ man/pop3p.8
-@@ -71,7 +71,7 @@ we know which server to connect.
+@@ -75,7 +75,7 @@ we know which server to connect.
Report all bugs to
.BR 3proxy@3proxy.ru
.SH SEE ALSO
@@ -88,7 +88,7 @@
.br
http://3proxy.ru/
.SH AUTHORS
---- man/proxy.8.orig 2016-01-19 22:20:05 UTC
+--- man/proxy.8.orig 2018-04-18 19:48:45 UTC
+++ man/proxy.8
@@ -1,15 +1,15 @@
-.TH proxy "8" "January 2016" "3proxy 0.8" "Universal proxy server"
@@ -110,9 +110,9 @@
is HTTP gateway service with HTTPS and FTP over HTTPS support.
.SH OPTIONS
.TP
---- man/smtpp.8.orig 2016-01-19 22:20:05 UTC
+--- man/smtpp.8.orig 2018-04-18 19:48:45 UTC
+++ man/smtpp.8
-@@ -72,7 +72,7 @@ we know which server to connect.
+@@ -76,7 +76,7 @@ we know which server to connect.
Report all bugs to
.BR 3proxy@3proxy.ru
.SH SEE ALSO
@@ -121,9 +121,9 @@
.br
http://3proxy.ru/
.SH AUTHORS
---- man/socks.8.orig 2016-01-19 22:20:05 UTC
+--- man/socks.8.orig 2018-04-18 19:48:45 UTC
+++ man/socks.8
-@@ -67,7 +67,7 @@ instead.
+@@ -71,7 +71,7 @@ instead.
Report all bugs to
.BR 3proxy@3proxy.ru
.SH SEE ALSO
@@ -132,9 +132,9 @@
.br
http://3proxy.ru/
.SH AUTHORS
---- man/tcppm.8.orig 2016-01-19 22:20:05 UTC
+--- man/tcppm.8.orig 2018-04-18 19:48:45 UTC
+++ man/tcppm.8
-@@ -61,7 +61,7 @@ as a destination in client application.
+@@ -65,7 +65,7 @@ as a destination in client application.
Report all bugs to
.BR 3proxy@3proxy.ru
.SH SEE ALSO
@@ -143,9 +143,9 @@
.br
http://3proxy.ru/
.SH AUTHORS
---- man/udppm.8.orig 2016-01-19 22:20:05 UTC
+--- man/udppm.8.orig 2018-04-18 19:48:45 UTC
+++ man/udppm.8
-@@ -67,7 +67,7 @@ as a destination in client application.
+@@ -71,7 +71,7 @@ as a destination in client application.
Report all bugs to
.BR 3proxy@3proxy.ru
.SH SEE ALSO
diff --git a/net/3proxy/pkg-plist b/net/3proxy/pkg-plist
index 253f4fab5b47..452a025e420f 100644
--- a/net/3proxy/pkg-plist
+++ b/net/3proxy/pkg-plist
@@ -1,23 +1,25 @@
bin/3proxy
bin/dighosts
bin/ftppr
+bin/httppr
bin/icqpr
bin/mycrypt
bin/pop3p
-bin/httppr
bin/smtpp
bin/socks
bin/tcppm
bin/udppm
-@sample etc/3proxy.cfg.sample
-lib/3proxy/PCREPlugin.so
-lib/3proxy/StringsPlugin.so
-lib/3proxy/TrafficPlugin.so
+lib/%%PORTNAME%%/PCREPlugin.so
+lib/%%PORTNAME%%/StringsPlugin.so
+lib/%%PORTNAME%%/TrafficPlugin.so
+lib/%%PORTNAME%%/pamauth.so
man/man3/3proxy.cfg.3.gz
man/man8/3proxy.8.gz
man/man8/ftppr.8.gz
-man/man8/pop3p.8.gz
man/man8/httppr.8.gz
+man/man8/pop3p.8.gz
man/man8/socks.8.gz
man/man8/tcppm.8.gz
man/man8/udppm.8.gz
+@dir(,,755) %%3PROXY_LOGDIR%%
+@sample etc/3proxy.cfg.sample