aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-econometrics/Makefile28
-rw-r--r--math/octave-forge-econometrics/distinfo3
-rw-r--r--math/octave-forge-econometrics/pkg-descr10
-rw-r--r--math/octave-forge/Makefile4
6 files changed, 44 insertions, 3 deletions
diff --git a/MOVED b/MOVED
index 41f7156adaa3..e6efdb796fce 100644
--- a/MOVED
+++ b/MOVED
@@ -12921,7 +12921,6 @@ irc/irssi-otr||2019-09-05|Has expired: Broken for more than 6 months
mail/p5-Mail-ClamAV||2019-09-05|Has expired: Broken for more than 6 months
mail/qmail-ldap||2019-09-05|Has expired: Broken for more than 6 months
math/fityk||2019-09-05|Has expired: Broken for more than 6 months
-math/octave-forge-econometrics||2019-09-05|Has expired: Broken for more than 6 months
math/octave-forge-fits||2019-09-05|Has expired: Broken for more than 6 months
math/octave-forge-linear-algebra||2019-09-05|Has expired: Broken for more than 6 months
math/octave-forge-mechanics||2019-09-05|Has expired: Broken for more than 6 months
diff --git a/math/Makefile b/math/Makefile
index 370b1d1915f4..ff9bc4f6e018 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -407,6 +407,7 @@
SUBDIR += octave-forge-dicom
SUBDIR += octave-forge-divand
SUBDIR += octave-forge-doctest
+ SUBDIR += octave-forge-econometrics
SUBDIR += octave-forge-fenv
SUBDIR += octave-forge-financial
SUBDIR += octave-forge-fpl
diff --git a/math/octave-forge-econometrics/Makefile b/math/octave-forge-econometrics/Makefile
new file mode 100644
index 000000000000..0c8759abd404
--- /dev/null
+++ b/math/octave-forge-econometrics/Makefile
@@ -0,0 +1,28 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-econometrics
+PORTVERSION= 1.1.2
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/optim.tar.gz:math/octave-forge-optim
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-econometrics/distinfo b/math/octave-forge-econometrics/distinfo
new file mode 100644
index 000000000000..72ec80098f68
--- /dev/null
+++ b/math/octave-forge-econometrics/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1571526627
+SHA256 (octave-forge/econometrics-1.1.2.tar.gz) = e2cca501f6b16ba4f2d5b4374dc3c80bd164472a30291dfd51947990263a3deb
+SIZE (octave-forge/econometrics-1.1.2.tar.gz) = 29882
diff --git a/math/octave-forge-econometrics/pkg-descr b/math/octave-forge-econometrics/pkg-descr
new file mode 100644
index 000000000000..cd4ce9afee91
--- /dev/null
+++ b/math/octave-forge-econometrics/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is econometrics.
+
+ Econometrics functions including MLE and GMM based techniques.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge/Makefile b/math/octave-forge/Makefile
index 2206579f6ef8..44f1bf0f441b 100644
--- a/math/octave-forge/Makefile
+++ b/math/octave-forge/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave-forge
PORTVERSION= 20180409
-PORTREVISION= 20
+PORTREVISION= 21
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
@@ -28,7 +28,7 @@ OPTIONS_DEFINE= ACTUARIAL BENCHMARK BIM BIOINFO BSLTL CGI \
STRUCT SYMBAND SYMBOLIC TCL_OCTAVE TISEAN TSA VIDEO \
ZENITY ZEROMQ
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NDATA_SMOOTHING:NECONOMETRICS:NFITS:NLINEAR_ALGEBRA:NMECHANICS:NPARALLEL:NSTRINGS:NTISEAN:NVIDEO}
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NDATA_SMOOTHING:NFITS:NLINEAR_ALGEBRA:NMECHANICS:NPARALLEL:NSTRINGS:NTISEAN:NVIDEO}
TARBALLS_DIR= ${LOCALBASE}/share/octave/tarballs