aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/noto-sans-cherokee/Makefile28
-rw-r--r--x11-fonts/noto-sans-cherokee/distinfo3
-rw-r--r--x11-fonts/noto-sans-cherokee/pkg-descr12
-rw-r--r--x11-fonts/noto-sans-cherokee/pkg-plist9
5 files changed, 53 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 075bc271e0bf..a37c33e3d318 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -200,6 +200,7 @@
SUBDIR += noto-sans-basic
SUBDIR += noto-sans-bengali
SUBDIR += noto-sans-cham
+ SUBDIR += noto-sans-cherokee
SUBDIR += noto-sans-hk
SUBDIR += noto-sans-jp
SUBDIR += noto-sans-kr
diff --git a/x11-fonts/noto-sans-cherokee/Makefile b/x11-fonts/noto-sans-cherokee/Makefile
new file mode 100644
index 000000000000..8d52e3d5149e
--- /dev/null
+++ b/x11-fonts/noto-sans-cherokee/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= noto
+PORTVERSION= 2.001
+CATEGORIES= x11-fonts
+MASTER_SITES= https://github.com/notofonts/cherokee/releases/download/NotoSansCherokee-v${PORTVERSION}/
+PKGNAMESUFFIX= -sans-cherokee
+DISTNAME= NotoSansCherokee-v${PORTVERSION}
+DIST_SUBDIR= Noto
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Noto Sans Cherokee
+WWW= https://fonts.google.com/noto \
+ https://notofonts.github.io/ \
+ https://github.com/notofonts/cherokee
+
+LICENSE= OFL11
+#LICENSE_FILE= ${WRKSRC}/OFL.txt
+
+USES= fonts zip
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NotoSansCherokee/hinted/ttf/*.ttf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/noto-sans-cherokee/distinfo b/x11-fonts/noto-sans-cherokee/distinfo
new file mode 100644
index 000000000000..5f3315326cb7
--- /dev/null
+++ b/x11-fonts/noto-sans-cherokee/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1710676069
+SHA256 (Noto/NotoSansCherokee-v2.001.zip) = 986b7fcf5c4cef9a7329aad8aea93d5c1b974e465eb7514f39517cace043a58d
+SIZE (Noto/NotoSansCherokee-v2.001.zip) = 3800204
diff --git a/x11-fonts/noto-sans-cherokee/pkg-descr b/x11-fonts/noto-sans-cherokee/pkg-descr
new file mode 100644
index 000000000000..24adffa2d959
--- /dev/null
+++ b/x11-fonts/noto-sans-cherokee/pkg-descr
@@ -0,0 +1,12 @@
+When text is rendered by a computer, sometimes characters are displayed as
+"tofu". They are little boxes to indicate your device doesn't have a font to
+display the text.
+
+Google has been developing a font family called Noto, which aims to support all
+languages with a harmonious look and feel. Noto is Google's answer to tofu. The
+name noto is to convey the idea that Google's goal is to see no more "tofu".
+Noto has multiple styles and weights, and is freely available to all. The
+comprehensive set of fonts and tools used in our development is available in our
+GitHub repositories.
+
+This port provides the fonts set of Noto Sans Cherokee.
diff --git a/x11-fonts/noto-sans-cherokee/pkg-plist b/x11-fonts/noto-sans-cherokee/pkg-plist
new file mode 100644
index 000000000000..3bf5424b0ba3
--- /dev/null
+++ b/x11-fonts/noto-sans-cherokee/pkg-plist
@@ -0,0 +1,9 @@
+%%FONTSDIR%%/NotoSansCherokee-Black.ttf
+%%FONTSDIR%%/NotoSansCherokee-Bold.ttf
+%%FONTSDIR%%/NotoSansCherokee-ExtraBold.ttf
+%%FONTSDIR%%/NotoSansCherokee-ExtraLight.ttf
+%%FONTSDIR%%/NotoSansCherokee-Light.ttf
+%%FONTSDIR%%/NotoSansCherokee-Medium.ttf
+%%FONTSDIR%%/NotoSansCherokee-Regular.ttf
+%%FONTSDIR%%/NotoSansCherokee-SemiBold.ttf
+%%FONTSDIR%%/NotoSansCherokee-Thin.ttf