aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/retcl/Makefile28
-rw-r--r--databases/retcl/distinfo3
-rw-r--r--databases/retcl/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index eedafe9a0e5f..1fab01434216 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -845,6 +845,7 @@
SUBDIR += redigo
SUBDIR += redis
SUBDIR += redis-devel
+ SUBDIR += retcl
SUBDIR += riak
SUBDIR += riak2
SUBDIR += rocksdb
diff --git a/databases/retcl/Makefile b/databases/retcl/Makefile
new file mode 100644
index 000000000000..8288aecb70b9
--- /dev/null
+++ b/databases/retcl/Makefile
@@ -0,0 +1,28 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= retcl
+PORTVERSION= 0.2.0
+CATEGORIES= databases
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Tcl client library for Redis
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= tcl:run
+USE_GITHUB= yes
+GH_ACCOUNT= gahr
+
+NO_BUILD= yes
+
+LIBDIR= ${TCL_LIBDIR:S/${LOCALBASE}/${PREFIX}/}
+PLIST_FILES= ${LIBDIR}/${PORTNAME}-${DISTVERSION}.tm
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${LIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.tm \
+ ${STAGEDIR}${LIBDIR}/${PORTNAME}-${DISTVERSION}.tm
+
+.include <bsd.port.mk>
diff --git a/databases/retcl/distinfo b/databases/retcl/distinfo
new file mode 100644
index 000000000000..7e4a9041093e
--- /dev/null
+++ b/databases/retcl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1494409318
+SHA256 (gahr-retcl-0.2.0_GH0.tar.gz) = 2e2d1f7c90b14c92cb66b66bbf289568cd3f03daef907c3ae8403c74e728aa8d
+SIZE (gahr-retcl-0.2.0_GH0.tar.gz) = 11467
diff --git a/databases/retcl/pkg-descr b/databases/retcl/pkg-descr
new file mode 100644
index 000000000000..a97f7c277687
--- /dev/null
+++ b/databases/retcl/pkg-descr
@@ -0,0 +1,5 @@
+Retcl is an event-driven, object-oriented, Redis client library targetting the
+Tcl scripting language. The library consists of a single Tcl Module file, which
+makes it extremely easy to deploy or integrate into existing projects.
+
+WWW: https://github.com/gahr/retcl