aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/proftpd-devel/Makefile4
-rw-r--r--ftp/proftpd/Makefile4
-rw-r--r--mail/claws-mail-clamav/Makefile6
-rw-r--r--mail/p5-Mail-ClamAV/Makefile4
-rw-r--r--mail/qsheff/Makefile2
-rw-r--r--mail/simscan/Makefile1
-rw-r--r--security/clamassassin/Makefile2
-rw-r--r--security/clamcour/Makefile4
-rw-r--r--security/klamav/Makefile4
-rw-r--r--security/p5-File-Scan-ClamAV/Makefile2
-rw-r--r--security/py-clamav/Makefile6
-rw-r--r--security/squidclam/Makefile4
-rw-r--r--www/c-icap/Makefile6
-rw-r--r--www/dansguardian-devel/Makefile4
-rw-r--r--www/gurlchecker/Makefile6
-rw-r--r--www/havp/Makefile5
-rw-r--r--www/mod_clamav/Makefile4
17 files changed, 43 insertions, 25 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index 149f226246c7..08782b5a904c 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -224,7 +224,7 @@ DISTFILES+= mod_clamav-0.5.1.tar.bz2:clam
EXTRACT_ONLY+= mod_clamav-0.5.1.tar.bz2
USE_CLAMAV= yes
MODULES:=${MODULES}:mod_clamav
-LIB_DEPENDS+= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS+= clamav.4:${PORTSDIR}/security/clamav
INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
.endif
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 149f226246c7..08782b5a904c 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -224,7 +224,7 @@ DISTFILES+= mod_clamav-0.5.1.tar.bz2:clam
EXTRACT_ONLY+= mod_clamav-0.5.1.tar.bz2
USE_CLAMAV= yes
MODULES:=${MODULES}:mod_clamav
-LIB_DEPENDS+= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS+= clamav.4:${PORTSDIR}/security/clamav
INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
.endif
diff --git a/mail/claws-mail-clamav/Makefile b/mail/claws-mail-clamav/Makefile
index c05bdadd6b6c..2ca4339621c1 100644
--- a/mail/claws-mail-clamav/Makefile
+++ b/mail/claws-mail-clamav/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clamav
PORTVERSION= 3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
PKGNAMEPREFIX= claws-mail-
@@ -17,7 +17,7 @@ COMMENT= Clamav plugin for claws-mail
BUILD_DEPENDS= claws-mail>=3.3.1:${PORTSDIR}/mail/claws-mail
RUN_DEPENDS= claws-mail>=3.3.1:${PORTSDIR}/mail/claws-mail
-LIB_DEPENDS= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS= clamav.4:${PORTSDIR}/security/clamav
USE_GMAKE= yes
USE_XORG= x11
@@ -30,4 +30,6 @@ PLIST_FILES= lib/claws-mail/plugins/clamav.a \
lib/claws-mail/plugins/clamav.la \
lib/claws-mail/plugins/clamav.so
+BROKEN= Doesn't build with clamav-0.93
+
.include <bsd.port.mk>
diff --git a/mail/p5-Mail-ClamAV/Makefile b/mail/p5-Mail-ClamAV/Makefile
index b2c3cfb468ab..35ffaedd0170 100644
--- a/mail/p5-Mail-ClamAV/Makefile
+++ b/mail/p5-Mail-ClamAV/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Mail-ClamAV
PORTVERSION= 0.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Mail
@@ -27,6 +27,8 @@ PERL_CONFIGURE= yes
MAN3= Mail::ClamAV.3
+BROKEN= Doesn't build with clamav-0.93
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/mail/qsheff/Makefile b/mail/qsheff/Makefile
index e53914d9e54e..461678559137 100644
--- a/mail/qsheff/Makefile
+++ b/mail/qsheff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qsheff-II
PORTVERSION= 2.1.r3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://www.enderunix.org/qsheff/ \
SF/qsheff
diff --git a/mail/simscan/Makefile b/mail/simscan/Makefile
index db20b7b89a77..65ac71e63a43 100644
--- a/mail/simscan/Makefile
+++ b/mail/simscan/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simscan
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
diff --git a/security/clamassassin/Makefile b/security/clamassassin/Makefile
index 65bb6a23ff37..a4924a2df56f 100644
--- a/security/clamassassin/Makefile
+++ b/security/clamassassin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clamassassin
PORTVERSION= 1.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://jameslick.com/clamassassin/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
diff --git a/security/clamcour/Makefile b/security/clamcour/Makefile
index 31e2cedf2073..96fcb038c9fa 100644
--- a/security/clamcour/Makefile
+++ b/security/clamcour/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clamcour
PORTVERSION= 0.3.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security mail
MASTER_SITES= http://www.becrux.com/pages/projects/clamcour/
@@ -15,7 +15,7 @@ MAINTAINER= bsd@dino.sk
COMMENT= ClamAV courier filter
BUILD_DEPENDS= courier-config:${PORTSDIR}/mail/courier
-LIB_DEPENDS= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS= clamav.4:${PORTSDIR}/security/clamav
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/security/klamav/Makefile b/security/klamav/Makefile
index a171973f9d0e..798053fe174e 100644
--- a/security/klamav/Makefile
+++ b/security/klamav/Makefile
@@ -7,7 +7,7 @@
PORTNAME= klamav
PORTVERSION= 0.42
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= klamav
@@ -39,6 +39,8 @@ CONFIGURE_ARGS+=--with-qt-dir=${QT_PREFIX} \
USE_KDELIBS_VER= 3
+BROKEN= Doesn't build with clamav-0.93
+
.include <bsd.port.pre.mk>
pre-configure:
diff --git a/security/p5-File-Scan-ClamAV/Makefile b/security/p5-File-Scan-ClamAV/Makefile
index c9ab8b88ad47..8373aec7f430 100644
--- a/security/p5-File-Scan-ClamAV/Makefile
+++ b/security/p5-File-Scan-ClamAV/Makefile
@@ -7,7 +7,7 @@
PORTNAME= File-Scan-ClamAV
PORTVERSION= 1.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= File
diff --git a/security/py-clamav/Makefile b/security/py-clamav/Makefile
index 25158f8b5d1f..4d472b4ad259 100644
--- a/security/py-clamav/Makefile
+++ b/security/py-clamav/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security python
MASTER_SITES= http://xael.org/norman/python/pyclamav/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= mnag@FreeBSD.org
COMMENT= A python binding to libclamav written in C
-LIB_DEPENDS= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS= clamav.4:${PORTSDIR}/security/clamav
DIST_SUBDIR= python
USE_PYTHON= yes
@@ -30,6 +30,8 @@ EXAMPLESDIR?= ${PREFIX}/share/examples/py-${PORTNAME}
PORTDOCS= *
+BROKEN= Doesn't build with clamav-0.93
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/security/squidclam/Makefile b/security/squidclam/Makefile
index a6e69d96b314..52d18a203680 100644
--- a/security/squidclam/Makefile
+++ b/security/squidclam/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squidclam
PORTVERSION= 0.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -31,6 +31,8 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/squidclam %%EXAMPLESDIR%%/squidclam.conf
PLIST_DIRS= %%EXAMPLESDIR%%
+BROKEN= Doesn't build with clamav-0.93
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index 7c80b75371cc..feb3343636ab 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= c-icap
PORTVERSION= 030606
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
@@ -32,6 +32,8 @@ OPTIONS= CLAMAV "Build with srv_clamav service" on \
IPV6 "Enable IPv6 support" off
# PERL "With Perl support" off
+BROKEN= Doesn't build with clamav-0.93
+
.include <bsd.port.pre.mk>
# Perl support not ready yet. Try to contact author or hack it by yourself.
@@ -55,7 +57,7 @@ CONFIGURE_ARGS+= --without-perl
.endif
.if !defined(WITHOUT_CLAMAV)
-LIB_DEPENDS+= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS+= clamav.4:${PORTSDIR}/security/clamav
PLIST_SUB+= CLAMAV=""
CONFIGURE_ARGS+= --with-clamav
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index 2bcf67957973..8d0d3b2cacbd 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dansguardian
PORTVERSION= 2.9.9.3
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= # empty, see below
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -75,7 +75,7 @@ PLIST_SUB+= CLISCANCONF="@comment "
.if defined(WITH_DG_CLAMAV)
CONFIGURE_ARGS+= --enable-clamav
-LIB_DEPENDS+= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS+= clamav.4:${PORTSDIR}/security/clamav
PLIST_SUB+= CLAMAVCONF=""
.else
PLIST_SUB+= CLAMAVCONF="@comment "
diff --git a/www/gurlchecker/Makefile b/www/gurlchecker/Makefile
index 96b94478ae39..7d6ea3b2d126 100644
--- a/www/gurlchecker/Makefile
+++ b/www/gurlchecker/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gurlchecker
PORTVERSION= 0.10.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www gnome
MASTER_SITES= http://labs.libre-entreprise.org/frs/download.php/%SUBDIR%/
MASTER_SITE_SUBDIR= 547
@@ -29,6 +29,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+BROKEN= Doesn't build with clamav-0.93
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_NLS)
@@ -51,7 +53,7 @@ CONFIGURE_ARGS+= --disable-tidy
.endif
.if defined(WITH_CLAMAV)
-LIB_DEPENDS+= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS+= clamav.4:${PORTSDIR}/security/clamav
.else
CONFIGURE_ARGS+= --disable-clamav
.endif
diff --git a/www/havp/Makefile b/www/havp/Makefile
index 1f23b237e604..3b499481ca9f 100644
--- a/www/havp/Makefile
+++ b/www/havp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= havp
PORTVERSION= 0.87
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.server-side.de/download/ \
http://bio3k.softboard.ru/uploads/arch/
@@ -14,7 +15,7 @@ MASTER_SITES= http://www.server-side.de/download/ \
MAINTAINER= b3k@mail.ru
COMMENT= HTTP Antivirus Proxy
-LIB_DEPENDS= clamav.3:${PORTSDIR}/security/clamav
+LIB_DEPENDS= clamav.4:${PORTSDIR}/security/clamav
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -35,6 +36,8 @@ OPTIONS= SSL "Enable SSL proxying (not scanned, only forwarded!)" on \
CLAMAV "Enable libclamav support" on \
TROPHIE "Enable Trend Micro (Trophie) support" off
+BROKEN= Doesn't build with clamav-0.93
+
.include <bsd.port.pre.mk>
.if defined(WITH_SSL)
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index e6669ffb15b7..c5d5313dc727 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -7,14 +7,14 @@
PORTNAME= mod_clamav
PORTVERSION= 0.21
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www security
MASTER_SITES= http://software.othello.ch/mod_clamav/
MAINTAINER= tmueko@kommunity.net
COMMENT= Scans content delivered by the Apache2 proxy module for viruses
-LIB_DEPENDS+= clamav.3:${PORTSDIR}/${CLAMAV_PORT}
+LIB_DEPENDS+= clamav.4:${PORTSDIR}/${CLAMAV_PORT}
USE_AUTOTOOLS= libtool:15
USE_APACHE= YES